1 Reply Latest reply on Dec 5, 2013 3:37 PM by Tanveer Roowala

    need for installing slony 1.2 on RHEL 6.2 for BDA replication

    Tanveer Roowala

      We have a customer running BDA content managers on RHEL 5.8 , however the new satellite managers they are installing have RHEL 6.2 on them.

       

      Now turns out for replication using slony the slony versions need to be identical and given RHEL 5.8 content manager has slony 1.2 on it it was not sync'n with the RHEL 6.8 satellite manager running slony 2.1.

       

       

      However with RHEL 6 the default version of postgresql is 8.4 which is incompatible with slony 1.2 , so we uninstalled postgresql 8.4 and installed postgresql 8.1  (same as RHEL 5.8) and were then able to install Slony 1.2 on RHEL  6.2.

       

      But now the error we are getting is as follows

       

      #service megamesh status

       

      Can't load '/app/clarity/perl/lib/site_perl/5.10.0/i686-linux-thread-multi/auto/GridApp/Archive/Archive.so' for module GridApp::Archive: libz.so.1: cannot open shared object file: No such file or directory at /app/clarity/perl/lib/5.10.0/i686-linux-thread-multi/XSLoader.pm line 64.

      at /app/clarity/perl/lib/site_perl/5.10.0/i686-linux-thread-multi/GridApp/Archive.pm line 10

      Compilation failed in require.

      BEGIN failed--compilation aborted.

       

      Has anyone run into ta similar issue and was able to resolve this ?

       

      Is there a way possible to get Slony 1.2 running on RHEL 6.x ?

      Thanks