5 Replies Latest reply on Dec 2, 2013 12:04 PM by Bill Robinson

    Application server browse not working in "Infrastructure Management"

    Ali SIMON

      Hi all,

      first post here


      i'm setting up new Applications Servers BBSA82

      These are supposed to replace the old servers.



      My server is installed, i can log the SRP, but the "Infrastructure Management" is not working.


      When i try to expand "+Applications Servers" it somehow "freeze". It gives me the hourglass and won't do anything, until i finally close the window.

      Same behaviour if I go to "Application Server Launchers". I see my server hostname, I can select it, it shows port 9700, 9701, 9702, are listening, but if I try to expand, it freeze the same way, not showing the <instance_name>.


      I don't have anything in the AppServerLauncher.log or the <instance_name>.log


      The database i connect to is the one currently used by the existing AppSrv.


      The bladelogic.keystore is not the same accross all servers. I know this is a problem(for ie, if I log to my old server, the new one is displayed with a red cross, app server launcher status not available), but I though it will be working if i log in to the new SRP instead of the old one.


      Any thoughts ?


      In advance thank you for your help


        • 1. Re: Application server brows not working in "Infrastructure Management"
          Bill Robinson

          can the new and old servers talk to each other on 9700-2 (not just that they are listening but there is no firewall blocking communication) ?


          how many instances of the appsrever are running on the new box ?

          • 2. Re: Application server brows not working in "Infrastructure Management"
            Ali SIMON

            Hello Bill,


            the old and new servers cannot talk to them on port 9700-2

            They're in different VLAN.

            New <-> New OK

            Old <-> Old OK

            New <-> Old NOK


            The server which has the console can talk to new servers on 9700-2 but not to old ones


            There are 2 old boxes and 4 new boxes with one instance of type 'config' on each (let appart 'job' servers)

            • 3. Re: Application server browse not working in "Infrastructure Management"
              Ali SIMON

              I have tried from the "old" console.
              It's the same behavior with that one.


              If I log to the SRP on the old servers, everything is working (except the launcher status is KO for new servers, since the keystroke is not the same)

              If I log to the SRP on one of the new servers, I can see the launcher status of the new servers, but If i try to expand it freeze.


              I've tried to run a wireshark on the Console server, but it gives nothing.


              What is the 'mechanism' behind this functionality ?

              • 4. Re: Application server browse not working in "Infrastructure Management"
                Ali SIMON

                Damn, it seems like it work but it take forever to display (almost 10 minutes)


                I can expand servers one by one and see the instance running on them.


                In my logs i get several messages of type :

                [02 Dec 2013 14:46:18,805] [Select-Client-Connections-Thread] [WARN] [::] [] Connection maps are out of sync. Synchronizing.

                [02 Dec 2013 14:46:18,805] [Select-Client-Connections-Thread] [INFO] [::] [] Connection disconnecting: id = 4810

                ..... and repeating

                I've tried to search for this here, but no luck


                Does this lead anywhere ?


                Any advices will be welcome.


                • 5. Re: Application server browse not working in "Infrastructure Management"
                  Bill Robinson

                  you connect w/ the gui to server A, when you try and look at infra mgr on server B, server A communicates to server B via ports 9700-2.  if that's not available, then you can't connect.  the new servers - they are in the same physical and network location as the existing database (we don't support a wan or otherwise slow connection between the appservers and db)  ?


                  since all the new servers can talk to each other here - what is the issue?  how long will you run the old servers?


                  additionally for the job sharing to work property the 'MinPort->MaxPort' and 'RegistryPort' values must be open between all appservers.