1 Reply Latest reply on Nov 20, 2013 8:20 AM by Florian Tesi

    TMART Availability Error: BrowserEngine: 7 - Startup failed

    Flavio Bonacordi

      Hi, I had created a code using workbench.

      My project have the WEB BROWSER-DRIVEN (AJAX) type selected.

       

      // ----------------------------------------------------------------------
      // Recorded 11/8/2013 by BMC TM ART Recorder v4.2.0.5498
      // ----------------------------------------------------------------------
      // Rule set "ASP.NET ViewState"
      //  * Rule "Parse and Replace __VIEWSTATE"
      //  * Rule "Parse and Replace __EVENTVALIDATION"
      // ----------------------------------------------------------------------
      @codepage(1252)
      benchmark BMCTMARTRecorder
      use "Kernel.bdh"
      use "BrowserAPI.bdh"
      use "GetMyLocation.bdh"
      dcluser
        user
          VUser
        transactions
          TInit           : begin;
          TMain           : 1;
      var
      dclrand
      dcltrans
        transaction TInit
        begin
        end TInit;
        transaction TMain
        var
          wnd1 : number; 
          sLocation    : string;
          sScript      : string;
          sMeasureName : string;
        begin
          sScript := GetScriptName(FILENAME_SIMPLE);
          GetMyLocation(sLocation);
          sMeasureName:=sLocation+"-"+sScript+"-"; 
          print(sMeasureName);
          MeasureStart(sMeasureName+"0-Total Time");
          MeasureStart(sMeasureName+"1-Open URL");
          BrowserStart(BROWSER_MODE_DEFAULT, 1074, 570);
          BrowserNavigate("https://webaddress/", "Navigate_https://webaddress/ (#1)");
          wnd1 := BrowserGetActiveWindow("wnd1");
          BrowserRadioButtonSelect("//INPUT[@id='rblLangs_1']", "RadioButtonSelect, INPUT, name=rblLangs (#1)");
          BrowserClick("//INPUT[@id='btnGo']", BUTTON_Left, "Click, INPUT, name=btnGo (#1)");
          MeasureStop(sMeasureName+"1-Open URL");
          MeasureStart(sMeasureName+"2-Search Assessments");
          BrowserClick("//A[@textContents='Main Menu']", BUTTON_Left, "Click, A, textContents=Main Menu (#1)");
          BrowserClick("//A[@textContents='Assessments']", BUTTON_Left, "Click, A, textContents=Assessments (#1)");
          MeasureStop(sMeasureName+"2-Search Assessments");
          MeasureStart(sMeasureName+"3-Search");
          BrowserClick("//INPUT[@name='fsubmit']", BUTTON_Left, "Click, BODY (#1)");
          MeasureStop(sMeasureName+"3-Search");
          MeasureStart(sMeasureName+"4-Open Item");
          BrowserClick("//A[@textContents='1269058']", BUTTON_Left, "Click, BODY (#2)");
          MeasureStop(sMeasureName+"4-Open Item");
          MeasureStart(sMeasureName+"5-Options");
          BrowserClick("//INPUT[@id='ctl00_sp_id_0_s2_btn*']", BUTTON_Left, "Click, BODY (#3)");
          MeasureStop(sMeasureName+"5-Options");
          MeasureStart(sMeasureName+"6-Logout");
          BrowserClick("//A[@textContents='Logout']", BUTTON_Left, "Click, INPUT, name=ctl00$sp_id_0$s2$btnOptions (#1)");
          MeasureStop(sMeasureName+"6-Logout");
          MeasureStop(sMeasureName+"0-Total Time");
        end TMain;
      

       

      I'm able to TRY THE SCRIPT into Workbench and get the measures that I need.

      I was ablet o upload the project to BMC TM ART Central and implement the monitor.

      The monitor was running fine for a couple of times and after that I staring get the Availability Error:

       

      BrowserEngine: 7 - Startup failed

       

      and since then I'm not able to gathering data anymore.

       

      Any hint?