2 Replies Latest reply on Nov 18, 2013 3:50 AM by Sami Halonen

    Agent installer job fails on Windows targets

    Sami Halonen

      I have several Windows servers I'm trying to install RSCD agent and I get the same error on all of them (see below). The version I'm using is 8.3.2. The agent MSI is copied to the target server just fine and there are no processes "stuck", keeping the staging directory locked.


      This is going to be a real show stopper, since I'm expected to deploy some 5000+ Windows agents in the near future.


      Any ideas?



      Error15.11.2013 10:16:13jcifs.smb.SmbFileOutputStream.isOpen()Z
      Warning15.11.2013 10:16:13Failed to delete directory /tmp/stage/03cf211f-c32d-4599-88f6-111a3a3d7322_0 on The process cannot access the file because it is being used by another process.
      Info15.11.2013 10:16:10Copying the agent bundle installer software from the local directory 'C:\Program Files\BMC Software\BladeLogic\NSH\tmp\application_server\1ea2e2f7-515f-4af7-8b47-d164ba4739bc' to the remote directory '/tmp/stage/03cf211f-c32d-4599-88f6-111a3a3d7322_0'.
      Info15.11.2013 10:16:09Loading users file information.
      Info15.11.2013 10:16:05OS discovery of server using the remote host authentication 'x' returned 'Windows 32-bit'.
      Info15.11.2013 10:16:05Command succeeded with stdout = HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment    PROCESSOR_ARCHITECTURE    REG_SZ    x86
      Info15.11.2013 10:16:04Executing command 'REG.exe Query "HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Environment" /v PROCESSOR_ARCHITECTURE'.
      Info15.11.2013 10:16:04Attempting to discover the OS of server using the remote host authentication x'.
      Info15.11.2013 10:16:04Remote host authentication 3 of 8 'x' validated successfully against server ''.  'x' will be used for the installation.
      Info15.11.2013 10:16:01Validating remote host authentication 3 of 8 'x' against server ''.
        • 1. Re: Agent installer job fails on Windows targets
          John O'Toole

          Hi Sami,


          The "jcifs.smb.SmbFileOutputStream.isOpen()Z" in the logs matches a defect, probably with the BSA application server upgrade, where an older version of a jar file is left in place in the <APPSERVER_INSTALL_DIR>\NSH\br\stdlib directory and causes a conflict.


          We need to get an external KB article out there on this issue but try the following workaround from the current internal/draft article we have (KA404293):


          1. Login to appserver machine

          2. cd to <APPSERVER_INSTALL_DIR>\NSH\br\stdlib

          3. List all files and see if there is multiple jcifs-<VERSION>.jar


          continue with the next steps if you have found multiple jcifs-<VERSION>.jar:

          4. Stop the appserver

          5. rename older jcifs-<VERSION>.jar and move it from stdlib directory

          6 Start the appserver and try installing agent again.

          The files might be called  jcifs-1.2.9 and jcifs-1.3.1. In that case, you would rename and move  jcifs-1.2.9


          Let us know how this goes and we'll work on getting the KA article tidied up and published if it fixes the issue for you.

          • 2. Re: Agent installer job fails on Windows targets
            Sami Halonen

            Thanks man, this solved it.