0 Replies Latest reply on Oct 24, 2013 9:31 AM by Andrzej NameToUpdate

    SQL Server Setup Failed with Access Denied

      Hello,

       

      I created nsh scripts which copies static ini file, build its dynamic part, copy binaries and starts setup on the cluster:

       

      nexec -i NodeA cmd /c D:\Temp\EE_SP3\setup /SkipRules=Cluster_IsWMIServiceOperational /ConfigurationFile=d:\temp\1stNode.ini

       

      If I run command manually it works fine. However if I do this as above or through BL job I am getting following:

       

      The user running this Setup operation must have sufficient privileges to access registry and service control manager on remote cluster node(s). Administrator privileges on the remote computer(s) is required.

       

      I noticed that issue is with accessing nodeB by Setup program. During installation BL has to execute something against nodeB and this causes access denied. I saw in security log on node B that BL account  from node A tried to access node B without success.

       

      Any idea how this can be solved?