8 Replies Latest reply on Oct 9, 2013 4:02 PM by Bill Robinson

    BLCLI to set property of type "server"

    Jeff Schwartzkopf

      I'm trying to use the blcli to update a the VITUAL_ENTITY_MANAGER property of the Class://SystemObject/Virtualization/<server> property instance.   VIRTUAL_ENTITY_MANAGER is of type "Server" and I can't quit figure out the syntax to make it work.  Is it possible?


      When I use the GUI to set the property and dump the properties VIRTUAL_ENTITY_MANAGER is set to


      VIRTUAL_ENTITY_MANAGER = fefcee50-3b3f-4b6a-9854-838dc1782a44 1002 DBKey:SDeviceModelKeyImpl:2-2004969


      So I have tried all mutiple variations of this and can't seem to make it work.  Here is what I am trying to run...


      blcli_execute PropertyInstance setPropertyValueByPSI Class://SystemObject/Virtualization/kcvm56 VIRTUAL_ENTITY_MANAGER <What goes here?>


      Any idea how to format that last parameter?  I've tried the DBKey, the output listed above as a string?  Seems as though the blcli command wants a string there, how do I format it to satisfy the command, I always seem to get a syntax error.