1 2 Previous Next 24 Replies Latest reply on Sep 19, 2014 11:48 AM by Nathan Whitaker

    BLPackage external command versus nexec

    Jim Campbell

      I am seeing some odd behaviour with a specific package that we have used for some time.  The package is used to install the HP Support Pack for Proliant using HP's hpsum utility.  To simplify, I staged all of the code onto the server and just created a batch file to call the command.  The problem I am seeing is that it is failing when I execute it using an external command inside of a BLPackage ONLY when the agent on the server is at 8.3sp1 or 8.3sp2 (which I tried in addition to the supported 8.3sp1 agent just to see if it was something specific to the exact SP we were using and am aware that uplevel agents are not supported).  Our appserver is at 8.3sp1.  Confusing matters further, if i use nexec to execute the same batch file (again to clarify, no content on the server is being changed at any point - I am simply calling a pre-staged batch file) I do not get this error.


      My batch file looks like:


      c:\temp\bladelogic\hpspp\swpackages\hpsum /use_latest /allow_non_bundle_components /s /veryv >> c:\temp\bladelogic\SPP_RESULT.txt 2>>&1


      If i call this batch file within an external command of a BLPackage for a pre-8.3 agent (I tried both 8.2sp4 and 8.1sp3patchlevel1) the installer runs as intended.  If i call this batch file using an 8.3 agent of any kind with an nexec command :


      nexec SERVERNAME c:\\temp\\bladelogic\\startspp.bat


      again it works fine.  The external command in the BLPackage is a simple:




      However, if I make the call using a BLPackage external command when the agent is at 8.3 the package does not work and the error I receive in the logs from the hpsum executable is :


      Qt: INTERNALL ERROR: failed to install GetMessage hook


      I have tried to compare everything I could to see why a BLPackage external command would behave differently and the ONLY thing I changed in between job runs was the agent installed on the server (and with a property update in between so the appserver had updated version information).  The same result is duplicated if I use User Principal Mapping or Automation Principals (works on pre-8.3 agents or with nexec, does not work with the combination of 8.3 agent + External Command).


      So what I have seen is:

      pre-83agent + BLPackage + Automation principal = works

      pre-83agent + BLPackage + User Principal Mapping = works

      83agent + nexec + Automation principal = works

      83agent + nexec + User Principal Mapping = works

      83agent + BLPackage + Automation Principal = fails with above error

      83agent + BLPackage + User Principal Mapping = fails with above error


      Any ideas on what could cause this?  I don't have any ideas of the details of how the HP software works but am intersted in why exactly the same software would behave differently just based on how the command was executed.


      Edit: Also the same behaviour is replicated on all OS Versions I have tried (2k3, 2K8R2, and 2K12).

        1 2 Previous Next