4 Replies Latest reply on Oct 8, 2013 10:17 AM by Bill Robinson

    nexec - "This account is currently not available"

    S Crawford

      Currently running RHEL 6.0 on System Z (zLinux) with RSCD agent version 8.2. Trying to run nexec to open a new bash shell (as root), but getting the following error:

       

      server1% nexec -i -l server1 bash

      This account is currently not available.

       

       

      When trying to use -e, the new shell session opens, but there are warning errors that come up and the output from the shell commands do not form on a new line:

       

      server1% nexec -e bash

      bash: cannot set terminal process group (-1): Inappropriate ioctl for device

      bash: no job control in this shell

      bash-4.1$ dateTue Sep  3 15:39:22 EDT 2013

      bash-4.1$ uptime 15:39:24 up 12 days,  6:50,  1 user,  load average: 0.00, 0.00, 0.00

       

       

      Checked /etc/passwd, root entry is set properly:

       

      [root@server1~]# cat /etc/passwd | grep root

      root:x:0:0:root:/root:/bin/bash

       

       

      Tried nexec to other shells, but also got the same error:

       

      server1% nexec -i -l server1 ksh

      This account is currently not available.