6 Replies Latest reply on Jan 27, 2014 6:39 AM by Bill Robinson

    invalid asset tag 'RPM'

      BMC Server Automation


      When trying to deploy an RPM to an AIX server I get " Invalid asset tag 'RPM' " in the job log and I'm not having any luck determining why. Looking for any assistance people can provide on this problem.


      Things I've tried.

      1. Added an RPM to the depot, right clicked on the rpm and tried deploying, received above error
      2. created a BL package of the rpm and tried deploying that, same error
      3. modified the install command listed in the rpm properties and retried above test, same error
      4. copied the RPM directly to the server I'm testing against and installed and removed it with no problems and no special options.


      errors that I see in the job log.

      1.      Invalid asset tag 'RPM'
      2.      found invalid asset tag while processing file '/va/tmp/stage/a6*/bldeploy.xml'
      3.      failed to parse '/var/tmp/stage/a6*/bldeploy.xml'


      Copy of bldeploy.xml

      <?xml version="1.0" encoding="UTF-8" standalone="yes"?>


      <BLPACKAGE CreatedBy="me@notyou.com" CreatedDate="2013/08/27 09:43:00" SchemaVersion="2.0">

         <RPM Action="Add" ItemId="1" DepotObjectKey="2256134.1">



            <Cmd>rpm -Uiv 2256134.1/vim-common.ppc.rpm</Cmd>

            <UndoCmd>rpm -e vim-common</UndoCmd>










        • 1. Re: invalid asset tag 'RPM'
          Joe Piotrowski

          On the target server you can run "agentctl toggle" to turn on logging. Try running the job again through BSA and look at the rscd.log on the target. Also, there should be a logs folder in the agent home directory and there should be additional deploy logs you can review for that job event. When you deploy the RPM on the target, are you using the same user account as what you're mapping to in your secure files (exports/users/users.local) on the target?

          1 of 1 people found this helpful
          • 2. Re: invalid asset tag 'RPM'

            ran 'agentctl toggle' then re-ran my job, hunting through the logs and so far the only other error that stands out is the 'TJM return code -4001'

            I'm not doing anything custom with the user that's running the job so it should be kicking off as root on the server side.


            some excerpts from the logs

            ROLLBACKPATH = /opt/bmc/BladeLogic/8.0/NSH/Transactions/46a73471c13738bb9a291f231f4fae04:
            RSCDIR = /opt/bmc/BladeLogic/8.0/NSH:
            XMLFILEPATH = /var/tmp/stage/f9b9eac7c2533fce8942314988399c9e/bldeploy.xml:
            08/27/13 12:52:27.699 DEBUG    bldeploy - Full command line /opt/bmc/BladeLogic/8.0/NSH/sbin/bldeploy 46a73471c13738bb9a291f231f4fae04 -N="/var/tmp/stage/f9b9eac7c2533fce8942314988399c9e" -P=Target.notyou.com -Q=params.txt -PKG="mesa_test-2158968.2-0.8345310973762874-2256342.1" -DryRun -Xr -Xs -V2 -js0 -jr0 -jc0
            08/27/13 12:52:28.699 DEBUG    bldeploy - Validating existence of wait lock /opt/bmc/BladeLogic/8.0/NSH/Transactions/locks/reboot.lck
            08/27/13 12:52:28.700 DEBUG    bldeploy - Deployment running in multi-job mode
            08/27/13 12:52:30.703 DEBUG    bldeploy - Read lock acquired release write lock
            08/27/13 12:52:30.704 DEBUG    bldeploy - Acquired appropriate lock: /opt/bmc/BladeLogic/8.0/NSH/Transactions/locks/reader/46a73471c13738bb9a291f231f4fae04.lck
            08/27/13 12:52:31.714 DEBUG    bldeploy - Creating directory /opt/bmc/BladeLogic/8.0/NSH/Transactions/46a73471c13738bb9a291f231f4fae04 :access world
            08/27/13 12:52:31.714 INFO     bldeploy - Bldeploy "mesa_test-2158968.2-0.8345310973762874" UUID(46a73471c13738bb9a291f231f4fae04) started using file /var/tmp/stage/f9b9eac7c2533fce8942314988399c9e/bldeploy.xml with rollback directory /opt/bmc/BladeLogic/8.0/NSH/Transactions/46a73471c13738bb9a291f231f4fae04
            08/27/13 12:52:31.714 ERROR    bldeploy - Invalid asset tag 'RPM'
            08/27/13 12:52:31.714 ERROR    bldeploy - Found invalid asset tag while processing file '/var/tmp/stage/f9b9eac7c2533fce8942314988399c9e/bldeploy.xml'
            08/27/13 12:52:31.714 ERROR    bldeploy - Failed to parse /var/tmp/stage/f9b9eac7c2533fce8942314988399c9e/bldeploy.xml
            08/27/13 12:52:31.716 DEBUG    bldeploy - DeletePkg = 0 DeleteUndo = 1
            08/27/13 12:52:31.717 DEBUG    bldeploy - Deleted the folder: /opt/bmc/BladeLogic/8.0/NSH/Transactions/46a73471c13738bb9a291f231f4fae04
            08/27/13 12:52:32.719 DEBUG    bldeploy - Bldeploy done - nRet = 10 (Deployment failed to process) exitCode = -4001 (Deployment failed)


            08/27/13 12:52:32.667 DEBUG    bldeploy - Received from PID=5439642 EVENT=INFO MSG=Package "mesa_test-2158968.2-0.8345310973762874" UUID(46a73471c13738bb9a291f231f4fae04) initialized, entering wait queue for processing
            08/27/13 12:52:32.667 DEBUG    bldeploy - Received from PID=5439642 EVENT=INFO MSG=Package "mesa_test-2158968.2-0.8345310973762874" UUID(46a73471c13738bb9a291f231f4fae04) processing instructions
            08/27/13 12:52:33.668 DEBUG    bldeploy - Compare to blp_prog=bldeploy
            08/27/13 12:52:35.670 DEBUG    bldeploy - TJM return code -4001 changed to succeeded. Correct code set in STOP event exitCode value
            08/27/13 12:52:35.670 DEBUG    bldeploy - Received from PID=5439642 EVENT=STOP MSG=Package "mesa_test-2158968.2-0.8345310973762874" UUID(46a73471c13738bb9a291f231f4fae04) completed. exitCode = -4001 (Deployment failed to process)
            08/27/13 12:52:36.671 DEBUG    bldeploy - Deleted event file: /opt/bmc/BladeLogic/8.0/NSH/Transactions/events/46a73471c13738bb9a291f231f4fae04.out
            08/27/13 12:52:37.674 DEBUG    bldeploy - Deleted event file: /opt/bmc/BladeLogic/8.0/NSH/Transactions/events/46a73471c13738bb9a291f231f4fae04.in
            08/27/13 12:52:37.674 DEBUG    bldeploy - Operation complete return code 0

            • 3. Re: invalid asset tag 'RPM'
              Bill Robinson

              i don't think we support rpm on aix, only linux as a native software type.  if you create a blpackage or custom depot software of the rpm file itself, not the object and add the command to do the rpm -Uvh <rpm> and deploy that what happens ?

              • 4. Re: invalid asset tag 'RPM'

                Followed your suggestion and created a blpackage with the rpm file and external command to install it, and that works as expected. For now this will be the direction I take for doing my RPM installs on AIX.


                Thank you Bill for the guidance.

                • 5. Re: invalid asset tag 'RPM'
                  Vivek Singh

                  Same happened with me today.Installing rpm on AIX.

                  I used custom software and that also worked with Install command.

                  Thanks for the info.

                  • 6. Re: invalid asset tag 'RPM'
                    Bill Robinson

                    you should create a support ticket and ask for rpm to be supported on aix.