10 Replies Latest reply on Aug 6, 2013 9:45 AM by Benjamin Hawkins

    Error Buffer - Permission Denied

    Benjamin Hawkins



      While trying to access servers via NSH Shell some users are getting the following errors:


      Error initializing node

      Error buffer: /cygdrive/C/Windows/rsc/secure: Permison Denied

      //{server}: Permissions Denied

      Press any key to continue . . .


      The rscd.log file is showing:

      d178be8c727acba2a0f0 0000000150 08/06/13 13:53:58.172 ERROR    rscd -  {IP Address} 4888 SYSTEM (Not_available): (Not_available): new_connection: SSL Protocol Mismatch Error


      Has any come across this before or know a resolution?




        • 1. Re: Error Buffer - Permission Denied
          Niranjan Nagandla

          I think the user which he is mapped to on the target do not have proper permissions to access the target “C:\Windows\rsc\secure” file(s). I think the user need read permissions on the “rsc\*”.




          1 of 1 people found this helpful
          • 2. Re: Error Buffer - Permission Denied
            Benjamin Hawkins

            The use they are mapped to is a member of local admins on the server and have access to the rsc folder.


            I've also check the rsc files and all the correct entries seem to be in users.local, users and exports.


            Is there any specific RBAC settings that the role would need to access NSH not going via a proxy?

            • 3. Re: Error Buffer - Permission Denied
              Niranjan Nagandla

              Can you reproduce the issue and attach the rscd log for that timeframe. I think that will show us if the connection is being initiated as a right user or not.


              08/06/13 08:37:20.416 INFO     rscd - 2568 BladeLogicRSCD@CLM-CLIENT->Administartor@CLM-CLIENT:PrivilegeMapped: agentinfo: agentinfo localhost

              08/06/13 08:37:20.432 INFO     rscd -  CLM-CLIENT 2568 BladeLogicRSCD (Not_available): (Not_available): The operation completed successfully.

              • 4. Re: Error Buffer - Permission Denied
                Bill Robinson

                Error buffer: /cygdrive/C/Windows/rsc/secure: Permison Denied

                would seem to indicate that the user starting nsh can't read this file on the local system.  can the user running the gui/nsh client read the local secure file ?

                • 5. Re: Error Buffer - Permission Denied
                  Benjamin Hawkins

                  All the RSCD Log has in it is:


                  dddf69771ffbaff4a8dd 0000000021 08/06/13 15:01:16.365 WARN     rscd -  {hostname} 6916 SYSTEM (Not_available): (Not_available): Main: Wait Timeout. Starting AgentHouseKeeping.

                  • 6. Re: Error Buffer - Permission Denied
                    Benjamin Hawkins

                    From the GUI the user can navigate to the /C/Windows/rsc/secure


                    Contents are:


                    #  Copyright (c) 2001-2010 BladeLogic, Inc.

                    #       -- All Rights Reserved --


                    # The information in this file determines what encryption and authentication

                    # parameters should be used by the RSCD Agent and the Network Shell utilities.


                    # Please read the BMCBladeLogicAdministration.pdf or "secure" man page for details

                    # on how to use this file.




                    • 7. Re: Error Buffer - Permission Denied
                      Benjamin Hawkins

                      So have done a bit more investigation and it gets a bit confusing:


                      Our users connect remotely via terminal server session over RDWeb services using domain authentication.


                      I've just tried a test user from RDWeb and once authenticated through they have no access to the NSH Shell it gives the error message above. They are a domain user with a locked down role policy.


                      I've also logged in via my Domain Admin account and with a BLAdmin role and can gain access to the NSH Shell.


                      I've also tried logging on to a Terminal Server as my account and running the Console as the test user but this time NSH worked fine.


                      If I however log on to the Terminal Server via the test domain user and then try my Console account it fails.


                      The Server we're testing NSH against isn't in the same domain as us or the BSA installation.


                      Any thoughts why this would work when logging onto the Terminal Server direct but not when using the Console via a Web Session?


                      Have I missed something when mapping a User to a Role within bladelogic. I'm not sure what effect domain authenticated account permissions could have on a multi tenant solution.

                      • 8. Re: Error Buffer - Permission Denied
                        Bill Robinson

                        on your client system can you open a cmd prompt and cd into c:\window\rsc ?

                        • 9. Re: Error Buffer - Permission Denied
                          Bill Robinson

                          The user that is running the gui does not have access to the local ‘secure’ file.  your user apparently does – perhaps it’s an admin account ?

                          • 10. Re: Error Buffer - Permission Denied
                            Benjamin Hawkins

                            Just check and the permissions were set to read and execute but the user group was unable to access it.


                            I removed and then re-added permissions to the rsc folder and filtered down. Looks like the permissions had got corrupt somehow.


                            Thanks for the responses