4 Replies Latest reply on Jul 20, 2013 2:09 PM by Bill Robinson

    Redhat PAJ fails (8.1 sp5)

    himanshu sangwan

      Hi All,

       

      When i ran an PAJ it fails with below dependency so excluded below rpms from PAJ list and re0ran analysis it worked fine but failed for other targets stating  "An rpm required as a part of dependency is in the exclude listERROR::-- The patch respository is incomplete and dependencies are missing in repositoryERROR::YUM listed errors"

       

       

      Please suggest workaround

       

      -Logs before exclude list

      ------------------------------------

       

      Error Jul 15, 2013 9:25:47 PM STDERR: ERROR::YUM dry run failedERROR::*******************************************ERROR::YUM unable to complete analysis for either of the following reasonsERROR::-- An rpm required as a part of dependency is in the exclude listERROR::-- The patch respository is incomplete and dependencies are missing in repositoryERROR::YUM listed errors belowERROR::*******************************************ERROR::Missing Dependency: popt = 1.9.1-33_nonptl.el4_8.1 is needed by package rpm-python-4.3.3-33_nonptl.el4_8.1.i386 (installed)ERROR::*******************************************ERROR::YUM unable to complete analysis for either of the following reasonsERROR::-- An rpm required as a part of dependency is in the exclude listERROR::-- The patch respository is incomplete and dependencies are missing in repositoryERROR::YUM listed errors belowERROR::*******************************************ERROR::Missing Dependency: rpm-libs = 4.3.3-33_nonptl.el4_8.1 is needed by package rpm-python-4.3.3-33_nonptl.el4_8.1.i386 (installed)ERROR::*******************************************ERROR::YUM unable to complete analysis for either of the following reasonsERROR::-- An rpm required as a part of dependency is in the exclude listERROR::-- The patch respository is incomplete and dependencies are missing in repositoryERROR::YUM listed errors belowERROR::*******************************************ERROR::Missing Dependency: rpm-libs = 4.3.3-33_nonptl.el4_8.1 is needed by package rpm-4.3.3-33_nonptl.el4_8.1.i386 (installed)ERROR::*******************************************ERROR::YUM unable to complete analysis for either of the following reasonsERROR::-- An rpm required as a part of dependency is in the exclude listERROR::-- The patch respository is incomplete and dependencies are missing in repositoryERROR::YUM listed errors belowERROR::*******************************************ERROR::Missing Dependency: popt = 1.9.1-33_nonptl.el4_8.1 is needed by package rpm-4.3.3-33_nonptl.el4_8.1.i386 (installed)

       

      Logs after exclude list

      ---------------------------------

       

      Error Jul 15, 2013 10:35:30 PM STDERR: ERROR::YUM dry run failedERROR::*******************************************ERROR::YUM unable to complete analysis for either of the following reasonsERROR::-- An rpm required as a part of dependency is in the exclude listERROR::-- The patch respository is incomplete and dependencies are missing in repositoryERROR::YUM listed errors belowERROR::*******************************************ERROR::Missing Dependency: rpm-libs = 4.3.3-35_nonptl.el4 is needed by package rpm-devel-4.3.3-35_nonptl.el4.i386 (repo)ERROR::*******************************************ERROR::YUM unable to complete analysis for either of the following reasonsERROR::-- An rpm required as a part of dependency is in the exclude listERROR::-- The patch respository is incomplete and dependencies are missing in repositoryERROR::YUM listed errors belowERROR::*******************************************ERROR::Missing Dependency: rpm = 4.3.3-35_nonptl.el4 is needed by package rpm-devel-4.3.3-35_nonptl.el4.i386 (repo)ERROR::*******************************************ERROR::YUM unable to complete analysis for either of the following reasonsERROR::-- An rpm required as a part of dependency is in the exclude listERROR::-- The patch respository is incomplete and dependencies are missing in repositoryERROR::YUM listed errors belowERROR::*******************************************ERROR::Missing Dependency: popt = 1.9.1-35_nonptl.el4 is needed by package rpm-devel-4.3.3-35_nonptl.el4.i386 (repo)ERROR::*******************************************ERROR::YUM unable to complete analysis for either of the following reasonsERROR::-- An rpm required as a part of dependency is in the exclude listERROR::-- The patch respository is incomplete and dependencies are missing in repositoryERROR::YUM listed errors belowERROR::*******************************************ERROR::Missing Dependency: popt = 1.9.1-35_nonptl.el4 is needed by package rpm-build-4.3.3-35_nonptl.el4.i386 (repo)ERROR::*******************************************ERROR::YUM unable to complete analysis for either of the following reasonsERROR::-- An rpm required as a part of dependency is in the exclude listERROR::-- The patch respository is incomplete and dependencies are missing in repositoryERROR::YUM listed errors belowERROR::*******************************************ERROR::Missing Dependency: rpm-libs = 4.3.3-35_nonptl.el4 is needed by package rpm-build-4.3.3-35_nonptl.el4.i386 (repo)ERROR::*******************************************ERROR::YUM unable to complete analysis for either of the following reasonsERROR::-- An rpm required as a part of dependency is in the exclude listERROR::-- The patch respository is incomplete and dependencies are missing in repositoryERROR::YUM listed errors belowERROR::*******************************************ERROR::Missing Dependency: rpm = 4.3.3-35_nonptl.el4 is needed by package rpm-build-4.3.3-35_nonptl.el4.i386 (repo)

       

       

      Thanks

      hsangwan