13 Replies Latest reply on Jul 3, 2013 1:53 AM by Sami Halonen

    Pushing certificate to agent (putcert) fails

    Sami Halonen

      I'm running out of ideas. I've checked and re-checked everything and I just can't get it to work. I've followed the installation guide to the letter and even tried anything I can think of outside of the guide. I'm running BSA 8.3 on Windows 2008 R2 and I'm trying to push the fingerprint to the agent on my test application server.


      Creating the cert works fine, bl_gen_ssl and secadmin and all that work fine.

      I have * rw,user=Administrator in exports file (tried * rw,map=Administrator too)

      I have rscd:port=4750:protocol=5:tls_mode=encryption_only:encryption=tls in secure file. Even re-created it using secadmin -m rscd -p 5 -T encryption_only -e tls


      Trying putcert SYSTEM id.pem blapptest01 gives a nice and descriptive error (blapptest01 is the test BSA application server):

      "SHA1 Fingerprint=83:80:C3:01:6C:D6:BD:A8:EE:DE:31:03:3A:79:38:C8:8D:CB:E7:F1

      Unable to send cert info to remote host blapptest01: No error"


      Checking rscd.log reveals something more:

      "657433d2cf7e32bce76d 0000000010 07/02/13 12:56:44.695 WARN     rscd - 2820 SYSTEM (wadmhalonens): putcert: Failed to map user to local user" where wadmhalonens is my Active Directory domain login name I'm using in the test environment.


      Anyone who could give me some ideas how to solve this?