3 Replies Latest reply on Mar 5, 2013 9:19 AM by Joe Piotrowski

    Change the proxyhost entry for licensing

      Hi (newbie bladelogic adminsitrator here)


      Weve just had our Proxy servers renewed and now our licensing doesnt seem to work.


      Ive gone onto and got and nsh prompt etc but Im unsire of the actual command line to use to change the proxthost to our new proxy server.


      Can anyone advise of the correct command line usage ? eg something like blasadmin proxyhost




      many thanks



        • 1. Re: Change the proxyhost entry for licensing
          Joe Piotrowski

          Tony it depends on how your application servers were set up. You will need to run the blasadmin utility against all your active application server instances and make the proper change.


          First, find the name of the instances on your application server. Look in the .../NSH/br/deployments folder. Those are the names of the application server instances. If you didn't make any custom changes the instance name used is "default."


          To connect to a specific instance the command is blasadmin -s <instanceName>. If you just type in blasadmin it will connect to the "default" instance by default.


          Once conncected your prompt will change to "user:instance>" like:



          From there you can use the "show" command to list the different groups. If you type in "show appserver" it will show the AppServer Configuration settings names. If you type in "show appserver all" it will list the names and their values.


          I believe the setting you need to change is called "HTTPProxyName." To see the current value type in "show appserver httpproxyname." To change the value type in "set appserver httpproxyname <value>" You may need to restart your appserver service/daemon for this change to take effect.

          • 2. Re: Change the proxyhost entry for licensing

            Hi Joe


            many thanks - your advice was spot on. Your a star





            • 3. Re: Change the proxyhost entry for licensing
              Joe Piotrowski

              Thanks Tony. I get lucky sometimes. I forgot you can also make changes through the Console GUI. Configuration > Infrastructure Management... > Proxy Servers.