1 Reply Latest reply on Feb 8, 2013 3:56 PM by John Martineau

    Creating Patch Catalog - RHEL6

      Having an issue creating a patch catalog in BSA 8.2 for RHEL 6. I know that createrepo 0.4.6 and python-urlgrabber 2.9.6 are needed, but it looks like RHEL6 came with python-urlgrabber 3.9.1 and I found the rpm for createrepo which I 'installed' onto the server. However, when I go to create a patch catalog for it I get the following error:

       

      Error    Feb 8, 2013 2:17:42 PM    Error while updating feed: Failed to install/update createrepo and python-urlgrabber. Please ensure createrepo and python-urlgrabber are installed on repository server.Exit code for python-urlgrabber installation : 1, error :warning: /repo/catalog_2000105.part/python-urlgrabber-2.9.6-1.2.el4.rf.noarch.rpm: Header V3 DSA/SHA1 Signature, key ID 6b8d79e6: NOKEY

      error: Failed dependencies:

      python-urlgrabber >= 3.9.0-8 is needed by (installed) yum-3.2.29-30.el6.noarch

      . Exit code for createrepo installation : 1, error :warning: /repo/catalog_2000105.part/createrepo-0.4.6-1.el4.rf.noarch.rpm: Header V3 DSA/SHA1 Signature, key ID 6b8d79e6: NOKEY

      error: can't create transaction lock on /var/lib/rpm/.rpm.lock (Permission denied)

      .

       

      Any help is appreciated!