3 Replies Latest reply on Jan 25, 2013 8:32 AM by Jim Wilson

    How to escape $ sign when using nexec command

      Hi everyone,


      I have tried to using the nexec to submit a command with a $ sign, error occurred. The traditional escape character "\" does not work here. Here is the complete command that I have submitted using nexec.


      nexec -ncq $SERVER "echo \"'SELECT name, value FROM v\$parameter;' | sqlplus / as sysdba\" "


      From the output, the SQL statement stopped at "v" that means the escape character "\" does not work in here.

      Any idea on how to escape the $ sign in nexec?


      Thanks for a lot for help.