4 Replies Latest reply on Dec 6, 2012 9:59 PM by Bill Robinson

    Error while logging into Blade logic Application Server - wrong application server URL

    Gurneet Singh Chopra

      Hi,

       

      I am using a F5 load balancer and want to login to Application from BL Console Client using a Virtual IP. Ports 9840 and 9841 are listening and i am able to telnet them.

       

      When i try logging in from BL Console, i get the below error:

       

      Your session credential does not contain a valid Application Server URL. Errors were: Failure parsing service greeting.

       

      I did the below setting to sync my BL Application with a F5 Load balancer:

       

      blasadmin -a

      (a) set AuthServer AppServiceURLs service:appsvc.bladelogic:blsess://10.54.190.58:9841

      (b) set AppServer ValidateClientIpAddress false

      (c) set AppServer ValidateRequestURL false

       

      Interestingly, when i try to acquire credentials from NSH, i am able to do that. Please find the below output for blcred cred -list

       

      C:\Users\kgzz247pa>blcred cred -list
      Username:         BLAdmin
      Authentication:   SRP
      Issuing Service:  service:authsvc.bladelogic:blauth://10.54.190.58:9840
      Expiration Time:  Sat Dec 01 00:57:43 CET 2012
      Maximum Lifetime: Sat Dec 01 00:57:43 CET 2012
      Client address:   10.54.82.6
      Authorized Roles:
          BLAdmins

      Destination URLs:
          service:appsvc.bladelogic:blsess://10.54.190.58:9841

       

       

      However, i am not able to login from RCP Client. I went through couple of similar discussions.

       

      Could there be a problem with the certificate? Do i need to generate a new certificate to get this going?

       

      Please suggest.

       

      Thanks,

      Gurneet