2 Replies Latest reply on Nov 29, 2012 5:08 PM by Bill Robinson

    nsh segmentation fault with local install

    Andrew St. Jean

      I installed BSA 8.2.01 on RedHat 6.2 and all seemed good until I tried to run nsh. nsh complained about missing libraries. That didn't surprise me too much because I used the -local switch when installing the application server. So I found where BSA keeps its libraries and added the directory to my library path. Now nsh seg faults whenever I try to run it.


      Command I used to install the application server.


      # ./BBSA82-SP1-LIN64.sh -local


      When I tried to run nsh, this is the error I received.


      # ./nsh

      ./nsh: error while loading shared libraries: libblsrp.so: cannot open shared object file: No such file or directory


      So I added the needed directory to LD_LIBRARY_PATH.


      # LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/srv/bladelogic/appserver/NSH/lib; export LD_LIBRARY_PATH


      Now nsh seg faults.


      # ./nsh

      Segmentation fault (core dumped)


      Here is the output of ldd when applied to nsh.


      # ldd ./nsh

              linux-vdso.so.1 =>  (0x00007fffd9b49000)

              libblsrp.so => /srv/bladelogic/appserver/NSH/lib/libblsrp.so (0x00007fe440a29000)

              libnc.so => /srv/bladelogic/appserver/NSH/lib/libnc.so (0x00007fe4407b3000)

              libdl.so.2 => /lib64/libdl.so.2 (0x0000003a45a00000)

              liblog4c.so => /srv/bladelogic/appserver/NSH/lib/liblog4c.so (0x00007fe440642000)

              libpthread.so.0 => /lib64/libpthread.so.0 (0x0000003a46200000)

              libblssl.so.0.9.8 => /srv/bladelogic/appserver/NSH/lib/libblssl.so.0.9.8 (0x00007fe4404f2000)

              libblcrypto.so.0.9.8 => /srv/bladelogic/appserver/NSH/lib/libblcrypto.so.0.9.8 (0x00007fe44026c000)

              libm.so.6 => /lib64/libm.so.6 (0x0000003a46a00000)

              libc.so.6 => /lib64/libc.so.6 (0x0000003a45e00000)

              /lib64/ld-linux-x86-64.so.2 (0x0000003a45600000)


      I'm able to use the BladeLogic Console to connect to the app server just fine and I've been creating and executing jobs without any trouble. Anybody have any ideas?