1 2 Previous Next 18 Replies Latest reply on Oct 12, 2012 7:39 AM by Lazar NameToUpdate

    Patch catalog update job taking lot time and not showing any progress

    Somnath Shilimkar

      Hi,

      Can anybody help me in following-->

      i have created windows patch catalog, in Console in task in progress view it is showing progress as 2/3 from last 3 hrs, and in appserver.log file it is showed

      65 % completion.

      following is appserver info which is repeating itself from last 2 hrs

       

      [14 Sep 2012 02:18:15,531] [Scheduled-System-Tasks-Thread-1] [INFO] [System:System:] [Memory Monitor] Total JVM (B): 760107008,Free JVM (B): 495076096,Used JVM (B): 265030912,VSize (B): 2606997504,RSS (B): 745201664,Used File Descriptors: 249

      [14 Sep 2012 02:19:15,530] [Scheduled-System-Tasks-Thread-20] [INFO] [System:System:] [Memory Monitor] Total JVM (B): 760107008,Free JVM (B): 482352856,Used JVM (B): 277754152,VSize (B): 2606997504,RSS (B): 745201664,Used File Descriptors: 249

      [14 Sep 2012 02:20:15,529] [Scheduled-System-Tasks-Thread-14] [INFO] [System:System:] [Memory Monitor] Total JVM (B): 760107008,Free JVM (B): 469530952,Used JVM (B): 290576056,VSize (B): 2606997504,RSS (B): 745201664,Used File Descriptors: 249

      [14 Sep 2012 02:21:07,294] [Client-Connections-Thread-0] [INFO] [BLAdmin:BLAdmins:192.168.6.1] [Client] Connection disconnecting: id = 14

      [14 Sep 2012 02:21:12,657] [Client-Connections-Thread-7] [INFO] [BLAdmin:BLAdmins:192.168.6.1] [Client] User 'BLAdmin' assumed the role 'BLAdmins'

      [14 Sep 2012 02:21:15,531] [Scheduled-System-Tasks-Thread-11] [INFO] [System:System:] [Memory Monitor] Total JVM (B): 760107008,Free JVM (B): 663662816,Used JVM (B): 96444192,VSize (B): 2606997504,RSS (B): 745230336,Used File Descriptors: 249

      [14 Sep 2012 02:22:15,529] [Scheduled-System-Tasks-Thread-9] [INFO] [System:System:] [Memory Monitor] Total JVM (B): 760107008,Free JVM (B): 649729304,Used JVM (B): 110377704,VSize (B): 2606997504,RSS (B): 745230336,Used File Descriptors: 249

      [14 Sep 2012 02:23:15,530] [Scheduled-System-Tasks-Thread-10] [INFO] [System:System:] [Memory Monitor] Total JVM (B): 760107008,Free JVM (B): 637340384,Used JVM (B): 122766624,VSize (B): 2606997504,RSS (B): 745230336,Used File Descriptors: 249

       

       

       

      in repository directory on windows server, files are downloded from vendor site but still job is not completing in Console and stuck at 2/3 in task in progress view

        • 1. Re: Patch catalog update job taking lot time and not showing any progress

          Hi Somnath,

          Depending upon the network bandwidth and also the number of filters selected in the catalog, it takes time to update the catalog. Since files are getting added to the repository it is still processing. What is your appserver version? Also how many filter have you selected?

           

          Regards,

          Kedar.

          • 2. Re: Patch catalog update job taking lot time and not showing any progress
            Somnath Shilimkar

            Hi kedar,

            appserver version is BBSA 8.2 sp1

            and network bandwidth is 2 MBPS.

            i selected only one filter( for Winzip) in windows catalog panel.

            • 3. Re: Patch catalog update job taking lot time and not showing any progress

              Hi Somnath,

              With only 1 filter and the bandwidth the job should have completed. Is the problem still persistent?

               

              If yes, are you using a load balancer? If yes refer to KB: KA327655

               

              If you are not using a load balancer, requesting to check if there is anything else logged in the appserver log and also the GUI log for the Catalog Update Job.

               

              Regards,

              Kedar.

              • 4. Re: Patch catalog update job taking lot time and not showing any progress
                Somnath Shilimkar

                No i am not using load balancer,

                 

                job executes till 65% as shown in the appsever.log

                but following lines are keep on coming in log file repeatedly,

                 

                read-18] [INFO] [System:System:] [Memory Monitor] Total JVM (B): 736407552,Free JVM (B): 279099376,Used JVM (B): 457308176,VSize (B): 2603999232,RSS (B): 786608128,Used File Descriptors: 254

                [14 Sep 2012 04:40:33,290] [Scheduled-System-Tasks-Thread-3] [INFO] [System:System:] [Memory Monitor] Total JVM (B): 736407552,Free JVM (B): 266605032,Used JVM (B): 469802520,VSize (B): 2603999232,RSS (B): 786677760,Used File Descriptors: 255

                [14 Sep 2012 04:41:33,291] [Scheduled-System-Tasks-Thread-10] [INFO] [System:System:] [Memory Monitor] Total JVM (B): 736407552,Free JVM (B): 254707680,Used JVM (B): 481699872,VSize (B): 2603999232,RSS (B): 786706432,Used File Descriptors: 255

                [14 Sep 2012 04:42:33,291] [Scheduled-System-Tasks-Thread-5] [INFO] [System:System:] [Memory Monitor] Total JVM (B): 736407552,Free JVM (B): 242298984,Used JVM (B): 494108568,VSize (B): 2603999232,RSS (B): 786735104,Used File Descriptors: 255

                [14 Sep 2012 04:43:33,290] [Scheduled-System-Tasks-Thread-9] [INFO] [System:System:] [Memory Monitor] Total JVM (B): 736407552,Free JVM (B): 227304848,Used JVM (B): 509102704,VSize (B): 2603999232,RSS (B): 786849792,Used File Descriptors: 254

                [14 Sep 2012 04:44:33,291] [Scheduled-System-Tasks-Thread-4] [INFO] [System:System:] [Memory Monitor] Total JVM (B): 736407552,Free JVM (B): 215398296,Used JVM (B): 521009256,VSize (B): 2603999232,RSS (B): 786857984,Used File Descriptors: 252

                [14 Sep 2012 04:45:33,291] [Scheduled-System-Tasks-Thread-10] [INFO] [System:System:] [Memory Monitor] Total JVM (B): 736407552,Free JVM (B): 203637136,Used JVM (B): 532770416,VSize (B): 2603999232,RSS (B): 786862080,Used File Descriptors: 252

                [14 Sep 2012 04:46:33,291] [Scheduled-System-Tasks-Thread-16] [INFO] [System:System:] [Memory Monitor] Total JVM (B): 736407552,Free JVM (B): 191327072,Used JVM (B): 545080480,VSize (B): 2603999232,RSS (B): 786890752,Used File Descriptors: 252

                [14 Sep 2012 04:47:33,296] [Scheduled-System-Tasks-Thread-19] [INFO] [System:System:] [Memory Monitor] Total JVM (B): 736407552,Free JVM (B): 178782928,Used JVM (B): 557624624,VSize (B): 2603999232,RSS (B): 786903040,Used File Descriptors: 252

                [14 Sep 2012 04:48:33,293] [Scheduled-System-Tasks-Thread-17] [INFO] [System:System:] [Memory Monitor] Total JVM (B): 736407552,Free JVM (B): 166196664,Used JVM (B): 570210888,VSize (B): 2603999232,RSS (B): 786903040,Used File Descriptors: 252

                [14 Sep 2012 04:49:33,291] [Scheduled-System-Tasks-Thread-4] [INFO] [System:System:] [Memory Monitor] Total JVM (B): 736407552,Free JVM (B): 153713424,Used JVM (B): 582694128,VSize (B): 2603999232,RSS (B): 786944000,Used File Descriptors: 252

                [14 Sep 2012 04:50:33,292] [Scheduled-System-Tasks-Thread-6] [INFO] [System:System:] [Memory Monitor] Total JVM (B): 736407552,Free JVM (B): 141130440,Used JVM (B): 595277112,VSize (B): 2603999232,RSS (B): 786976768,Used File Descriptors: 252

                [14 Sep 2012 04:51:33,292] [Scheduled-System-Tasks-Thread-1] [INFO] [System:System:] [Memory Monitor] Total JVM (B): 736407552,Free JVM (B): 128695880,Used JVM (B): 607711672,VSize (B): 2603999232,RSS (B): 786980864,Used File Descriptors: 252

                [14 Sep 2012 04:52:31,221] [Client-Connections-Thread-9] [INFO] [BLAdmin:BLAdmins:192.168.6.1] [Client] Connection disconnecting: id = 2

                [14 Sep 2012 04:52:31,233] [Client-Connections-Thread-0] [INFO] [BLAdmin:BLAdmins:192.168.6.1] [Client] Connection disconnecting: id = 1

                [14 Sep 2012 04:52:33,291] [Scheduled-System-Tasks-Thread-17] [INFO] [System:System:] [Memory Monitor] Total JVM (B): 736407552,Free JVM (B): 116175944,Used JVM (B): 620231608,VSize (B): 2603999232,RSS (B): 786984960,Used File Descriptors: 250

                [14 Sep 2012 04:52:36,235] [Client-Connections-Thread-6] [INFO] [BLAdmin:BLAdmins:192.168.6.1] [Client] Connection disconnecting: id = 3

                [14 Sep 2012 04:52:36,766] [Client-Connections-Thread-3] [INFO] [BLAdmin:BLAdmins:192.168.6.1] [Client] User 'BLAdmin' assumed the role 'BLAdmins'

                [14 Sep 2012 04:53:33,291] [Scheduled-System-Tasks-Thread-12] [INFO] [System:System:] [Memory Monitor] Total JVM (B): 736407552,Free JVM (B): 101380904,Used JVM (B): 635026648,VSize (B): 2603999232,RSS (B): 787103744,Used File Descriptors: 249

                [14 Sep 2012 04:54:33,291] [Scheduled-System-Tasks-Thread-3] [INFO] [System:System:] [Memory Monitor] Total JVM (B): 736407552,Free JVM (B): 290267896,Used JVM (B): 446139656,VSize (B): 2603999232,RSS (B): 787120128,Used File Descriptors: 247

                [14 Sep 2012 04:55:33,290] [Scheduled-System-Tasks-Thread-1] [INFO] [System:System:] [Memory Monitor] Total JVM (B): 736407552,Free JVM (B): 277702432,Used JVM (B): 458705120,VSize (B): 2603999232,RSS (B): 787120128,Used File Descriptors: 247

                [14 Sep 2012 04:56:33,292] [Scheduled-System-Tasks-Thread-6] [INFO] [System:System:] [Memory Monitor] Total JVM (B): 736407552,Free JVM (B): 265436360,Used JVM (B): 470971192,VSize (B): 2603999232,RSS (B): 787120128,Used File Descriptors: 247

                [14 Sep 2012 04:57:33,292] [Scheduled-System-Tasks-Thread-7] [INFO] [System:System:] [Memory Monitor] Total JVM (B): 736407552,Free JVM (B): 253103008,Used JVM (B): 483304544,VSize (B): 2603999232,RSS (B): 787120128,Used File Descriptors: 247

                 

                in the hotfix node i can see some file entries also in bulletin node there are two entries.. means it is getting downloaded but its job completion is not going on properly, may be i find something in GUI log

                • 5. Re: Patch catalog update job taking lot time and not showing any progress

                  Can you try running the Catalog without downloading the payloads (aka: uncheck "download from vendor"). You're not really obligated to download this during Catalog Job, and without it, the Catalog should run much faster. See if that works, and we can proceed from there.

                  • 6. Re: Patch catalog update job taking lot time and not showing any progress
                    Somnath Shilimkar

                    hi lazar,

                    i tried running catalog without downloading from vendors.. it showed results as successfull..

                    what to do next.

                    i gone through Console.log and appserver.log

                    in both files follwing code keep on repeating  after 65% completion of running catalog (when we checked download from vendor) --> is this error ?

                     

                    [14 Sep 2012 04:51:33,292] [Scheduled-System-Tasks-Thread-1] [INFO] [System:System:] [Memory Monitor] Total JVM (B): 736407552,Free JVM (B): 128695880,Used JVM (B): 607711672,VSize (B): 2603999232,RSS (B): 786980864,Used File Descriptors: 252

                    [14 Sep 2012 04:52:31,221] [Client-Connections-Thread-9] [INFO] [BLAdmin:BLAdmins:192.168.6.1] [Client] Connection disconnecting: id = 2

                    [14 Sep 2012 04:52:31,233] [Client-Connections-Thread-0] [INFO] [BLAdmin:BLAdmins:192.168.6.1] [Client] Connection disconnecting: id = 1

                    [14 Sep 2012 04:52:33,291] [Scheduled-System-Tasks-Thread-17] [INFO] [System:System:] [Memory Monitor] Total JVM (B): 736407552,Free JVM (B): 116175944,Used JVM (B): 620231608,VSize (B): 2603999232,RSS (B): 786984960,Used File Descriptors: 250

                    [14 Sep 2012 04:52:36,235] [Client-Connections-Thread-6] [INFO] [BLAdmin:BLAdmins:192.168.6.1] [Client] Connection disconnecting: id = 3

                    [14 Sep 2012 04:52:36,766] [Client-Connections-Thread-3] [INFO] [BLAdmin:BLAdmins:192.168.6.1] [Client] User 'BLAdmin' assumed the role 'BLAdmins'

                    [14 Sep 2012 04:53:33,291] [Scheduled-System-Tasks-Thread-12] [INFO] [System:System:] [Memory Monitor] Total JVM (B): 736407552,Free JVM (B): 101380904,Used JVM (B):

                     

                     

                    and before downlading files from shavlik following messages i seen in both log files, tell me if it is cause of failure..

                    [16 Sep 2012 22:26:06,462] [PSU-Thread-1] [WARN] [BLAdmin:BLAdmins:] [Patch-Metadata-Updator] Required credentials not available for BASIC <any realm>@xml.shavlik.com:80

                    [16 Sep 2012 22:26:06,462] [PSU-Thread-1] [WARN] [BLAdmin:BLAdmins:] [Patch-Metadata-Updator] Preemptive authentication requested but no default credentials available

                     

                    above messages are seen for without downloading payloads (aka : unchecking "download from vendor") as well as for downloading payload (aka: checking "download from vendor")

                     

                     

                    while updating following lines i see in appserver.log.. it this root cause ?

                     

                     

                    [16 Sep 2012 22:47:02,671] [PSU-Thread-1] [WARN] [BLAdmin:BLAdmins:] [Patch-Metadata-Updator] winzip10-6698.EXEis invalid, ignoring it

                    [16 Sep 2012 22:47:02,671] [WorkItem-Thread-2] [WARN] [BLAdmin:BLAdmins:] [Patch-Metadata-Updator] Excluding invalid package ' : winzip10-6698.EXE

                    • 7. Re: Patch catalog update job taking lot time and not showing any progress

                      Whether or not you check the "download from vendor", the actual metadata files (shavlik xml files) will still be downloaded. This is why you may see:

                      [16 Sep 2012 22:26:06,462] [PSU-Thread-1] [WARN] [BLAdmin:BLAdmins:] [Patch-Metadata-Updator] Required credentials not available for BASIC <any realm>@xml.shavlik.com:80

                      [16 Sep 2012 22:26:06,462] [PSU-Thread-1] [WARN] [BLAdmin:BLAdmins:] [Patch-Metadata-Updator] Preemptive authentication requested but no default credentials available

                       

                      This may suggest that something is not redirecting properly or the executables are not downloaded with expected size:

                      [16 Sep 2012 22:47:02,671] [PSU-Thread-1] [WARN] [BLAdmin:BLAdmins:] [Patch-Metadata-Updator] winzip10-6698.EXEis invalid, ignoring it

                      [16 Sep 2012 22:47:02,671] [WorkItem-Thread-2] [WARN] [BLAdmin:BLAdmins:] [Patch-Metadata-Updator] Excluding invalid package ' : winzip10-6698.EXE

                       

                      You are using proxy, correct? I think that's where we need to investigate next. Reproduce again with WinZIP Filter (to keep it fast and simple) and with "download from vendor", and review the proxy side for any issues or possible configuration tweaks.

                      • 8. Re: Patch catalog update job taking lot time and not showing any progress
                        Somnath Shilimkar

                        Hi lazar,

                        i am not using any proxy.

                         

                        On my machine i have in VM in which i have 3 OS

                        1) for Database server

                        2) for file server

                        3) for application server

                         

                        and i am using Console from My host machine i.e. on Windows 7.

                        means i have VM ware network apdapter,

                        private network is used.

                         

                        as long as downloading shavlik metadata and payload is concerned, i have connected my application server to internet by adding network apdapter to application server's VM and i have replicated same IP as my real machine.

                         

                        so scene is

                        for communication between appserver, file server, database server and Console i have used private network

                        and for connecting to internet-> as explained in above paragraph for internet connection for downloading

                        • 9. Re: Patch catalog update job taking lot time and not showing any progress

                          After having created successful catalog (without checking 'download from vendor), can you attempt to download patches via separate job? Right-click on Catalog / select 'Download', then select about 50-100 patches, and in the Properties tab of the job creation wizard for debug_mode_enabled select true.

                           

                          I'd like to see it it will start downloading any patches, maybe skip few really old ones, maybe timeout or fail down the line.

                          The debug log will actually be stored separately from regular appserver log and job log, it will be in <appserver_that_ran_the_job>/NSH/tmp/debug/xxxxx/xxxxxxx. Review the log and see if you can learn anything from it, attach here for review...

                          • 10. Re: Patch catalog update job taking lot time and not showing any progress

                            Somnath, let us know if you have the solution, if not please follow the last post and we'll try to help resolving.

                            • 11. Re: Patch catalog update job taking lot time and not showing any progress
                              Somnath Shilimkar

                              Hi,

                                  thanks for help,

                                  i have been working on some different task (Provisioning) from past few days, at that time i decided to work on provisioning first and once i m completed with my training then i will move to those parts which are having issues like this issue,

                              so from now i m going to work on this. i have kept in my mind to solve this issue no matter whatever it takes.

                               

                              i will follow above posted task and get back to you..

                               

                               

                              thanks

                              • 13. Re: Patch catalog update job taking lot time and not showing any progress
                                Somnath Shilimkar

                                i just feel to ask about creating Patch Catalog.

                                when we create patch catalog, we have to provide

                                1) windows helper server location (helper directory)

                                2) repository location (repository directory)

                                 

                                both of these directories i have kept empty( of course after we run patch catalog update consisting "download from vendor checked" repository get filled with some .msi files)

                                means i have kept them empty before running any patch related job..

                                SO IT IT CORRECT TO KEEP THEM EMPTY, OR DO WE HAVE TO PUT SOMETHING IN THOSE DIRECTORY ?

                                 

                                 

                                ONE MORE THING,  EVERY TIME WHEN I RUN PATCH CATALOG UPDATE JOB, HELPER DIRECTORY IS ALWAYS EMPTY AFTER SUCCESSFUL UPDATE( WITHOUT CHECKING DOWNLOAD FROM VENDOR)... IS IT OK ?

                                • 14. Re: Patch catalog update job taking lot time and not showing any progress

                                  Hi Somnath,

                                  After configuring the Helper and Repository in the GUI, do not have to put anything into these directories at the file system level.

                                   

                                  After executing CUJ: Repository is the location where the downloaded content is stored. Helper is the location for temporary processing like metadata extraction. So the behavior is correct.

                                   

                                  Regards,

                                  Kedar.

                                  1 2 Previous Next