2 Replies Latest reply on Aug 30, 2012 2:31 AM by Dhiraj Verma

    Bulk Agent Installer - Bladelogic 8.1



      I am trying deploy Bladelogic RSCD agent 8.1 using bulk installer, and getting failed to deploy.


      The required ports are opened and ADMIN share is enabled. When I run bulk installer job, which is copying installer, silent file successfully, but failed to execute the RSCD agent. below is the log file of job:


      2012-08-27|11:51:49] Starting agent install routines

      [2012-08-27|11:51:49] Checking agent status on BP1LCSAP071

      [2012-08-27|11:51:50] No existing RSCD Agent detected on :BP1LCSAP071

      [2012-08-27|11:51:50] Proceeding with the install routine.

      [2012-08-27|11:51:50] Agent installer selected :agentinstaller4

      [2012-08-27|11:51:50] RSC File selected :rsc3

      [2012-08-27|11:51:50] Attempting copier Windows Local Copier with password set: password1


      [2012-08-27|11:51:50] Attempting to copy agent installer "agentinstaller4" over SMB


      [2012-08-27|11:52:05] Successfully copied "RSCD81-SP5-WIN64.exe" to the temporary directory on   "BP1LCSAP071"

      [2012-08-27|11:52:05] Attempting to copy Silent Installer over SMB


      [2012-08-27|11:52:05] Successfully copied "rscd_Install80.iss" to the temporary directory on   "BP1LCSAP071"

      [2012-08-27|11:52:05] Attempting to copy RSC Files over SMB


      [2012-08-27|11:52:05] Successfully copied "exports" to the temporary directory on   "BP1LCSAP071"


      [2012-08-27|11:52:05] Successfully copied "users.local" to the temporary directory on   "BP1LCSAP071"

      [2012-08-27|11:52:05] Attempting installer Windows Local Installer with password set: password1




      [2012-08-27|11:52:31] PsExec v1.73 - Execute processes remotelyCopyright (C) 2001-2006 Mark RussinovichSysinternals - www.sysinternals.comConnecting to BP1LCSAP071...                                                                              Starting PsExec service on BP1LCSAP071...                                                                              Connecting with PsExec service on BP1LCSAP071...                                                                              Starting C:/Temp\RSCD81-SP5-WIN64.exe on BP1LCSAP071...                                                                              C:/Temp\RSCD81-SP5-WIN64.exe exited on BP1LCSAP071 with error code -2147213312.

      [2012-08-27|11:52:31] ExitValue = -2147213312

      [2012-08-27|11:52:31] PsExec Command has failed with exit value - -2147213312

      [2012-08-27|11:52:31] Agent install process with PsExec has failed

      [2012-08-27|11:52:31] Cleaning temporary files on: BP1LCSAP071

      [2012-08-27|11:52:36] Cleaned temporary files on: BP1LCSAP071

      [2012-08-27|11:52:36] No installers were successful. Exiting...

        • 1. Re: Bulk Agent Installer - Bladelogic 8.1

          What is the OS on which you are running this?


          You are using v1.73 of the psexec, upgrade it to the latest one from here-http://technet.microsoft.com/en-us/sysinternals/bb897553.aspx and test.


          Also see, https://kb.bmc.com/infocenter/index?page=content&id=KA329338

          1 of 1 people found this helpful
          • 2. Re: Bulk Agent Installer - Bladelogic 8.1

            It is saying some issue with resolving psexec,

            In case psexec fails to execute the commandline, the exit code returned by psexec will apply to psexec itself.


            psexec will ,however, write a brief diagnostic message on the console window telling you whether it succeeded or not, and if it did not succeed why not.

            psexec.exe \\remotemachine ipconfig.exe /all > psexec.log 2>&1


            Some time the remote application may cause psexesvc.exe process dying. There is a psexesvc.exe process which has no response in the remote server when this problem comes up.


            Please tried to use pskill.exe to kill psexesvc.exe process in the remote server and find remote application can't be called successfully. And this solve the problem


            This seems like a psexec error though Please check the registry entry on the server where PSExec is present

            Registry entry Present With one key per product, e.g. for psexec: "HKCU\Software\Sysinternals\PsExec"


            One more possible error would be  if your TEMP environment variable has been overriden. Make sure you have not defined a variable with that name.

            1 of 1 people found this helpful