8 Replies Latest reply on Jul 29, 2012 6:35 PM by Lazar NameToUpdate

    Unable to get shavlik XML

    Vinnie Lima

      Hi,

       

      Used to be able to point browser directly to http://xml.shavlik.com/data/PD5.xml and hfnetchk6b.xml but no longer able to. I get a garbled XML Parsing error from the shavlik site.

       

      Has something changed? I need these XML for a standalone BBSA 8.1 instance for Patch analysis.

       

      Even my offline patch downloader wont work anymore downloading from Shavlik.

       

      Thanks,

      Vinnie

        • 1. Unable to get shavlik XML

          The "garbled XML Parsing error" is expected, if you pasted those links to the browser. That's because the Internet Explorer is trying to output the contents of the xml file (by default). Since the XML is encrypted, you get garbled error.

           

          Not sure why the offline downloader would not work, but "garbled" responce actually implies that the files are there, otherwise you would have seen 404 error (one of few).

           

          Try wget to download the files.

          Or download the CAB version, and then extract the XML from within. (CAB version is like a zip file)

          1 of 1 people found this helpful
          • 2. Unable to get shavlik XML
            Vinnie Lima

            Is there an update I need for BBSA 8.1 SP2 to be able to extract CAB?  Getting the following when updating windows patch catalog:

             

            Error occur:  Level: F

            Type: EXECUTION_ERROR

            Message: ConvertXML.exe returned error (Exit code:1): Error Could not extract file ()from CAB file at '<path to hfnetchk6b.cab>'

             

            I just now downloaded the CAB files and updated the Patch Catalog to use it.

            • 3. Re: Unable to get shavlik XML

              Here's the KB that addressed your error message:

               

              KA361809 - BBSA Windows Catalog Update Job error: ConvertXML.exe returned error (Exit code: 1): Error Could not extract file ()from CAB file at '/[win_help_server]/tmp/temp_xxx/hfnetchk6b.cab'

              https://kb.bmc.com/infocenter/index?page=content&id=KA361809

               

              I try to publish a KB for every error message (especially in patching). If you find an uppublished error message, let me know.

               

              To fix the extraction issue would require for you to update root certificates on every target that's affected by the error message relevant to shavlik and cab (there are few of them). Easiest fix is to replace CAB links with XML.

               

              Edit:

              Here's the KB that mentions the root certificates fix as well:

              KA370265 - BBSA Windows Patch Catalog, Analysis, Hotfixes error: 80004005 Downloaded Cab file '[temp_folder]/hf7b.cab' is not trusted.

              https://kb.bmc.com/infocenter/index?page=content&id=KA370265

              1 of 1 people found this helpful
              • 4. Re: Unable to get shavlik XML
                Vinnie Lima

                So to clarify where this started from....

                 

                Trying to run the Offline Patch Downloader and I get the following error:

                 

                null

                Downloader finished with return status - 1

                 

                 

                I dont know if its the version of offline patch downloader or something else....We are using the 8.1.2 downloader and the XML we are using is below:

                 

                <windows-downloader-config>

                    <config>

                        <temporary-location>F:\win_patch_helper_temp</temporary-location>

                        <validate-payload-certificate>true</validate-payload-certificate>

                        <payload-repository-location>F:\win_patch_repo</payload-repository-location>

                        <download-request-retries>10</download-request-retries>

                        <download-request-timeout>180000</download-request-timeout>

                        <downloader-parallel-threads>10</downloader-parallel-threads>

                    </config>

                    <subscription>

                        <products>

                            <include-product>               

                                   <product-category>Microsoft Windows Server 2008</product-category>

                                <product-category-language>English</product-category-language>                     

                            </include-product>

                      </products>

                    </subscription>

                </windows-downloader-config>

                • 5. Re: Unable to get shavlik XML

                  the previous error was from catalog update job. the last email talks about offline downloader run. there are two separate issues, and I'm not sure how they are connected.

                   

                  for the offline downloader run. there should be downloader.log with possibly a stack trace. can you paste it? have you found any hits in the KCS?

                  • 6. Re: Unable to get shavlik XML
                    Vinnie Lima

                    One issue lead to another.  Goal here is offline patch download for Windows.  Ran into Offline patch download issue, tried the Online mode (then ran into the XML download issue).

                     

                    downloader.log has the same info returned to stdout.

                    • 7. Re: Unable to get shavlik XML
                      Vinnie Lima

                      Grrr:

                       

                      https://kb.bmc.com/infocenter/index?page=content&id=KA354674&actp=search&viewlocale=en_US&searchid=1343411356427

                       

                      The one time I dont look in the KCS

                       

                      But I followed the instructions in the KB and still get the same error.  I did move the old JAR out of the offline patch downloader's libs directory and placed the new one.

                       

                      I'll open a case with support as well.

                       

                      Thanks.

                      • 8. Re: Unable to get shavlik XML

                        it must be failing with something else now... the fix with the new jar has always worked to resolve that particular issue. paste the error from downloader.log (unless you opened a ticket)