1 Reply Latest reply on Jul 19, 2012 8:00 AM by Shantanu Ballal

    Cannot deploy views correctly for work orders

      Share This:

      Hi,

       

      I'm trying to solve - on SRM 7.6.00 - the bug that you cannot specify the WOI:WorkOrder form in Classic view.

       

      To do this, I've added two entries to the View Definition form (SYS:ViewSelectionRoleDefinition):

      Record #1  

         Application Name: Remedy Service Request and Catalog System

         Form Name: WOI:WorkOrder

         View Name: Default User View

         Role: WO Classic View User

       

      Record #2  

         Application Name: Remedy Service Request and Catalog System

         Form Name: WOI:WorkOrder

         View Name: Simplified User View

         Role: WO Best Practice View User

       

      Furthermore, I've added two to the SYS:ViewSelectionRoleCompanyLookup form:

      Record #1  

         Company: - Global -

         Application Name: Remedy Service Request and Catalog System

         Role: WO Best Practice View User

         Role Instance ID: AG0050569C6882hc4dSgSblcBAUqsA (as found in 7.6.4)

       

      Record #2  

         Company: - Global -

         Application Name: Remedy Service Request and Catalog System

         Role: WO Classic View User

         Role Instance ID: AG0050569C68821dEdSgTKlpBAdLIA (as found in 7.6.4)

       

      Thus, I was able to deploy the Classic view for Work Orders.

       

      However, the form does not show in Classic view, it always show in Best Practice view.

      Perhaps I use the wrong Role Instance ID?

      Perhaps I need to undertake one or several additional steps to make this work?

       

      Can somebody help?

       

      Thanks in advance.

       

      Best Regards,

      Werner

        • 1. Re: Cannot deploy views correctly for work orders

          Werner,

           

          I was facing a similar issue as mentioned by you. I do not know if it is a known defect or what. I tried a lot many time but still the form opens in a Best Practice view. When I checked from developer studio I found that there is no classic form available for work order. WOI:WorkOrder form is having two views 1. Simplified User View and 2. Default User view. and the default view for this form is "Simplified user View which I changed from

           

          Default View WO.jpg

          Default User View WO.jpg

          Choose the default view as "Default User View" and not a simplified user view.

           

          Now you would be able to see the form in classic view kinda.

           

          But it will be for all the users as the view is changed at form level.

           

          May be it is defect. I am using SRM 7.6.04 SP2 version.

           

           

          Cheers!!

          Shantanu