3 Replies Latest reply on Jul 16, 2012 8:58 AM by Lazar NameToUpdate

    The error with redhat5 32 patch analysis error

      Hi all:

         my redhat5 32 analysis job had crated in 2012.03.11.   before may,this job was operting normally. but the job has error now. and all the target server has the same error:

       

       

      STDERR: ERROR::YUM dry run failedERROR::*******************************************ERROR::YUM unable to complete analysis for either of the following reasonsERROR::-- An rpm required as a part of dependency is in the exclude listERROR::-- The patch respository is incomplete and dependencies are missing in repositoryERROR::YUM listed errors belowERROR::*******************************************ERROR::Missing Dependency: nss = 3.13.1-5.el5_8 is needed by package nss-tools-3.13.1-5.el5_8.i386 (repo)ERROR::*******************************************ERROR::YUM unable to complete analysis for either of the following reasonsERROR::-- An rpm required as a part of dependency is in the exclude listERROR::-- The patch respository is incomplete and dependencies are missing in repositoryERROR::YUM listed errors belowERROR::*******************************************ERROR::Missing Dependency: nss = 3.13.1-5.el5_8 is needed by package nss-devel-3.13.1-5.el5_8.i386 (repo)ERROR::*******************************************ERROR::YUM unable to complete analysis for either of the following reasonsERROR::-- An rpm required as a part of dependency is in the exclude listERROR::-- The patch respository is incomplete and dependencies are missing in repositoryERROR::YUM listed errors belowERROR::*******************************************ERROR::Missing Dependency: libnss3.so(NSS_3.13) is needed by package nss-tools-3.13.1-5.el5_8.i386 (repo)ERROR::*******************************************ERROR::YUM unable to complete analysis for either of the following reasonsERROR::-- An rpm required as a part of dependency is in the exclude listERROR::-- The patch respository is incomplete and dependencies are missing in repositoryERROR::YUM listed errors belowERROR::*******************************************ERROR::Missing Dependency: nss >= 3.13.1 is needed by package xulrunner-10.0.3-1.el5_8.i386 (repo)ERROR::*******************************************ERROR::YUM unable to complete analysis for either of the following reasonsERROR::-- An rpm required as a part of dependency is in the exclude listERROR::-- The patch respository is incomplete and dependencies are missing in repositoryERROR::YUM listed errors belowERROR::*******************************************ERROR::Missing Dependency: libnssutil3.so(NSSUTIL_3.13) is needed by package nss-tools-3.13.1-5.el5_8.i386 (repo)

       

       

      THSKS

      SANHO

       

        • 1. The error with redhat5 32 patch analysis error
          Shirish Katariya

          Hi Sanho,

           

                             Did you Updated the RHpatches on boxes between this time duration??? According to these logs Yes You Did it. Right??? The Error is occuring because of it. Because Its showing in error:: "The patch respository is incomplete and dependencies are missing in repositoryERROR::YUM listed errors".

          This error has many reasons, either the patching job was unsuccessful, or may be it was aborted in between, thats why the patches were not successfully updated. and some files were missing those are required for running this job. So kindly create a new job with latest patches and run it.

           

          Thanks,

          Shirish Katariya.

          • 2. The error with redhat5 32 patch analysis error

              1. make sure you have run a Catalog Update on the Catalog on which this Job is based. This will make sure that all the rpms required are in the repository

            2. If this is a list based analyis job, make sure the rpm it is reporting is not in excluded list

            What is the job based on ?

             

            Thanks,

            Rohit

            1 of 1 people found this helpful
            • 3. The error with redhat5 32 patch analysis error

              Also review the following kb for the explanation and general troubleshooting for such error message. In your case, as others mentioned, the rpms are either missing from the repo, or you intentionally put them in the exclude filter.

              Start by updating the catalog and removing exclude filter (if present) to get the most accurate results, and then take it from there.

               

              KA356911 - Linux Patch Analysis: How to troubleshoot error: Missing Dependency: [rpm1] = [version] is needed by package [rpm2-version.arch] (repo)

              https://kb.bmc.com/infocenter/index?page=content&id=KA356911