2 Replies Latest reply: Jun 29, 2012 11:24 AM by Jeff D. RSS

Solarwinds Orion ETL Template Configuration

Jeff D.

Hello,

 

I am attempting to configure the Solarwinds Orion template and have run into a few issues.  I have successfully imported the template into BCO using Integration Studio and am able to configure it in BCO.  Our Solarwinds installation is running on a Windows 2008 Server R2 running SQL Server 2008.  The service account I am using has been granted access to the Solarwinds dB as well. 

 

Here are my questions:

 

1) What are the settings & format for the ETL Connector itself?  See below for the format I've been using.

 

Screen shot 2012-06-29 at 8.50.44 AM.png

2)  Is there any additional setup required to connect to MS SQL Servers in general and SQL 2008 in particular? 

 

I am receiving the following errors on simulation the ETL, which I assume are due to an inability to connect to the database.

 

Screen shot 2012-06-29 at 8.51.18 AM.png

 

Thanks in advance!

 

Jeff

  • 1. Re: Solarwinds Orion ETL Template Configuration
    Renato Bonomini

    Hi Jeff!

     

    Have you configured the freetds driver to include the definition of the database server?

    Lookup  KA353505 which refers to the BPPM ETL but is similar.

     

    In short, you need to create an entry in

    $CPITBASE/etl/freetds/etc/freetds.conf

    and use that to configure the database connection.

     

    Please notice that freetds might not work with NT authentication, SQL-Server native authentication is recommended.

     

    Let me know if it helps,

    Renato

  • 2. Solarwinds Orion ETL Template Configuration
    Jeff D.

    Thank you for your help, Renato.  After some back and forth, this is what finally fixed it for me.

     

     

    Configured freetds.conf with the following:

     

    [Orion]

         host = <<Server Name>>

         instance = <<SQL Instance Name>>  ; In my case they were the same

         port = <<Port #>>    ;In my case, the above instance was listening on a non-standard port

         tds version = 7.0     ;this setting didnt' seem to matter

     

    At this point, I ran the command-line utility as described in the KA article and it failed. I changed my username to <<Domain>>\\<<Service Account Name>> (note the escape character) to get it to function properly. 

     

    After reviewing the testconnection.txt file that was output by the command-line test, I noticed that I was being put in MASTER.  I asked our DBA to make the default database to our Solarwinds DB.  This appeared to have me log in directly to where the ETL needed to be.

     

    I suspect, however, that if I need to do an ETL from another dB on the same dB server that I'll need to find a better solution.

     

    I then reconfigured the ETL to match my freetds.conf settings as described.  Simulations continued to fail until Renato pointed out that I didn't need the escape character on the ETL side. 

     

    The simulation ETL is currently running and, assuming that it completes successfully, I'll run a full import later today.

     

    Thanks again!

     

    Jeff