1 2 Previous Next 15 Replies Latest reply on Jun 29, 2012 4:38 AM by Fred Breton

    Weblogic_BLRoot exception

      Share This:



      I am getting error while running DCO job - Ignoring class weblogic_blroot class not applicable on target server.


      I have Instalelled BBSA 8.2 SP1.

      My weblogic application server is on Solaris 9.2 server on which I have installed RSCD agent. I have set all custome object property class values as required. When I execute DCO job I am getting exception as weblogic_BLRoot class not applicable.




        • 1. Weblogic_BLRoot exception

          With 8.2, to manage Weblogic or/and WebSphere, you need too component: a server with an RSCD agent and client libraries of you JEE server (usually the full binary of your JEE application server). Not all OS that support RSCD are supported to act as a proxy. Solaris 9.2 is not supported (the supported OS).


          How ever you can manage a JEE application server that is not running on a proxy supported platform as the manangement is done thru the standard SOAP port, so there's no need to the proxy to be on a domain manager.

          A proxy could manage several Application server domains/cells of the same flavour and version. To so so, at BAA level, we use an Agentless Manage Object (AMO) to have a logical representation of the application server infrastructure (and so to not be server centric). All management, configuration, deployment operation need to go thru the AMO.


          Did you create an AMO for your Weblogic domain and run the DCO job targetting the AMO?

          Have a look on this doc part about AMO creation.

          • 2. Weblogic_BLRoot exception

            Thanks Fred,


            My environment details are as below . .


            I have Win2k3 on which I have deployed BBSA 8.2.

            I have one target server Solaris 10 on which I have installed RSCD (took another server as 9.2 is not supported). Now on same server Weblogic application server is running. How do I create AMO? I tried but not able to do so as it says server already exists.


            I tried executing DCO job for this server and now I am getting "no applicable classes for target" exception. I checked all custom property class. but no luck.




            • 3. Weblogic_BLRoot exception

              If you look on the links I provided on my previous post you'll see that Solaris is not a supported OS to be JEE application server proxy. You can also see that the AMO name should be not resovable as an RSCD server.


              In your environment, you can use your win2k3 as proxy server (you need to have weblogic binary installed, but don't need to start it). You setup the ARA_WL_PROPERTIES for all directories, files to point to your win2k3 env, and the ARA_APPSERVER to your weblogic domain manager (I guess your solaris box) with the right SOAP port and user/password name.


              However, it maybe good to get a BAA training .


              I hope this help.


              • 4. Weblogic_BLRoot exception

                Yes Fred,


                I am new to this BAA and didn't get training on this. Thanks for your help.

                I will figure out what I can do.




                • 5. Weblogic_BLRoot exception

                  BDW in the link you have provided have mentioned the supported server as Oracle Solaris 10, 32-bit. I am using same OS here for proxy server.




                  • 6. Weblogic_BLRoot exception

                    Sorry, you're right, I always forget that Oracle own Solaris


                    So, you're on good track. To create an AMO, just use a name that you're not able to resolve, You just need a logical name. You can use your WebLogic domain name for example, then:

                    1.      in the AMO property AGENTLESS_MANAGED_OBJECT_PROXY_HOST, associate your Solaris box (that is your proxy, collocated with your domain manager)
                    2. in th AMO property ARA_WL_PROPERTIES, associate the instance of the class in which you defined all connection parameters to your domain manager.
                    3. deploy the WebLogic CO on the AMO.



                    Then when you browse the AMO, you should see a WL object and rightclicking on it you should be able to do a refresh provider to populate it.


                    Hope this help.


                    1 of 1 people found this helpful
                    • 7. Weblogic_BLRoot exception

                      Thanks Fred,


                      I will try this . . otherwise I will use some other server as proxy and try to connect weblogic server using SOAP port.

                      Lets see if this works . I will post updates here.




                      • 8. Weblogic_BLRoot exception

                        Hey Fred,


                        It worked . DCO successfully executed.

                        Now the problem is I am not able to brows the applications. I tried to "refresh provider data" bit it throws error returning null. Now the confusion is - To successfully brows or discover it is require that the application server should be in running. is it correct ??




                        • 9. Weblogic_BLRoot exception

                          It is done

                          Now I am able to brows too. had issue with Weblogic connection. There was port issue. it is fixed now.

                          your suggestions helped lot. Thanks a lot Fred,




                          • 10. Weblogic_BLRoot exception

                            You're wellcome. I'm pleased that I can help.


                            New technical forum place will be created under BMC Application management and I plan to publish some how to for BAA, BMA and BRPM firts implementation step could be easier.

                            • 11. Weblogic_BLRoot exception

                              Hey Fred,


                              have you ever observed BBSA console hang issue. I have 3 weblogic servers which I have successfully added on console and also ran the DCO job successfully. One of them is Weblogic8 while other 2 are Weblogic 8.1. I am able to brows weblogic8 server but while brows others 2 console goes in hang state. I am getting below error in appserver as well as in console log -


                              [28 Jun 2012 20:06:49,939] [Client-Connections-Thread-0] [WARN] [BLAdmin:BLAdmins:] [Client] Failed to send message to client

                              com.bladelogic.om.infra.mfw.util.BlException: Connection reset by peer: socket write error

                                  at com.bladelogic.om.infra.mfw.net.BlSessionServerConnection.write(BlSessionServerConnection.java:260)

                                  at com.bladelogic.om.infra.mfw.net.BlSessionServerConnection.write(BlSessionServerConnection.java:281)

                                  at com.bladelogic.om.infra.mfw.fw.ClientDataStreamImpl.write(ClientDataStreamImpl.java:25)

                                  at com.bladelogic.om.infra.app.util.ServerUtil.sendDataToClient(ServerUtil.java:45)

                                  at com.bladelogic.om.infra.message.app.frame.APIMessageFrame.service(APIMessageFrame.java:154)

                                  at com.bladelogic.om.infra.mfw.net.ClientWorkerThread.processRequest(ClientWorkerThread.java:385)

                                  at com.bladelogic.om.infra.mfw.net.ClientWorkerThread.processClientRequest(ClientWorkerThread.java:282)

                                  at com.bladelogic.om.infra.mfw.net.ClientWorkerThread.handleClientRequest(ClientWorkerThread.java:182)

                                  at com.bladelogic.om.infra.mfw.net.ClientWorkerThread.execute(ClientWorkerThread.java:101)

                                  at com.bladelogic.om.infra.mfw.net.ClientWorkerThread.execute(ClientWorkerThread.java:27)

                                  at com.bladelogic.om.infra.app.service.thread.BlBlockingThread.run(BlBlockingThread.java:95)



                              Any idea ??




                              • 12. Weblogic_BLRoot exception

                                I guess you're using the same proxy server for all your weblogic domains. If it's the case, that is the issue as you can manage several domains from one proxy but they need to be on the same Weblogic version. So you need to use one proxy for 8 and one proxy for 8.1.


                                That said, we officailly supporte WebLogic 8.1 but not 8.0

                                • 13. Weblogic_BLRoot exception

                                  Thanks fred,


                                  But I am using 2 separate oracle Solaris 10 server as proxy for rest of two servers (Weblogic 81). I also tried de-registering CO and again running DCO job. job is executed successfully but no luck in browsing the webelogic application. Console goes in hang state .




                                  • 14. Weblogic_BLRoot exception

                                    Ok Now I got the popup error message that say -


                                    A timeout occurred while making an RPC call : on host <hostname> and proxy host <IP of proxy>




                                    1 2 Previous Next