8 Replies Latest reply on Jun 18, 2012 1:28 PM by Mike Reider

    Oracle Linux provisioning - repodata

    Mike Reider

      Hi all, Im trying to provision Oracle Enterprise Linux 6,


      I setup a new sytem package based on RHEL6, copied the OEL installation files (taken from the .iso that I downloaded from Oracle) to the pxestore,




      When I run the provision job, it boots the kernel, starts creating the swap space, everything looks ok, until it gets to the repo, then I get this error



      there is a repodata directory in the Server directory (this is all straight from the .iso media)




      Im stuck on why its failing.


      BL v 8.2, on Win2008x64, SQL2008


      also - when I click Edit, it says its not available, basically the only option I have is to quit the provisioning screen, after which it exits and reboots the machine to a blank state.

        • 1. Oracle Linux provisioning - repodata
          Bill Robinson

          iirc the issue is a symlink from the cd not copying correctly on windows.  if you can use oel 6.1 or 6.2 i don't think that media has this issue. 

          • 2. Oracle Linux provisioning - repodata
            Mike Reider

            Hi Bill, I tried using the 6.2 ISO


            Oracle Linux Release 6 Update 2 for x86 (32 Bit)


            part number V29609-01




            I copied over all the files from the .iso mount to the pxestore




            ran the prov job, getting same exact error, cant retrieve repository metadata.


            I setup RHEL the same exact way and it seemed to work, from what I understand Oracle linux is pretty much RHEL with different logos and graphics.

            • 3. Oracle Linux provisioning - repodata
              Hemal Shah

              1) Copy the initrd and vmlinux, fresh from the new iso from the folder isolinux to the tftproot/X86PC/pxelinux/<somefolder>

              2) Update the SPT with the path to the above copied vmlinux and initrd.


              This should help resolve the issue

              • 4. Re: Oracle Linux provisioning - repodata
                Mike Reider

                update on OEL provisioning


                after testing prov on OEL 6.0, 6.1, 6.2, we could not get it to provision due to metadata repository errors, this is likely due to the version 6 having an incomplete/faulty folder structure,


                this is 6.2, the Server folder does not containany RPM files, all RPMs are instead kept in root > Packages folder



                the RPMs are not present in teh Server directory (instead they are in Packages folder), also in the Server/repodata folder, the files for OEL6 dont look correct, they are missing extensions, and the repomd.xml is referencing files that have extensions, these extensions are missing on the actual files

                repomd.xml for OEL 6.2




                In 5.8, the files look correct, without the long number strings, and the repomd.xml is refercing the correct files



                all the RPMs are in the Server directory,




                We got 5.8 to provision correctly.



                This doesnt look to be anything related to  bladelogic, looks like its the way Oracle packaged 6.x on their install media,its breaking the provisioning process.


                As of this time, it doesnt looke like OEL 6.x  is compatible with BL provisioining process.

                • 5. Re: Oracle Linux provisioning - repodata
                  Bill Robinson

                  This works fine if the datastore is linux, so there is no issue w/ BSA running kickstart w/ OEL6. 


                  in the root can you delete the 'repodata' directory if it exists, and then copy the Server/repodata folder and its contents to the root (OEL62_x64 in your case) ?

                  • 6. Re: Oracle Linux provisioning - repodata
                    Mike Reider

                    Hi Bill, we got an update from support that mentions pretty much that,


                    to make OEL 6.2 work,


                    1. delete the repodata file (0kb) from the root of the install media

                    2. move the repodata folder from Server folder to the root of the install media

                    3. open up the repomd.xml and add the extensions that are mentioned to the actual files in the repodata folder (the actual files dont have the extensions, so append them to the files)




                    1f837393fd36e52cd5f50882638691fadd118270616b2a80f0c71cdb00b99be0   ---->



                    this should provision 6.2 sucessfully, I tried it on my VM and it worked.

                    • 7. Re: Oracle Linux provisioning - repodata
                      Bill Robinson

                      Ok – I didn’t realize you needed to make any changes to repomd.xml as well.  it’s probably not very common to source a kickstart install from a windows box.  I wonder if you could create a junction for the top level repodata folder – that should be analogous to a symlink – as this works fine on a unix file system which understands symlinks.

                      • 8. Re: Oracle Linux provisioning - repodata
                        Mike Reider

                        actually the repomd.xml file isnt being modified, you only have to change the files in the repodata folder to match whatever the repomd.xml is referencing, so


                        if repomd.xml is referencing this file




                        change the file 1f837393fd36e52cd5f50882638691fadd118270616b2a80f0c71cdb00b99be0


                        name to add the extention mentioned in the XML file.