2 Replies Latest reply on Jun 11, 2012 7:41 AM by Prabhat Handoo

    Bladelogic Data Migration Error 7.6 to 8.2.01

      Migration from  7.6.0,7.7.0 TO 8.0.0 succeeds:

      ****** FINISHED ****** SINGLE STEP MIGRATION FROM 7.6.0,7.7.0 TO 8.0.0

      FROM CONFIG FILE D:\Data\Migrate\upgrade\7.6.0_to_8.0.0\OM\Migration_actions\

      WITH **NO** ERRORS

       

      Migration from 8.0.0,8.0.6,8.0.8 TO 8.1.1 fails:

      [08 Jun 2012 17:08:54,961] [Thread-7] [INFO] [::] [] EXCEPTION WHILE RUNNING SINGLE STEP MIGRATION FROM 8.0.0,8.0.6,8.0.8 TO 8.1.1
      ============================================================================================
      [1] ERROR: TSK NM=mig_upgrade_table_9105  ; TSK SCR NM=    ; TO=8.1.1  ; TSK MSG=Could not create constraint. See previous errors.                                                                                      
      [2] ERROR: TSK NM=mig_upgrade_table_9105  ; TSK SCR NM=    ; TO=8.1.1  ; TSK MSG=Upgrade halted. mig_upgrade_table_9105 did not complete step populate table at point 108.  Contact BladeLogic Support before resuming. 
      .
      .
      ****** FINISHED ****** SINGLE STEP MIGRATION FROM 8.0.0,8.0.6,8.0.8 TO 8.1.1
      FROM CONFIG FILE D:\Data\Migrate\upgrade\8.0.0_to_8.1.0\OM\Migration_actions\
      WITH **2** ERRORS
      .
      .
      [08 Jun 2012 17:08:54,961] [Thread-7] [INFO] [::] []
      ============================================================================================
      DISPLAYING ALL THE ERRORS
      ============================================================================================

      [08 Jun 2012 17:08:54,961] [Thread-7] [INFO] [::] [] [1] SingleStepMigrationResult: TSK NM=mig_upgrade_table_9105  ; TSK SCR NM=    ; TO=8.1.1  ; TSK MSG=Could not create constraint. See previous errors.                                                                                      
      [2] SingleStepMigrationResult: TSK NM=mig_upgrade_table_9105  ; TSK SCR NM=    ; TO=8.1.1  ; TSK MSG=Upgrade halted. mig_upgrade_table_9105 did not complete step populate table at point 108.  Contact BladeLogic Support before resuming. 

      [08 Jun 2012 17:08:54,961] [Thread-7] [INFO] [::] [] Any error=true;; Framework error=false;; Data error=true

      [08 Jun 2012 17:08:54,961] [Thread-7] [INFO] [::] []
      ============================================================================================

      [08 Jun 2012 17:08:54,976] [Thread-7] [INFO] [::] [] MIGRATION FRAMEWORK WAS SUCCESSFUL
      [08 Jun 2012 17:08:54,976] [Thread-7] [INFO] [::] [] DATA MIGRATION WAS NOT SUCCESSFUL AND DID NOT FINISH BECAUSE THERE WAS AN ERROR
      [08 Jun 2012 17:08:54,976] [Thread-7] [INFO] [::] [] Total time: 35 minutes 15 second(s)
      [08 Jun 2012 17:08:54,976] [Thread-7] [INFO] [::] []
      ============================================================================================

       

      I have attached the migration.log.

       

      Any ideas?

      Thanks


      Joe