11 Replies Latest reply on May 14, 2012 11:44 AM by russ mcdowell

    Problem installing compliance content for 8.2

    russ mcdowell

      I am attempting to install the compliance content for 8.2 onto a windows 2008 r2 64bit virtual machine.  this machine is also running my console and appserver software and is also my BL file server.

       

      There was no previous installation of complaince content on this machine.

       

      I verified the RSCD agent was running before beginning the install.

       

      I added the installed to DEP.

       

      Because this is windows I kicked off Content-Windows-Setup.exe

       

      I Next through the welcome screen

       

      I accepted the License Agreement

       

      I provided BLAdmin & password for a profile w the server name, no other profiles existed at this time

       

      Credentials passed check

       

      Problem popped up when Appserver validation failed.

       

      I tried a couple different profile variations, FQDN and IP among them for hostname.

       

      In re-examining the documentation I discovered I had not done the Installer prereqs for Windows on pg 62.  I cancelled the install and had the machine moved to a new GPO OU since it is a domain member and GPO governed the offending properties.  Upon restart I ran gpupdate /force and rebooted again for good measure.

       

      Now when I kick off the installer I next past the welcome screen and agree to the licensing, it immediately goes to Validating BladeLogic profiles, creating a new one or selecting a different profile is no longer an option, and I am taken to "Please enter the name of the applications erver onto which the content templates will be loaded."  In the Application Server field is the IP of the machine.  This is a single server set up but when I hit Next it fails the Validating appserver list check.

       

      What should I do to correct this?

        • 1. Problem installing compliance content for 8.2

          Do you see anything logging the appserver.log when this error happens? Is the rscd on this server at 8.2 as well?

          • 2. Problem installing compliance content for 8.2
            russ mcdowell

            I don't see anything of apparent value in the appserver.log

             

            Add/Remove programs shows the 8.0.10.1014 agent as well as the 8.2.0.158.  The Console shows the agent version for my appserver to be 1,014 however - which I assume means it still sees the old.

            With that I go back to add/remove programs, highlight 8.0.10.1014 and hit uninstall and get a window saying a newer version is installed do I want to remove RSCD, which I assume is referring to the newer.

            • 3. Problem installing compliance content for 8.2

              I think this is a problem with the agent mismatch. The agent should be on 8.2 as well. I remember seeing a similar issue here on communities which was fixed by re-running the 8.2 agent. There is a Bladelogic registry where the value is picked. If possible, you can uninstall agent and then install the correct version again.

              • 4. Problem installing compliance content for 8.2
                russ mcdowell

                I re-ran the 8.2 RSCD install with no impact.

                 

                I ran the uninstall on the 8.0.10 entry in add/remove programs and ran the repair on the 8.2.  After reboot the appserver service won't start so I'm worse off now than I was before.  Way it goes, right?

                 

                This is from the console.log

                [14 May 2012 08:01:15,190] [main] [ERROR] [::] [] File server validation failed because either the file server is not specified, cannot be contacted, or sufficient permissions are not granted on the file server agent to the appserver. Please verify the connectivity between appserver and file server and ensure that the appserver has read write permissions on the file server.

                [14 May 2012 08:01:15,190] [main] [ERROR] [::] [] Error installing to Start: name=bladelogic.service.FileManagerService state=Create

                com.bladelogic.om.infra.app.service.ServiceInitializationException: com.bladelogic.om.infra.mfw.util.BlException: File server validation failed because either the file server is not specified, cannot be contacted, or sufficient permissions are not granted on the file server agent to the appserver. Please verify the connectivity between appserver and file server and ensure that the appserver has read write permissions on the file server.

                • 5. Problem installing compliance content for 8.2

                  If I understand correctly, now you have 8.2 agent and appserver but the appserver does not start. Correct me if I am wrong.

                   

                  Is the appserver and fileserver on the same server? If yes, follow the recommendations for doing so at the https://kb.bmc.com/infocenter/index?page=content&id=KA316223&actp=search&viewlocale=en_US&searchid=1337002075235 article. You may want to add the line System:System rw,user=<username> in the users.local file.

                   

                  The error you are getting means that the appserver cant connect to the fileserver. If the fileserver is a different server other than the appserver, check connectivity. But I feel if you have landed in this issue now, fileserver resides on the appserver itself.

                   

                  Check the article and make that change. Hope this helps.

                  1 of 1 people found this helpful
                  • 6. Problem installing compliance content for 8.2
                    russ mcdowell

                    You are correct.  Add/remove programs now reflects just the 8.2 RSCD and appserver and console are at 8.2 as well.  The file server is local too.

                     

                    I will start on that KB article and let you know what I find.  I appreciate the assistance!

                    • 7. Problem installing compliance content for 8.2

                      yeah, in that case I feel that somehow the users.local must have got removed from the old instance. Check the KB with recommendations for setting fileserver on the appserver. Most of the issues I have seen are because of the system:system mapping missing.

                       

                      Once the appserver is up and running, you could test the original issue of content. I hope both the issues are related and get fixed.

                       

                      Good luck!

                      • 8. Problem installing compliance content for 8.2

                        Also confirm by running Version for rscd, there is a file for so to confirm the agent is on 8.2.

                        • 9. Problem installing compliance content for 8.2
                          russ mcdowell

                          I edited the exports file and copied over users and users.local as those two were missing.  I assume they're still needed.

                          I rebooted the system and am waiting for it to come up now.

                          • 10. Problem installing compliance content for 8.2
                            Bill Robinson

                            you need to have a mapping entry for the OS user running the installer on each of the appserver agents.  so if you run the installer as 'russm' you would need to have something like:

                             

                            russm  rw,map=Administrator

                             

                            in the users.local on your appserver agents.

                             

                            or you could have:

                             

                            * rw,user=Administrator

                             

                            in the exports file and make sure the users file does not contain the 'nouser' entry.

                             

                            if you do that i'd revert the exports file after you are done w/ the install.

                             

                            it looks like you are doing that ?

                            1 of 1 people found this helpful
                            • 11. Problem installing compliance content for 8.2
                              russ mcdowell

                              That ended up being the problem.  First it was both RSCD versions (8.0.10 and 8.2.0) being somehow present.  Then, with the removal of 8.0.10 it was the loss of that mapping.

                               

                              I suppose for future upgrades the local 8.0.10 RSCD should be removed then the appserver and console updated and then a fresh install of the 8.2 RSCD should be done.  I have to do this again later for another BL environment I support that is independant of this one.