5 Replies Latest reply on Mar 22, 2012 5:37 PM by Alejandro González

    AppServer service fails to start

    Alejandro González

      Hi i have a problem, AppServer service fails to start, the log says the next:


      [20 Mar 2012 16:37:50,631] [main] [INFO] [::] [] Validating file server host (prod500ws02)...

      [20 Mar 2012 16:37:52,924] [main] [ERROR] [::] [] File server validation failed because either the file server is not specified, cannot be contacted, or sufficient permissions are not granted on the file server agent to the appserver. Please verify the connectivity between appserver and file server and ensure that the appserver has read write permissions on the file server.


      when i try to run the command:  agentinfo <hostname> the next message is showing:



      Can't access host "prod500ws02": No authorization to access host


      i chek that in Windows\rsc the users.local and exports have the rigth configuration.


      i dont know what happend.


      Thank you for youre help.

        • 1. Re: AppServer service fails to start
          Bill Robinson

          Is there a ‘nouser’ line in the users file?

          What are the contents of each file (users, users.local, exports) – it’s not clear what you mean by ‘right’ config.


          Also, you may need to put an entry in users.local:


          System:System rw,map=Administrator


          (or root)

          • 2. AppServer service fails to start

            All that Bill mentioned above. Apart from that,

            See the kb https://kb.bmc.com/infocenter/index?page=content&id=KA316223&actp=search&viewlocale=en_US&searchid=1332163487498

            This has more insight on how file servers should be set with BBSA. Hope this helps.

            • 3. AppServer service fails to start
              Alejandro González

              Thanks Bill Robinson and prabhathandoo for youre response, this is my configuration:


              1. users.local


              #  Copyright (c) 2001-2012 BladeLogic, Inc.

              #       -- All Rights Reserved --


              # This file contains a list of user permission overrides. The permissions

              # defined in this file will override any associated permissions defined in the

              # "exports" or "users" file.


              # Please read the BMCBladeLogicAdministration.pdf for details on how to use this

              # file.


              BLAdmins:BLAdmin    rw,map=monseg

              System:System       rw,map=monseg


              System:System rw,map=Administrator


                2. users



              # This file was automatically generated by the Configuration Manager RBAC console.

              # Any changes to this file will be lost upon the next update by the RBAC

              # console. Local changes should be made in the users.local file


              # The special characters listed below get automatically encoded. For example,

              # "Configuration Manager Administrator" becomes "Configuration%20Manager%20Administrator".

              # '%' --> %25

              # ',' --> %2c

              # ':' --> %3a

              # '#' --> %23

              # ' ' --> %20

              # TAB --> %09


              # Date created: Wed Mar 07 12:17:32 CST 2012

              # Created by BLAdmins:BLAdmin from Application Server PROD500WS02 running on host PROD500WS02

              # BLAdmins ACLs

              BLAdmins:BLAdmin        rw,map=monseg


              # NSH-only ACLs

              BLAdmin                 rw,map=monseg





                   3. exports


              #  Copyright (c) 2001-2012 BladeLogic, Inc.

              #       -- All Rights Reserved --


              #  This file is read by the "rscd" to determine permissions for the given host.


              # Please read the BMCBladeLogicAdministration.pdf or "exports" man page for details

              # on how to use this file.


              *   rw,user=monseg


              and when i run te Aplication Server Configuración Wizard the next error is shown:




              i dont  know why, i installed BBSA 8.2 and it is supposed that this version of Bladelogic does not need a license.


              Thank you for your Help.

              • 4. AppServer service fails to start

                In your users.local file, change  System:System rw,map=Administrator to System:System rw,map=monseg

                Restart the rscd service and then try.


                This is an issue with blappconf uitilty in 8.2 and has been fixed in 8.2 SP1.


                Also try removing nouser in users file if the above does not help.


                This maybe an issue around user mapping. Show a copy of rscd.log if the above does not help.



                • 5. AppServer service fails to start
                  Alejandro González

                  Thnaks for youre assistance the problem was solved.


                  I reinstalled the RSCD then i run the executble of the Appserver (BBSA82-WIN64.exe) and i select the Repair option, and thats all my Appserver works fine.


                  Thankyou very much i apreciate the help.



                  Have a nice day.