5 Replies Latest reply on Mar 6, 2012 4:28 AM by Joe Piotrowski

    AppServer service fails to start after reinstalling RSCD Agent

    Joe Piotrowski

      I have (3) AppServers running BBSA 8.1.02. They were running RSCD Agents 8.1.04. I uninstalled the 8.1.04 Agents on the AppServers and installed an older Agent version (8.1.02 P3) on each AppServer.


      The AppServer service now fails to start. When I check the appserver.log I see this error message:

      [06 Mar 2012 09:02:57,281] [main] [ERROR] [::] [] NSH Directory need to be set

      [06 Mar 2012 09:02:57,281] [main] [ERROR] [::] [] Error installing to Start: name=bladelogic.service.FileManagerService state=Create

      com.bladelogic.om.infra.app.service.ServiceInitializationException: com.bladelogic.om.infra.mfw.util.BlException: NSH Directory need to be set


      I attempted to run blasadmin.exe and it fails. I get a Windows APPCRASH error message saying "blasadmin.exe has stopped working."


      When I attempt to run nsh from a cmd Window I get the following error:

      D:\Software\BMC Software\BladeLogic\8.1\NSH\bin>nsh

            1 [main] nsh 2432 exception::handle: Exception: STATUS_ACCESS_VIOLATION

          574 [main] nsh 2432 open_stackdumpfile: Dumping stack trace to nsh.exe.stackdump


      The contents of nsh.exe.stackdump:

      Exception: STATUS_ACCESS_VIOLATION at eip=0048DD59

      eax=00000000 ebx=00000000 ecx=FFFFFFFF edx=00000091 esi=10472AF0 edi=00000000

      ebp=0028CC88 esp=0028CC60 program=D:\Software\BMC Software\BladeLogic\8.1\NSH\bin\nsh.exe, pid 2432, thread main

      cs=0023 ds=002B es=002B fs=0053 gs=002B ss=002B

      Stack trace:

      Frame     Function  Args

      0028CC88  0048DD59  (104483E4, 00000001, 00000004, 104483E0)

      0028CCB8  0045690E  (00000001, 104483E0, 00000001, 104483E0)

      0028CD08  0048CE81  (00000001, 104483E0, 104482A8, 00000001)

      0028CD58  61006CD3  (00000000, 0028CD94, 61006570, 7EFDE000)

      End of stack trace


      The exact same behavior is occuring on all of my AppServers. How did uninstalling/reinstalling the RSCD Agent effect my AppServer environment? And how can I resolve this?