1 2 Previous Next 22 Replies Latest reply on Feb 17, 2012 2:42 PM by sandman1 NameToUpdate

    provisioning hangs windows os

      Hi

      Running Blade 8.1.3. created the winpe image using the gui tool successfully. set it up in the right location. my target server pxeboots, grabs an ip from the dhcp server (the proper bl dhcp options are being passed, did a packet capture to validate) then the traget server loads the winpe image and after that it hangs looking for network information. im not sure why it is hanging. my pxe and tftp logs seem ok no errors. i get the following screen:

       

       

       

       

       

      When I fill in the network details screen with all the fields and click assign network details, it just stays there nothing happens. no error message either.

      has anyone seen this before?

       

      thanks

        • 2. provisioning hangs windows os
          Bill Robinson

          what kind of hardware is this?  does winpe have nic drivers injected into it for your nics ?

          • 3. provisioning hangs windows os

            Can you paste the Provisioning logs ?

            • 4. provisioning hangs windows os

              target server is hp bl465c g7. yes i injected the nic driver

              • 5. Re: provisioning hangs windows os
                Bill Robinson

                Are you sure?  because it doesn’t seem to find the nic?  You did this during the winpe image creation wizard?

                 

                What version of winpe are you using?  is the driver for windows or winpe ?

                • 6. provisioning hangs windows os

                  yes i tested with winpe drivers as well both v2.1 and 3 and it didn't work. if i use those or a wrong driver, it gives me an error saying that could not find nic drivers, when i put in the right one, that's when i see the screen above.

                  • 7. provisioning hangs windows os

                    there are no errors in the pxe or tftp logs. the strange thing is that the mac address never shows up under devices in the gui and when i try to manually add it it says that the device already exists...

                    • 8. Re: provisioning hangs windows os
                      Bill Robinson

                      you have the drivers for the right arch ?

                      • 9. Re: provisioning hangs windows os

                        If it is not showing under devices and also not letting you to add it manually, then the MAC is registered you can delete it by creating a smart group under your devices to find the MAC address and delete it or you can use blcli to delete it

                         

                        blcli ProvisionDevice deletePMDevice xx-xx-xx-xx-xx-xx

                        • 10. Re: provisioning hangs windows os
                          Bill Robinson

                          That won’t matter though.  if you can’t boot into winpe, then you can’t start the windows installer.  So you need to work out the nic issue in winpe.

                          • 11. Re: provisioning hangs windows os

                            Ok so the problem was that the WAIK version I was using was no good I had to use the one for windows7 which supports windows 2008 r2. the one i was using only supported 2008. so now i am passed that point and it picks up all it needs. i can see the mac under devices, i launch the provisioning job and it goes all the way to step 14/16 and the target server says missing bootmgr. i created pauses in the provisioning job to see what is happening and everystep is successfull except this last one before the reboot:

                             

                            Then I hit enter and it reboots and it's looking for bootmgr on the c drive of the target machine...

                            1 of 1 people found this helpful
                            • 12. Re: provisioning hangs windows os

                              Also do we know if sysprep deployment is supported?

                              • 13. Re: provisioning hangs windows os
                                Bill Robinson

                                can you post the provisioning job log? (right click on the device and look at prov history and find your failed run)

                                • 14. Re: provisioning hangs windows os

                                  Bill, here is the provision log file attached.

                                  thanks

                                  Start Time21-Jan2012  9:40:39 PM
                                  End Time
                                  StatusRunning
                                  ParticipantTypeDateMessage
                                  Run at Jan 21, 2012 9:40:39 PMInfo1/21/2012 21:40Started running the job 'jobprovision' with priority 'NORMAL' on  application server '<servername>'(1)
                                  2008r2Info1/21/2012 21:40Running provisioning job with data store:  WINDOWS DATASTORE
                                  2008r2Info1/21/2012 21:40pxe image file: WinPE_2_x_x64_Image
                                  Run at Jan 21, 2012 9:40:39 PMInfo1/21/2012 21:40Executing work item Provision Job:PollForProvisionedWorkItem;  on application server: <servername>
                                  2008r2Info1/21/2012 21:42Starting Switch Boot Image
                                  2008r2Info1/21/2012 21:42
                                  X:\Windows\system32>if  exist X:\windows\system32\Bladelogic\BLWIN64 goto donotreboot
                                  X:\Windows\system32>echo  'Switch Boot Image Done'
                                  'Switch Boot  Image Done'
                                  2008r2Info1/21/2012 21:44Completed Disk Array Config
                                  2008r2Info1/21/2012 21:44Starting Pre Disk Partition
                                  2008r2Info1/21/2012 21:44
                                  X:\Windows\system32>echo  'Pre Install Done'
                                  'Pre Install  Done'
                                  2008r2Info1/21/2012 21:44Completed Pre Disk Partition
                                  2008r2Info1/21/2012 21:44Starting Disk Partition
                                  2008r2Info1/21/2012 21:45
                                  X:\Windows\system32>call  X:\Windows\System32\BladeLogic\bin\dskprt-pre.bat
                                  X:\Windows\system32>set  dskprt=1
                                  X:\Windows\system32>set  MACADDR=00-17-A4-77-74-50
                                  X:\Windows\system32>call  X:\Windows\System32\BladeLogic\bin\dskprt-core.bat
                                  X:\Windows\system32>DiskPart  /s X:\Windows\System32\BladeLogic\bin\part.txt
                                  Microsoft  DiskPart version 6.1.7600
                                  Copyright  (C) 1999-2008 Microsoft Corporation.
                                  On computer:  MININT-2AF5VD7
                                  Disk 0 is  now the selected disk.
                                  DiskPart  succeeded in cleaning the disk.
                                  DiskPart  succeeded in creating the specified partition.
                                  Partition 1  is now the selected partition.
                                  DiskPart  successfully assigned the drive letter or mount point.
                                  DiskPart  marked the current partition as active.
                                      0 percent completed
                                      0 percent completed
                                      0 percent completed
                                    100 percent completed
                                  DiskPart  successfully formatted the volume.
                                  DiskPart  succeeded in creating the specified partition.
                                  DiskPart  succeeded in creating the specified partition.
                                      0 percent completed
                                      0 percent completed
                                    100 percent completed
                                  DiskPart  successfully formatted the volume.
                                  DiskPart  succeeded in creating the specified partition.
                                      0 percent completed
                                      0 percent completed
                                      0 percent completed
                                    100 percent completed
                                  DiskPart  successfully formatted the volume.
                                  Disk 0 is  now the selected disk.
                                  The volume  you selected is not valid or does not exist.
                                  There is no  volume selected.
                                  X:\Windows\system32>call  X:\Windows\System32\BladeLogic\bin\dskprt-post.bat
                                  X:\Windows\system32>X:\Windows\System32\BladeLogic\bootsect.exe  /nt60 c:
                                  Target  volumes will be updated with BOOTMGR compatible bootcode.
                                  C:  (\\?\Volume{4d6fe565-8c2d-11df-a4a1-0017a4777454})
                                      Successfully updated NTFS filesystem  bootcode.
                                  Bootcode was  successfully updated on all targeted volumes.
                                  X:\Windows\system32>md  c:\BLProv
                                  2008r2Info1/21/2012 21:45Completed Post Disk Partition
                                  2008r2Info1/21/2012 21:45Starting Format
                                  2008r2Info1/21/2012 21:45
                                  X:\Windows\system32>set  postprt=1
                                  X:\Windows\system32>set  MACADDR=00-17-A4-77-74-50
                                  2008r2Info1/21/2012 21:45Completed Format
                                  2008r2Info1/21/2012 21:45Starting Make Run Once
                                  2008r2Info1/21/2012 21:45
                                  X:\Windows\system32>echo  'Make Run Once Completed'
                                  'Make Run  Once Completed'
                                  2008r2Info1/21/2012 21:50Completed Make Run Once
                                  2008r2Info1/21/2012 21:50c:\BLProv>net use k: \\<servername>\pxestore  ***********   /user:<servername>\pxeuser "
                                  The command  completed successfully.
                                  X:\Windows\system32>cd  /d k:
                                  K:\>cd  \winpe_x64\ISO\sources
                                  K:\winpe_x64\ISO\sources>setup  /noreboot /unattend:c:\BLProv\unattend.txt
                                  'setup' is  not recognized as an internal or external command
                                  operable  program or batch file.
                                  1 2 Previous Next