7 Replies Latest reply on Apr 15, 2013 4:19 AM by Chandra Suvro Bose

    Reports not updating

      Share This:

      I have upgraded the memory on some Servers. Re-ran the discovery and snapshot jobs to pick these new changes up. Ran the ETL job, but these new changes are not showing up within the Reports.

       

      The ETL job fails with a return code 7000, which I'm told is a known issue. I try to run "update_cognos_model_custom_objects.bat" but get the following

       

      01/18/2012 02:10:43 PM: Another process is already updating cognos model, exitin

      g now. Please refer user guide for further information.

       

      I have tried running a stop_etl job and starting again, but the same everytime. I have checked the Inventory templates and the Snapshot results and they both show the chnages in Memory.

       

      Any Ideas?

        • 1. Re: Reports not updating
          Amit Rathi

          Try removing props.lock if present from report_home/etl/bin and run the ETL again after removing this file.

          • 2. Re: Reports not updating
            John O'Toole

            You can also provide a “-l 1” flag I believe to override the lock.

            • 3. Reports not updating

              Getting this same issue again, but not seeing any props.lock file in the etl/bin folder.

               

              com.sunopsis.dwg.function.SnpsFunctionBaseException: OS command returned 6.

                 at com.sunopsis.dwg.tools.OSCommand.actionExecute(OSCommand.java)

                 at com.sunopsis.dwg.function.SnpsFunctionBase.execute(SnpsFunctionBase.java)

                 at com.sunopsis.dwg.dbobj.SnpSessTaskSql.execIntegratedFunction(SnpSessTaskSql.java)

                 at com.sunopsis.dwg.dbobj.SnpSessTaskSql.treatTaskTrt(SnpSessTaskSql.java)

                 at com.sunopsis.dwg.dbobj.SnpSessTaskSqlS.treatTaskTrt(SnpSessTaskSqlS.java)

                 at com.sunopsis.dwg.dbobj.SnpSessTaskSql.treatTask(SnpSessTaskSql.java)

                 at com.sunopsis.dwg.dbobj.SnpSessStep.treatSessStep(SnpSessStep.java)

                 at com.sunopsis.dwg.dbobj.SnpSession.treatSession(SnpSession.java)

                 at com.sunopsis.dwg.cmd.DwgCommandScenario.treatCommand(DwgCommandScenario.java)

                 at com.sunopsis.dwg.cmd.DwgCommandBase.execute(DwgCommandBase.java)

                 at com.sunopsis.dwg.cmd.e.i(e.java)

                 at com.sunopsis.dwg.cmd.e.y(e.java)

                 at com.sunopsis.dwg.DwgJv.treatCmd(DwgJv.java)

                 at com.sunopsis.dwg.DwgJv.main(DwgJv.java)

                 at oracle.odi.Agent.main(Agent.java

              • 4. Re: Reports not updating
                Amit Rathi

                Can you please send the update_model.log in “/logs” folder?

                • 5. Reports not updating

                  Thu Mar 1 11:52:06 2012: Error: 4_UPDATE_COGNOS domain exited with status 88

                  Thu Mar 1 11:52:07 2012: Following are the possible causes for this failure:

                  Thu Mar 1 11:52:07 2012: 1) Domain 4_UPDATE_COGNOS is already running in another instance.

                  Thu Mar 1 11:52:07 2012: Please navigate to the Metadata navigator and check if any other ETL runs are in progress for the same site.

                  Thu Mar 1 11:52:07 2012: If this is not so, please use the stop_etl.nsh script to stop and reset the ETL.

                  Thu Mar 1 11:52:07 2012: Removing exstat files for this run.

                  Thu Mar 1 11:52:08 2012: Finished removing exstat files.

                  Thu Mar 1 11:52:08 2012: Removing lock file.

                   

                  No other instances running, tried running the the stop_etl.nsh script first.

                   

                  Can see this in the Update_cognos_model_properties.log

                   

                   

                  Transaction: 1

                  Action: SetActiveLocale

                  SetActiveLocale successful, continuing...

                  Transaction: 2

                  Action: UpdateObject

                  BME-SP-0007 An unknown error occurred during execution.

                  BME-SP-0028 All applied changes will be saved.

                  Check messages to determine which errors occurred.

                  • 6. Re: Reports not updating

                    Also

                     

                    TS-BL-FS01# stop_etl.nsh -s1 -v81

                    Stopping ETL.

                    Parameter verification:

                        Site Id:  1

                        OM Version:  81

                    Navigating to ETL path...

                    Completed.

                    Removing orphaned exstat files.

                    Finished removing orphaned exstat files.

                    Checking lock file for Site Id: 1

                    Could not remove lock file for Site Id: 1

                    Proceeding with Database Reset.

                    Stop ETL is successful.

                    TS-BL-FS01#

                    • 7. Re: Reports not updating

                      Hi David,

                       

                      How did u resolve the issue?