5 Replies Latest reply on Dec 20, 2011 8:52 AM by Rohit Nayyar

    RBAC Mapping a role to an instance of Custom Property class



      This 7.6.320


      I was trying to map  a role to a property of a custom property class using the 'map to use a property'.

      This is what I tried:

      1. Create a  new Custom property class called _ABC_CUSTOM_CLASS, to this I added a property called 'local_user' which is of type string.
      2. create a new instance of this Custom property class called inst01 with local_user set to 'rohit'.
      3. Added a new property to Server class called it as _ABC_SERVER_CUSTOM_CLASS of type  of the custom property class created in 1.
      4. Created a new role TEST_ROLE and in the mapping specified it to use _ABC_SERVER_CUSTOM_CLASS.local_user.


      I am able to do this , but when I open the role again , I find that it has been only set to _ABC_SERVER_CUSTOM_CLASS, which errors out as it is not of type String.


      Has someone ever tried something like this before ?



      Rohit Nayyar