2 Replies Latest reply on Dec 12, 2011 8:35 AM by Eyal NameToUpdate

    double blcli_storeenv - problem with environment parameters

      Hi,

       

      The blcli_storeenv command is giving me unexpected results.

       

      I'm writing an NSH script in Blade Logic 8.0.6.622.

       

      The script is NSH of type 2 (Execute the script once, passing the host list as parameter).

      I'm running it as a job in the Blade Logic console.

       

      The script:

       

      SERVER="$1" 
      
      echo "Retrieveing properties for $SERVER"
      blcli_execute Server getFullyResolvedPropertyValue "$SERVER" PRIZMA_BSS_STATION_ID
      blcli_storeenv PRIZMA_BSS_STATION_ID
      echo "$PRIZMA_BSS_STATION_ID"
      exit
      
      

       

      I'm running it against a target server called Test1-BSS.rnd.local, and the property PRIZMA_BSS_STATION_ID=Example

       

      The output:

       

      Info    Dec 12, 2011 1:01:42 PM    Retrieveing properties for TEST1-BSS.rnd.local
      Info    Dec 12, 2011 1:01:50 PM    ExampleExample
      Info    Dec 12, 2011 1:01:50 PM    Exit Code 0
      

       

      I'm getting the value of the property twice.

       

      What's weirder, when I tried this echo:

       

      echo "The ID of the server $SERVER is $PRIZMA_BSS_STATION_ID"
      

       

      I got:

       

      Info    Dec 12, 2011 1:24:39 PM    ExampleThe ID of the server TEST1-BSS.rnd.local  is Example
      

       

      I'm usually writing in Jython, and this is one of my first times writing in NSH, so I might be doing something wrong.

       

      Can anyone point me in the right direction?

       

      Thanks,

      Eyal