4 Replies Latest reply on Nov 28, 2011 11:10 AM by Jim Campbell

    8.1sp3 Shavlik problem?

    Jim Campbell

      We had fixed our 8.0sp6 setup  to account for the change to the Shavlik metadata for patching.  After upgrading last night to 8.1sp3 I'm now getting an error that is similar but not quite the same as the one we received at 8.0sp6 when updating the catalogue.  We were told that 8.1sp3 would have the changes already included and that we wouldn't have to do anything:

       

      [24 Nov 2011 09:33:19,088] [WorkItem-Thread-133] [ERROR] [user@domain:BLAdmins:] [Patch-Metadata-Updator] com/bmc/sa/patchfeed/ElementId

      java.lang.NoClassDefFoundError: com/bmc/sa/patchfeed/ElementId

                at com.bmc.sa.patchfeed.windows.WindowsFeed.update(WindowsFeed.java:372)

                at com.bladelogic.om.patch.model.job.catalogUpdate.AbstractCatalogFeedUpdateWorkItem.execute(AbstractCatalogFeedUpdateWorkItem.java:183)

                at com.bladelogic.om.infra.app.service.workitem.WorkItem.doExecute(WorkItem.java:114)

                at com.bladelogic.om.infra.app.service.workitem.thread.WorkItemThread.execute(WorkItemThread.java:173)

                at com.bladelogic.om.infra.app.service.workitem.thread.WorkItemThread.execute(WorkItemThread.java:49)

                at com.bladelogic.om.infra.app.service.thread.BlBlockingThread.run(BlBlockingThread.java:95)

      Caused by: java.lang.ClassNotFoundException: com.bmc.sa.patchfeed.ElementId

                at java.net.URLClassLoader$1.run(Unknown Source)

                at java.security.AccessController.doPrivileged(Native Method)

                at java.net.URLClassLoader.findClass(Unknown Source)

                at java.lang.ClassLoader.loadClass(Unknown Source)

                at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)

                at java.lang.ClassLoader.loadClass(Unknown Source)

                at java.lang.ClassLoader.loadClassInternal(Unknown Source)

                ... 6 more

       

       

      Is this the same problem and does the same .jar in the ftp site in the 8.1 directory apply for all service packs of 8.1?