1 Reply Latest reply on Nov 21, 2011 8:38 AM by Adam Bowen

    Disable MTFTP on PXE-Server

    Steffen Kreis



      during our testing we realized that a client always triesto communicate via MTFTP first when PXE-booting it.

      As we do not use MTFTP this leads to an error due to atimeout and thn the pxelinux gets loaded using "normal" TFTP.


      To avoid that timeout, how can we completely disable MTFTP ?


      We tried with the derfault parameters for mtftp_configurations before, as well as using the PXE-Servers local address here.

      Both configurations showed no difference.


      This is especially problematic as some Dell blades seem to have a long timeout before switching from MTFTP to TFTP.




        • 1. Re: Disable MTFTP on PXE-Server

          Certain hardware models, such as Dell PowerEdge T310s/R710s and HP DL380G6s, have newer firmware versions that increase the MTFTP timeout from a few seconds to 10 minutes.  This does not break the provisioning process, but does lengthen it considerably.  The following revision can be made to every server that hosts a PXE Server, if desired, to prevent the extended timeout when such models are to be provisioned:


          ·        Edit the '/opt/bmc/bladelogic/8.1/pxe/NSH/br/pxe.conf' settings in the following manner within the "mtftp configurations" section of the file:








          ·        Stop and restart the 'blpxe' service from '/etc/init.d':


                ./blpxe stop


                ./blpxe start

          --credit to Tony Bove