12 Replies Latest reply on Nov 16, 2011 7:33 AM by Bill Robinson

    Pxe Error

    GuruPrasad D S

      I am trying to install win2008R2 standard on to my newly vreated vm.


      I completed all the steps for provisioning,but when it starts provisioning the VM auto selects the linux OS.


      pxe error.JPG

      plz suggest the solution..

        • 1. Pxe Error
          Rupali Deshmukh

          Check the Default Boot Image set in Configuration menu=>Provisioning Configuration=>Image Files tab. In your case, it is probably set to Gentoo (Linux pre-boot image) for both 32 bit & 64 bit architecture. You can either change the Default boot image to WinPE (Windows pre-boot image) here. Or as seen in your screen shot if the device was PXE booted and it must have been added to the list of Imported Devices in your RCP console, you can associate the WinPE boot image directly with your discovered device with MAC 00-50-56-90-00-13. Thus, it will automatically boot to WinPE image instead of Gentoo and continue with Windows OS provisioning.

          • 2. Pxe Error
            GuruPrasad D S

            yes i set the default option to winPE only


            I added the device in imported Devices still the same problem..


            even though no gentoo images in the datastore,no default option set to gentoo its starting the boot process from gentoo. How?


            i have a question that how the vm get autoselect as gentoo ?

            • 3. Pxe Error

              Hi.. Can you please give more details on the second part. As in how to associate the device directly to the Win PE image? Details on that..

              • 4. Pxe Error

                I am geeting this on the taget server console." Could not find kernel image:gentoo64/gentoo".



                • 5. Pxe Error
                  Rupali Deshmukh

                  May be, your target VM is booting from some other PXE/TFTP server in the network. Are multiple PXE present in the network by any chance? And BTW, the pre-boot images (gentoo & WinPE) are not on datastore, but on tftproot on TFTP server. Check your TFTP log file, is it displaying the logs for sending the right boot image to your target VM with MAC 00-50-56-90-00-13. Also, which are the default boot images selected in your Provisoning Configuration for x86 and x64 arch?


                  Krithesh, when you add the device, you need to select the right WinPE boot image from the 'Boot Image File' drop down. This will associate the Device with Boot image.

                  • 6. Re: Pxe Error
                    Gerardo Bartoccini

                    Please consider that setting WinPE as default image doesn’t actually unset gentoo/64 as default images.

                    If you want WinPE to be the ONLY default image, you need to unset gentoo/64

                    • 7. Pxe Error

                      Thank you. Have done that. No results

                      • 8. Pxe Error

                        Yes. I have done that too. Unset the gentoo. Still the VM is looking for gentoo image itself.

                        • 9. Pxe Error
                          Hemal Shah

                          There are two default boot images, one for x86 and one for x64. If you specify a x86 default boot image, you will still have a x64 default boot image present. Regarding your problem, have you added the device in your workspace and associated the right boot image ?? Are your PXE and appserer pointing to the same DB ??

                          • 10. Pxe Error
                            Rupali Deshmukh

                            Krithesh, there is one more possibility that in the Provisioning Job that you created, there is a option to choose the Boot Image, I suppose gentoo 64 is selected in the Job. If the job is executed before the VM boot, the boot image from the job takes precedence. If the VM is booted and there is no job run until then, the default boot image associated with the device takes precedence. And if the device is not added to the imported list, but auto-discovered, then the default boot image in the Provisioning Configuration takes precedence. Thus, in your case, since the job executed on a device already added before the VM is booted, the boot image selected in the job would take precedence. Make sure, the Job has right WinPE image selected

                            • 11. Pxe Error

                              Even in the provision job I havent chosen gentoo. i chose winPE. I have placed the winPE image on the tftproot folder. Full path is "C:\Program Files(x86)\BMC Software\BladeLogic\8.1\PXE\tftproot". Creted a folder inside tftproot. The folder cosists of these three files.

                              'BCD', 'boot.sdi', 'WinPE.wim'.

                              Is it the right location to place the files?

                              • 12. Re: Pxe Error
                                Bill Robinson

                                When you create the winpe image you specify a folder to create it in – like ‘boot_2_0’.  That folder contains the wim, bcd and boot.sdi.  that whole folder needs to be put in the tftproot directory.  The folder name needs to be maintained.  There is also a bootmgr.exe that goes in the root of the tftproot dir, and there’s a pxeboot.0 that goes in the X86PC/pxelinux dir.


                                Also – if you have the device in the Devices workspace in the gui, open it and see what the boot image is set to.  You may need to change it.