2 Replies Latest reply on Nov 24, 2011 10:11 AM by jp NameToUpdate

    How to enable webservices in BBSA 8.1SP2

      Hello,

       

      I encounter an error on BBSA 8.1SP2Patch5, during appserver start, attempting to enable WebServices.

       

      Please find below the command I entered on blasadmin utility :

       

      #set AppServer enableWebServices true

       

      Then I restart the blappserv service and continue with the command below registering web services to the TIBCO registry:

       

      #set WebServices RegistryServer opblaa01

      #set WebServices RegistryServerPort 8080

      #set WebServices RegistryServerUserName BLAdmin

      #set WebServices RegistryServerPassword xxxx

      #set WebServices RegistryPublishedHostName opblaa01

       

       

      Then I restart blappserver again

      Please see below the webservices configuration :

       

       

      bladmin:default>show webservices all

       

       

      [WebServices]

      MaxSessionsPerUser:50

      MaxWebServicesSessions:30

      RegistryApplicationName:BMC_BladeLogic_Server_Automation_Suite

      RegistryBusinessName:BMC

      RegistryCriteria:

      RegistryPublishedHostName:opblaa01

      RegistryServer:opblaa01

      RegistryServerPassword:xxxx

      RegistryServerPort:8080

      RegistryServerUserName:BLAdmin

      TimeOutInterval:300000

      TouchTimeForService:5000

      WebServiceRunReleasedCommandsOnly:false

       

       

      Please find below an extract of appserver.log :

      [10 Nov 2011 14:27:06,324] [main] [INFO] [::] [] Starting Agent Service...

      [10 Nov 2011 14:27:06,333] [main] [INFO] [::] [] Agent Service started.

      [10 Nov 2011 14:27:06,495] [main] [INFO] [::] [] ClientValidation Service started.

      [10 Nov 2011 14:27:06,501] [main] [INFO] [::] [] Starting Configuration Service...

      [10 Nov 2011 14:27:06,984] [main] [INFO] [::] [] Configuration Service started.

      [10 Nov 2011 14:27:07,014] [main] [INFO] [::] [] Starting Content Importer Service...

      [10 Nov 2011 14:27:07,015] [main] [INFO] [::] [] Content Importer Service started.

      [10 Nov 2011 14:27:07,088] [main] [INFO] [::] [] Starting Tomcat Service ...

      [10 Nov 2011 14:27:07,395] [main] [INFO] [::] [] Starting tomcat server

      [10 Nov 2011 14:27:07,591] [main] [INFO] [::] [] Starting Servlet Engine: Apache Tomcat/5.5.26

      [10 Nov 2011 14:27:07,597] [main] [INFO] [::] [] XML validation disabled

      [10 Nov 2011 14:27:08,758] [main] [INFO] [::] [] WSAuthenticationModule.init

      [10 Nov 2011 14:27:11,122] [main] [INFO] [::] [] Initializing Coyote HTTP/1.1 on http-10003

      [10 Nov 2011 14:27:11,190] [main] [INFO] [::] [] Starting Coyote HTTP/1.1 on http-10003

      [10 Nov 2011 14:27:11,299] [main] [INFO] [::] [] Publishing Web Services in the registry for host opblaa01.bagnolet.francetelecom.fr

      [10 Nov 2011 14:27:11,958] [main] [INFO] [::] [] I/O exception (java.net.ConnectException) caught when processing request: Connection refused

      [10 Nov 2011 14:27:11,958] [main] [INFO] [::] [] Retrying request

      [10 Nov 2011 14:27:11,958] [main] [INFO] [::] [] I/O exception (java.net.ConnectException) caught when processing request: Connection refused

      [10 Nov 2011 14:27:11,958] [main] [INFO] [::] [] Retrying request

      [10 Nov 2011 14:27:11,959] [main] [INFO] [::] [] I/O exception (java.net.ConnectException) caught when processing request: Connection refused

      [10 Nov 2011 14:27:11,959] [main] [INFO] [::] [] Retrying request

      [10 Nov 2011 14:27:11,972] [main] [ERROR] [::] [] Error installing to Start: name=bladelogic.service.EmbeddedTomcatService state=Create

      java.lang.RuntimeException: dk.itst.uddi.client.exceptions.UDDIException: org.apache.axis2.AxisFault: Connection refused

              at com.bmc.webservices.uddiapi.impl.TibcoUDDIRegistryImpl.addBusiness(Unknown Source)

              at com.bladelogic.om.infra.app.service.tomcat.DefaultEmbeddedTomcatServiceImpl.publishServices(DefaultEmbeddedTomcatServiceImpl.java:278)

              at com.bladelogic.om.infra.app.service.tomcat.EmbeddedTomcatServiceImpl.startService(EmbeddedTomcatServiceImpl.java:123)

              at com.bladelogic.om.infra.app.service.tomcat.DefaultEmbeddedTomcatServiceImpl.start(DefaultEmbeddedTomcatServiceImpl.java:162)

              at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

              at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

              at java.lang.reflect.Method.invoke(Method.java:597)

              at org.jboss.joinpoint.plugins.reflect.ReflectMethodJoinPoint.dispatch(ReflectMethodJoinPoint.java:72)

              at org.jboss.kernel.plugins.dependency.KernelControllerContextActions$DispatchJoinPoint.run(KernelControllerContextActions.java:631)

              at java.security.AccessController.doPrivileged(Native Method)

              at org.jboss.kernel.plugins.dependency.KernelControllerContextActions.dispatchJoinPoint(KernelControllerContextActions.java:99)

              at org.jboss.kernel.plugins.dependency.KernelControllerContextActions$LifecycleAction.installAction(KernelControllerContextActions.java:452)

              at org.jboss.kernel.plugins.dependency.KernelControllerContextActions$1.run(KernelControllerContextActions.java:156)

              at java.security.AccessController.doPrivileged(Native Method)

              at org.jboss.kernel.plugins.dependency.KernelControllerContextActions$KernelControllerContextAction.install(KernelControllerContextActions.java:179)

              at org.jboss.dependency.plugins.AbstractControllerContextActions.install(AbstractControllerContextActions.java:51)

              at org.jboss.dependency.plugins.AbstractControllerContext.install(AbstractControllerContext.java:226)

              at org.jboss.dependency.plugins.AbstractController.install(AbstractController.java:593)

              at org.jboss.dependency.plugins.AbstractController.incrementState(AbstractController.java:346)

              at org.jboss.dependency.plugins.AbstractController.resolveContexts(AbstractController.java:438)

              at org.jboss.dependency.plugins.AbstractController.resolveContexts(AbstractController.java:379)

              at org.jboss.dependency.plugins.AbstractController.install(AbstractController.java:225)

              at org.jboss.dependency.plugins.AbstractController.install(AbstractController.java:151)

              at org.jboss.kernel.plugins.deployment.AbstractKernelDeployer.deployBean(AbstractKernelDeployer.java:291)

              at com.bladelogic.om.infra.app.service.bootstrap.ServiceBeanXMLDeployer.deployBean(ServiceBeanXMLDeployer.java:38)

              at org.jboss.kernel.plugins.deployment.AbstractKernelDeployer.deployBeans(AbstractKernelDeployer.java:261)

              at org.jboss.kernel.plugins.deployment.AbstractKernelDeployer.deploy(AbstractKernelDeployer.java:117)

              at org.jboss.kernel.plugins.deployment.xml.BeanXMLDeployer.deploy(BeanXMLDeployer.java:91)

              at com.bladelogic.om.infra.app.service.bootstrap.ServiceBootstrap.deploy(ServiceBootstrap.java:252)

              at com.bladelogic.om.infra.app.service.bootstrap.ServiceBootstrap.deployService(ServiceBootstrap.java:199)

              at com.bladelogic.om.infra.app.service.bootstrap.ServiceBootstrap.bootstrap(ServiceBootstrap.java:153)

              at org.jboss.kernel.plugins.bootstrap.AbstractBootstrap.run(AbstractBootstrap.java:91)

              at com.bladelogic.om.infra.app.service.bootstrap.ServiceBootstrap.startup(ServiceBootstrap.java:66)

              at com.bladelogic.om.infra.mfw.fw.BlManager.start(BlManager.java:863)

              at com.bladelogic.om.infra.mfw.fw.BlManager.main(BlManager.java:1381)

      Caused by: dk.itst.uddi.client.exceptions.UDDIException: org.apache.axis2.AxisFault: Connection refused

              at dk.itst.uddi.client.UDDIClient.authenticate(UDDIClient.java:171)

              at dk.itst.uddi.client.UDDIClient.getInquiry(UDDIClient.java:130)

              at com.bmc.webservices.uddiapi.impl.tibco.RegistryUtilBase.getBusiness(Unknown Source)

              at com.bmc.webservices.uddiapi.impl.tibco.RegistryUtilBase.findBusiness(Unknown Source)

              at com.bmc.webservices.uddiapi.impl.tibco.RegistryUtilBase.addBusiness(Unknown Source)

              ... 36 more

      Caused by: org.apache.axis2.AxisFault: Connection refused

              at org.apache.axis2.AxisFault.makeFault(AxisFault.java:430)

              at org.apache.axis2.transport.http.HTTPSender.sendViaPost(HTTPSender.java:193)

              at org.apache.axis2.transport.http.HTTPSender.send(HTTPSender.java:75)

              at org.apache.axis2.transport.http.CommonsHTTPTransportSender.writeMessageWithCommons(CommonsHTTPTransportSender.java:389)

              at org.apache.axis2.transport.http.CommonsHTTPTransportSender.invoke(CommonsHTTPTransportSender.java:222)

              at org.apache.axis2.engine.AxisEngine.send(AxisEngine.java:435)

              at org.apache.axis2.description.OutInAxisOperationClient.send(OutInAxisOperation.java:402)

              at org.apache.axis2.description.OutInAxisOperationClient.executeImpl(OutInAxisOperation.java:229)

              at org.apache.axis2.client.OperationClient.execute(OperationClient.java:165)

              at dk.itst.uddi.client.stubs.UddiSecurityStub.get_authToken(UddiSecurityStub.java:382)

              at dk.itst.uddi.client.UDDIClient.authenticate(UDDIClient.java:169)

              ... 40 more

      Caused by: java.net.ConnectException: Connection refused

              at java.net.PlainSocketImpl.socketConnect(Native Method)

              at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:333)

              at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:195)

              at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:182)

              at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366)

              at java.net.Socket.connect(Socket.java:519)

              at java.net.Socket.connect(Socket.java:469)

              at java.net.Socket.<init>(Socket.java:366)

              at java.net.Socket.<init>(Socket.java:240)

              at org.apache.commons.httpclient.protocol.DefaultProtocolSocketFactory.createSocket(DefaultProtocolSocketFactory.java:79)

              at org.apache.commons.httpclient.protocol.DefaultProtocolSocketFactory.createSocket(DefaultProtocolSocketFactory.java:121)

              at org.apache.commons.httpclient.HttpConnection.open(HttpConnection.java:706)

              at org.apache.commons.httpclient.MultiThreadedHttpConnectionManager$HttpConnectionAdapter.open(MultiThreadedHttpConnectionManager.java:1321)

              at org.apache.commons.httpclient.HttpMethodDirector.executeWithRetry(HttpMethodDirector.java:386)

              at org.apache.commons.httpclient.HttpMethodDirector.executeMethod(HttpMethodDirector.java:170)

              at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:396)

              at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:346)

              at org.apache.axis2.transport.http.AbstractHTTPSender.executeMethod(AbstractHTTPSender.java:550)

              at org.apache.axis2.transport.http.HTTPSender.sendViaPost(HTTPSender.java:189)

              ... 49 more

      [10 Nov 2011 14:27:12,035] [main] [INFO] [::] [] Loading JNI libaries...

      [10 Nov 2011 14:27:12,047] [main] [INFO] [::] [] Loaded JNI library BlAsJni

      [10 Nov 2011 14:27:12,051] [main] [INFO] [::] [] Loaded JNI library XJNIService

      [10 Nov 2011 14:27:12,051] [main] [INFO] [::] [] Loaded JNI library Atrium Core

      [10 Nov 2011 14:27:12,053] [main] [INFO] [::] [] Initializing JNI Configuration...

      [10 Nov 2011 14:27:12,054] [main] [INFO] [::] [] Initialized JNI library BlAsJni

      [10 Nov 2011 14:27:12,056] [main] [INFO] [::] [] Initialized JNI library XJNIService

      [10 Nov 2011 14:27:12,056] [main] [INFO] [::] [] Initialized JNI library Atrium Core

      [10 Nov 2011 14:27:12,056] [main] [INFO] [::] [] JNI Configuration complete.

      [10 Nov 2011 14:27:12,071] [main] [INFO] [::] [] Job Infra Manager Service is starting

      [10 Nov 2011 14:27:12,105] [main] [INFO] [::] [] Starting LDAP Connection Service...

      [10 Nov 2011 14:27:12,105] [main] [INFO] [::] [] LDAP Connection Service started.

      [10 Nov 2011 14:27:12,217] [main] [INFO] [::] [] Starting Model Graph Service...

      [10 Nov 2011 14:27:15,919] [main] [INFO] [::] [] Model Graph Service started.

      [10 Nov 2011 14:27:16,004] [main] [INFO] [::] [] Starting ObjectExporter Service...

      [10 Nov 2011 14:27:16,004] [main] [INFO] [::] [] Verifying exporter classes...

      [10 Nov 2011 14:27:16,016] [main] [INFO] [::] [] Object exporters verified.

      [10 Nov 2011 14:27:16,016] [main] [INFO] [::] [] ObjectExporter Service started.

      [10 Nov 2011 14:27:16,033] [main] [INFO] [::] [] Starting PKI Service...

      [10 Nov 2011 14:27:16,039] [main] [INFO] [::] [] PKI Service started.

      [10 Nov 2011 14:27:16,044] [main] [INFO] [::] [] Starting LDAP Service...

      [10 Nov 2011 14:27:16,044] [main] [INFO] [::] [] LDAP service is not configured.

      [10 Nov 2011 14:27:16,044] [main] [INFO] [::] [] LDAP Service started.

      [10 Nov 2011 14:27:16,050] [main] [INFO] [::] [] Starting Port Provider...

      [10 Nov 2011 14:27:16,050] [main] [INFO] [::] [] Port Provider started.

      [10 Nov 2011 14:27:16,091] [main] [INFO] [::] [] Starting Sizing Service...

      [10 Nov 2011 14:27:16,091] [main] [INFO] [::] [] Sizing Service started.

      [10 Nov 2011 14:27:16,098] [main] [INFO] [::] [] Starting Caching Service...

      [10 Nov 2011 14:27:16,099] [main] [INFO] [::] [] Caching Service started.

      [10 Nov 2011 14:27:16,103] [main] [INFO] [::] [] Starting Session Service...

      [10 Nov 2011 14:27:16,129] [main] [INFO] [::] [] Session Service started.

      [10 Nov 2011 14:27:16,151] [main] [INFO] [::] [] Starting Task Scheduling Service...

      [10 Nov 2011 14:27:16,157] [main] [INFO] [::] [] Task Scheduling Service started.

      [10 Nov 2011 14:27:16,161] [main] [INFO] [::] [] Starting Directory Service...

      [10 Nov 2011 14:27:16,181] [main] [INFO] [::] [] Starting RMI registry on host: opblaa01.bagnolet.francetelecom.fr

      [10 Nov 2011 14:27:16,197] [main] [INFO] [::] [] Directory Service started.

      [10 Nov 2011 14:27:16,200] [main] [INFO] [::] [] Setting client socket factory: com.bladelogic.om.infra.app.service.client.OMClientSocketFactory

      [10 Nov 2011 14:27:16,200] [main] [INFO] [::] [] Setting server socket factory: com.bladelogic.om.infra.app.service.client.ServerSocketFactory

      [10 Nov 2011 14:27:16,200] [main] [INFO] [::] [] Setting authenticator: com.bladelogic.om.infra.app.service.manage.auth.BlSessionServerAuthenticator

      [10 Nov 2011 14:27:16,202] [main] [INFO] [::] [] Starting Management Service ...

      [10 Nov 2011 14:27:16,300] [main] [INFO] [::] [] Management Service started.

      [10 Nov 2011 14:27:16,309] [main] [INFO] [::] [] Starting App Server Data Source...

      [10 Nov 2011 14:27:17,023] [main] [INFO] [::] [] Initialized connection pool General-Connection-Pool with url = jdbc:oracle:thin:@opblaa02:20300:BLADE and user = bladelogic

      [10 Nov 2011 14:27:17,098] [main] [INFO] [::] [] Initialized connection pool Job-Connection-Pool with url = jdbc:oracle:thin:@opblaa02:20300:BLADE and user = bladelogic

      [10 Nov 2011 14:27:17,154] [main] [INFO] [::] [] Initialized connection pool Client-Connection-Pool with url = jdbc:oracle:thin:@opblaa02:20300:BLADE and user = bladelogic

      [10 Nov 2011 14:27:17,154] [main] [INFO] [::] [] App Server Data Source started.

      [10 Nov 2011 14:27:17,155] [main] [INFO] [::] [] Starting Instrumentation Service...

      [10 Nov 2011 14:27:17,161] [main] [INFO] [::] [] Instrumentation Service started.

      [10 Nov 2011 14:27:17,235] [main] [INFO] [::] [] Starting Database Service...

      [10 Nov 2011 14:27:17,247] [main] [INFO] [::] [] Loaded /exec/applis/BLAAS1/NSH/br/deployments/default/sql/blas-sqlmap.properties

      [10 Nov 2011 14:27:17,291] [main] [INFO] [::] [] Loaded /exec/applis/BLAAS1/NSH/br/deployments/default/sql/sqlmap.properties

      [10 Nov 2011 14:27:17,379] [main] [INFO] [::] [] Loaded /exec/applis/BLAAS1/NSH/br/deployments/default/sql/streamable_sqlmap.properties

      [10 Nov 2011 14:27:17,380] [main] [INFO] [::] [] Loaded /exec/applis/BLAAS1/NSH/br/deployments/default/sql/reports-sqlmap.properties

      [10 Nov 2011 14:27:17,396] [main] [INFO] [::] [] Database service loaded 4 mapping files.

      [10 Nov 2011 14:27:17,396] [main] [INFO] [::] [] Database Service started.

      [10 Nov 2011 14:27:17,562] [main] [INFO] [::] [] Starting Notification Service...

      [10 Nov 2011 14:27:17,565] [main] [INFO] [::] [] Notification Service started.

      [10 Nov 2011 14:27:17,566] [main] [INFO] [::] [] Starting Job Executor Service...

      [10 Nov 2011 14:27:17,566] [main] [INFO] [::] [] Job Executor Service started.

      [10 Nov 2011 14:27:17,566] [main] [INFO] [::] [] Starting SRP Authentication Service...

      [10 Nov 2011 14:27:17,617] [main] [INFO] [::] [] SRP Authentication Service started.

      [10 Nov 2011 14:27:17,617] [main] [INFO] [::] [] Starting App Server Service...

      [10 Nov 2011 14:27:17,840] [main] [INFO] [::] [] Server: opblaa01_bagnolet_francetelecom_fr; id: 2002000; RMI Port: 9836

      [10 Nov 2011 14:27:17,851] [main] [INFO] [::] [] App Server Service started.

      [10 Nov 2011 14:27:17,851] [main] [INFO] [::] [] Verifying object deleters...

      [10 Nov 2011 14:27:17,855] [main] [INFO] [::] [] Object deleters verified.

      [10 Nov 2011 14:27:17,855] [main] [INFO] [::] [] Verifying object soft deleters...

      [10 Nov 2011 14:27:17,868] [main] [INFO] [::] [] Object soft deleters verified.

      [10 Nov 2011 14:27:17,869] [main] [INFO] [::] [] Verifying object purgers...

      [10 Nov 2011 14:27:17,869] [main] [INFO] [::] [] Object purgers verified.

      [10 Nov 2011 14:27:17,869] [main] [INFO] [::] [] Starting Atrium Import Service...

      [10 Nov 2011 14:27:17,870] [main] [INFO] [::] [] Atrium Import Service started.

      [10 Nov 2011 14:27:17,906] [main] [INFO] [::] [] Starting Diagnostic Service...

      [10 Nov 2011 14:27:17,918] [main] [INFO] [::] [] Diagnostic Service started.

      [10 Nov 2011 14:27:17,919] [main] [INFO] [::] [] Starting Event Service...

      [10 Nov 2011 14:27:17,934] [Event-Processor-Thread-1] [INFO] [::] [] Event processor thread started.

      [10 Nov 2011 14:27:17,951] [main] [INFO] [::] [] Event Service started.

      [10 Nov 2011 14:27:17,951] [main] [INFO] [::] [] Starting RBAC Role Service...

      [10 Nov 2011 14:27:17,951] [main] [INFO] [::] [] RBAC Role Service started.

      [10 Nov 2011 14:27:17,951] [main] [INFO] [::] [] Starting RBAC User Service...

      [10 Nov 2011 14:27:17,951] [main] [INFO] [::] [] RBAC User Service started.

      [10 Nov 2011 14:27:17,952] [main] [INFO] [::] [] Starting NshProxyConnection Service...

      [10 Nov 2011 14:27:17,952] [main] [INFO] [::] [] Nsh-Proxy is reserving the controlport

      [10 Nov 2011 14:27:17,953] [Event-Dispatcher-Thread] [INFO] [::] [] Event dispatcher thread started.

      [10 Nov 2011 14:27:17,954] [main] [INFO] [::] [] Nsh-Proxy is establishing control connection...

      [10 Nov 2011 14:27:17,954] [Thread-16] [INFO] [::] [] Nsh-Proxy is waiting for control socket ...

      [10 Nov 2011 14:27:17,955] [Event-Transfer-Thread-0] [INFO] [::] [] Event transfer thread started.

      [10 Nov 2011 14:27:17,955] [Event-Processor-Thread-2] [INFO] [::] [] Event processor thread started.

      [10 Nov 2011 14:27:17,955] [Event-Processor-Thread-3] [INFO] [::] [] Event processor thread started.

      [10 Nov 2011 14:27:17,955] [Event-Processor-Thread-4] [INFO] [::] [] Event processor thread started.

      [10 Nov 2011 14:27:17,955] [Event-Processor-Thread-0] [INFO] [::] [] Event processor thread started.

      [10 Nov 2011 14:27:17,955] [Diagnostic-Test-Runner-Thread-2] [INFO] [::] [] Diagnostic test execution thread started.

      [10 Nov 2011 14:27:17,954] [Diagnostic-Test-Runner-Thread-0] [INFO] [::] [] Diagnostic test execution thread started.

      [10 Nov 2011 14:27:17,954] [Diagnostic-Test-Runner-Thread-1] [INFO] [::] [] Diagnostic test execution thread started.

      [10 Nov 2011 14:27:17,957] [Event-Transfer-Thread-4] [INFO] [::] [] Event transfer thread started.

      [10 Nov 2011 14:27:17,960] [Event-Transfer-Thread-2] [INFO] [::] [] Event transfer thread started.

      [10 Nov 2011 14:27:17,961] [Event-Transfer-Thread-1] [INFO] [::] [] Event transfer thread started.

      [10 Nov 2011 14:27:17,961] [Event-Transfer-Thread-3] [INFO] [::] [] Event transfer thread started.

      [10 Nov 2011 14:27:17,961] [Thread-16] [INFO] [::] [] Nsh-Proxy accepted the control socket connection

      [10 Nov 2011 14:27:17,961] [main] [INFO] [::] [] Nsh-Proxy established control connection.

      [10 Nov 2011 14:27:17,976] [main] [INFO] [::] [] Nsh-Proxy is starting the selector

      [10 Nov 2011 14:27:17,979] [main] [INFO] [::] [] Nsh-Proxy is starting the acceptor

      [10 Nov 2011 14:27:17,979] [main] [INFO] [::] [] NshProxyConnection Service started.

      [10 Nov 2011 14:27:17,979] [main] [INFO] [::] [] Starting File Manager Service...

      [10 Nov 2011 14:27:18,005] [main] [INFO] [::] [] Validating file server host (opblaa01.bagnolet.francetelecom.fr)...

      [10 Nov 2011 14:27:18,189] [main] [INFO] [::] [] Validating file server path (//opblaa01.bagnolet.francetelecom.fr/stockage/BLfileServer/)...

      [10 Nov 2011 14:27:18,191] [main] [INFO] [::] [] Cleaning up application server temp directory: /exec/applis/BLAAS1/NSH/tmp/application_server

      [10 Nov 2011 14:27:18,193] [main] [INFO] [::] [] Cleaning up file server temp directory: //opblaa01.bagnolet.francetelecom.fr/stockage/BLfileServer/tmp/opblaa01_bagnolet_francetelecom_fr

      [10 Nov 2011 14:27:18,196] [main] [INFO] [::] [] Cleaning up temp zip files in: /exec/applis/BLAAS1/NSH/br

      [10 Nov 2011 14:27:18,209] [main] [INFO] [::] [] File Manager Service started.

      [10 Nov 2011 14:27:18,269] [main] [INFO] [::] [] Adding method invocation provider: com.bladelogic.om.infra.app.api.manage.APIMethodInvocationProvider

      [10 Nov 2011 14:27:18,270] [main] [INFO] [::] [] Adding method invocation provider: com.bladelogic.om.infra.app.service.agentservice.AgentMethodInvocationProvider

      [10 Nov 2011 14:27:18,288] [main] [INFO] [::] [] Starting Grammar Service...

      [10 Nov 2011 14:27:18,288] [main] [INFO] [::] [] Upgrading custom grammars...

      [10 Nov 2011 14:27:18,318] [main] [INFO] [::] [] Custom grammars upgraded.

      [10 Nov 2011 14:27:18,318] [main] [INFO] [::] [] Grammar Service started.

      [10 Nov 2011 14:27:18,318] [main] [INFO] [::] [] Starting Support Service...

      [10 Nov 2011 14:27:18,322] [Support-Thread-0] [INFO] [::] [] Support data thread started.

      [10 Nov 2011 14:27:18,324] [main] [INFO] [::] [] Support Service started.

      [10 Nov 2011 14:27:18,324] [main] [INFO] [::] [] Starting Job Schedule Approval Service...

      [10 Nov 2011 14:27:18,329] [Support-Thread-1] [INFO] [::] [] Support data thread started.

      [10 Nov 2011 14:27:18,330] [Support-Thread-2] [INFO] [::] [] Support data thread started.

      [10 Nov 2011 14:27:18,332] [main] [INFO] [::] [] Starting Distribution Manager...

      [10 Nov 2011 14:27:18,334] [main] [INFO] [::] [] Distribution manager using multi-appserver job assignment decision maker.

      [10 Nov 2011 14:27:18,341] [main] [INFO] [::] [] Distribution Manager started.

      [10 Nov 2011 14:27:18,341] [main] [INFO] [::] [] Starting Job Run Service...

      [10 Nov 2011 14:27:18,347] [main] [INFO] [::] [] Job Run Service started.

      [10 Nov 2011 14:27:18,355] [Bl-Exec-0] [INFO] [::] [] BlExec worker thread started.

      [10 Nov 2011 14:27:18,356] [Bl-Exec-1] [INFO] [::] [] BlExec worker thread started.

      [10 Nov 2011 14:27:18,357] [Bl-Exec-2] [INFO] [::] [] BlExec worker thread started.

      [10 Nov 2011 14:27:18,360] [Bl-Exec-4] [INFO] [::] [] BlExec worker thread started.

      [10 Nov 2011 14:27:18,361] [Bl-Exec-5] [INFO] [::] [] BlExec worker thread started.

      [10 Nov 2011 14:27:18,801] [Bl-Exec-3] [INFO] [::] [] BlExec worker thread started.

      [10 Nov 2011 14:27:18,802] [Bl-Exec-6] [INFO] [::] [] BlExec worker thread started.

      [10 Nov 2011 14:27:18,802] [Bl-Exec-19] [INFO] [::] [] BlExec worker thread started.

      [10 Nov 2011 14:27:18,803] [Bl-Exec-18] [INFO] [::] [] BlExec worker thread started.

      [10 Nov 2011 14:27:18,804] [Bl-Exec-17] [INFO] [::] [] BlExec worker thread started.

      [10 Nov 2011 14:27:18,804] [Bl-Exec-16] [INFO] [::] [] BlExec worker thread started.

      [10 Nov 2011 14:27:18,804] [Bl-Exec-15] [INFO] [::] [] BlExec worker thread started.

      [10 Nov 2011 14:27:18,805] [Bl-Exec-14] [INFO] [::] [] BlExec worker thread started.

      [10 Nov 2011 14:27:18,805] [Bl-Exec-13] [INFO] [::] [] BlExec worker thread started.

      [10 Nov 2011 14:27:18,805] [Bl-Exec-12] [INFO] [::] [] BlExec worker thread started.

      [10 Nov 2011 14:27:18,806] [Bl-Exec-10] [INFO] [::] [] BlExec worker thread started.

      [10 Nov 2011 14:27:18,806] [Bl-Exec-9] [INFO] [::] [] BlExec worker thread started.

      [10 Nov 2011 14:27:18,807] [Bl-Exec-8] [INFO] [::] [] BlExec worker thread started.

      [10 Nov 2011 14:27:18,807] [Bl-Exec-7] [INFO] [::] [] BlExec worker thread started.

      [10 Nov 2011 14:27:18,807] [main] [INFO] [::] [] BlExec Service started.

      [10 Nov 2011 14:27:18,808] [main] [INFO] [::] [] Starting Routing Service...

      [10 Nov 2011 14:27:18,808] [main] [INFO] [::] [] Routing Service started.

      [10 Nov 2011 14:27:18,808] [main] [INFO] [::] [] Starting RBAC Service...

      [10 Nov 2011 14:27:18,808] [main] [INFO] [::] [] Registering Security checkers...

      [10 Nov 2011 14:27:18,835] [main] [INFO] [::] [] Security checkers registered.

      [10 Nov 2011 14:27:18,835] [main] [INFO] [::] [] RBAC Service started.

      [10 Nov 2011 14:27:18,836] [main] [INFO] [::] [] Starting Schedule Service...

      [10 Nov 2011 14:27:18,836] [main] [INFO] [::] [] Schedule Service started.

      [10 Nov 2011 14:27:18,854] [Bl-Exec-11] [INFO] [::] [] BlExec worker thread started.

      [10 Nov 2011 14:27:18,888] [main] [INFO] [::] [] Starting SSLConnectionManager Service...

      [10 Nov 2011 14:27:18,900] [main] [INFO] [::] [] SSL-Connections is starting the worker threads

      [10 Nov 2011 14:27:18,904] [SSL-Connections-Thread-0] [INFO] [::] [] Client worker thread started.

      [10 Nov 2011 14:27:18,908] [SSL-Connections-Thread-2] [INFO] [::] [] Client worker thread started.

      [10 Nov 2011 14:27:18,908] [SSL-Connections-Thread-3] [INFO] [::] [] Client worker thread started.

      [10 Nov 2011 14:27:18,909] [SSL-Connections-Thread-4] [INFO] [::] [] Client worker thread started.

      [10 Nov 2011 14:27:18,909] [SSL-Connections-Thread-5] [INFO] [::] [] Client worker thread started.

      [10 Nov 2011 14:27:18,910] [SSL-Connections-Thread-6] [INFO] [::] [] Client worker thread started.

      [10 Nov 2011 14:27:18,910] [SSL-Connections-Thread-7] [INFO] [::] [] Client worker thread started.

      [10 Nov 2011 14:27:18,911] [SSL-Connections-Thread-8] [INFO] [::] [] Client worker thread started.

      [10 Nov 2011 14:27:18,911] [main] [INFO] [::] [] SSL-Connections is reserving the controlport

      [10 Nov 2011 14:27:18,911] [SSL-Connections-Thread-9] [INFO] [::] [] Client worker thread started.

      [10 Nov 2011 14:27:18,912] [main] [INFO] [::] [] SSL-Connections is establishing control connection...

      [10 Nov 2011 14:27:18,912] [Thread-19] [INFO] [::] [] SSL-Connections is waiting for control socket ...

      [10 Nov 2011 14:27:18,916] [SSL-Connections-Thread-1] [INFO] [::] [] Client worker thread started.

      [10 Nov 2011 14:27:18,920] [Thread-19] [INFO] [::] [] SSL-Connections accepted the control socket connection

      [10 Nov 2011 14:27:18,921] [main] [INFO] [::] [] SSL-Connections established control connection.

      [10 Nov 2011 14:27:18,931] [main] [INFO] [::] [] SSL-Connections is starting the selector

      [10 Nov 2011 14:27:18,931] [main] [INFO] [::] [] SSL-Connections is starting the acceptor

      [10 Nov 2011 14:27:18,932] [main] [INFO] [::] [] SSLConnectionManager Service started.

      [10 Nov 2011 14:27:18,932] [main] [INFO] [::] [] Starting Job Manager...

      [10 Nov 2011 14:27:21,368] [Job-Execution-0] [INFO] [::] [] Job executor processor thread started.

      [10 Nov 2011 14:27:21,385] [Job-Execution-2] [INFO] [::] [] Job executor processor thread started.

      [10 Nov 2011 14:27:21,389] [Job-Execution-1] [INFO] [::] [] Job executor processor thread started.

      [10 Nov 2011 14:27:21,390] [Job-Execution-4] [INFO] [::] [] Job executor processor thread started.

      [10 Nov 2011 14:27:21,392] [Job-Execution-3] [INFO] [::] [] Job executor processor thread started.

      [10 Nov 2011 14:27:21,397] [main] [INFO] [::] [] Starting Work Item Service...

      [10 Nov 2011 14:27:21,398] [main] [INFO] [::] [] Using storage location: /exec/applis/BLAAS1/NSH/tmp/application_server/59555aa4-0dbc-495a-ac5e-b9d9970c3b44 for work item caching.

      [10 Nov 2011 14:27:21,436] [WorkItem-Thread-1] [INFO] [::] [] Work item thread started.

      (...)

      [10 Nov 2011 14:27:40,006] [main] [INFO] [::] [] Registering remote services...

      [10 Nov 2011 14:27:40,007] [main] [INFO] [::] [] Shutdown processes complete

      [10 Nov 2011 14:27:40,015] [Thread-0] [INFO] [::] [] Undeploying

      [10 Nov 2011 14:27:40,016] [Thread-6] [INFO] [::] [] WSAuthenticationModule.shutdown

      [10 Nov 2011 14:27:40,095] [Thread-0] [ERROR] [::] [] java.rmi.NotBoundException: bladelogic.service.AppServerService

       

       

      Now appserver failed to start with a "java.rmi.NotBoundException", it's ok if I disable webservices on blasadmin

       

      The Bl appserver Version is 8.1 SP2P5 (release 265)

       

      The system Application server Version is :

       

      Linux opblaa01 2.6.9-42.ELsmp #1 SMP Wed Jul 12 23:27:17 EDT 2006 i686 athlon i3 Red Hat Enterprise Linux AS release 4 (Nahant Update 4)

       

       

      Does anyone have any idea resolving this Issue ?I understand that there are two means of accessing web services (SOAP Web Services & RESTful Web Services) but in my case, none of them is available as appserver does not start.

       

      Let me know if you need further info

       

       

      Thanks and regards,

      Jean-Philippe