1 2 3 Previous Next 32 Replies Latest reply on Oct 25, 2011 12:50 PM by Bill Robinson

    blcontent error

      Trying to load blcontent on a v8 server.


      App server is running and I can connect to it via the console from a remote machine.


      Attached is a screenshot, as I wasn't sure what file the error would write to when it happened.


      Tried to open a support ticket, but I could not attach the file (it fails upon attempt).


      Would like to contribute to the community once I get through the initial install.


      Thank you in advance,


        • 1. blcontent error

          I don't see a screenshot.

          • 2. Re: blcontent error

            The upload of the file errored out.  I'll try again ...

            • 3. Re: blcontent error
              Bill Robinson

              you have to paste it into the post, you can’t attach here.

              • 4. blcontent error

                I apparently have a java error somewhere.  Not only does blcontent blow up on the error, but I see lines and lines of text in my appserver log similar to this: [20 Sep 2011 16:07:59,926] [Scheduled-System-Tasks-Thread-1] [INFO] [System:System:] [Memory Monitor] Total JVM (B): 329023488,Free JVM (B): 119611616,Used JVM (B): 209411872,VSize (B): 457605120,RSS (B): 351952896,Used File Descriptors: 2231 Is there a java heap setting that normally needs to be tweaked?  Or any other ideas? Thank you, Dave

                • 5. blcontent error

                  Sorry for the poor format.  I had to change from html in order to paste the text into the reply.

                  • 6. blcontent error

                    That is normal memory usage stuff. That is not an error message.

                    • 7. Re: blcontent error
                      Bill Robinson

                      Those messages are the normal monitoring messages from the appserver, they are not an error.


                      It looks like it has only 300m of heap?

                      • 8. Re: blcontent error
                        Bill Robinson

                        Can you cut and paste the text of the blcontent error?

                        • 9. blcontent error

                          What log file would it write to?  I tried to redirect it to a text file, checked appserver log, and looked at the other text files, but I don't see it anywhere.  Obviously, a newbie.

                          • 10. blcontent error

                            capture your screen and paste it into the post. Don't attach it.

                            • 11. Re: blcontent error
                              Bill Robinson

                              What’s in the console when you run it?  can you just cut and paste from there?


                              Or ./blcontent > blah 2>&1

                              • 12. Re: blcontent error

                                Due to some security restrictions, screen scraps from the server are a pain.  Here is the text. [20 Sep 2011 16:23:05,207] [main] [INFO] [::] [] Initialized JNI library BlAsJni [20 Sep 2011 16:23:05,223] [main] [INFO] [::] [] Initialized JNI library XJNISer vice [20 Sep 2011 16:23:05,223] [main] [INFO] [::] [] Initialized JNI library Atrium Core [20 Sep 2011 16:23:05,223] [main] [INFO] [::] [] JNI Configuration complete. [20 Sep 2011 16:23:05,239] [main] [INFO] [::] [] Starting Model Graph Service... [20 Sep 2011 16:23:09,879] [main] [INFO] [::] [] Model Graph Service started. [20 Sep 2011 16:23:09,879] [main] [INFO] [::] [] Starting Non-Network Directory Service... [20 Sep 2011 16:23:09,879] [main] [INFO] [::] [] Non-Network Directory Service s tarted. [20 Sep 2011 16:23:09,879] [main] [INFO] [::] [] Starting Non-Network Management Service... [20 Sep 2011 16:23:09,879] [main] [INFO] [::] [] Non-Network Management Service started. [20 Sep 2011 16:23:09,910] [main] [INFO] [::] [] Starting Port Provider... [20 Sep 2011 16:23:09,910] [main] [INFO] [::] [] Port Provider started. [20 Sep 2011 16:23:09,942] [main] [INFO] [::] [] Starting Sizing Service... [20 Sep 2011 16:23:09,942] [main] [INFO] [::] [] Sizing Service started. [20 Sep 2011 16:23:09,942] [main] [INFO] [::] [] Starting Caching Service... [20 Sep 2011 16:23:09,942] [main] [INFO] [::] [] Caching Service started. [20 Sep 2011 16:23:09,942] [main] [INFO] [::] [] Starting Session Service... [20 Sep 2011 16:23:09,957] [main] [INFO] [::] [] Session Service started. [20 Sep 2011 16:23:09,973] [main] [ERROR] [::] [] Error installing to Configured : name=bladelogic.service.AsDataSourceService state=Instantiated java.lang.IllegalArgumentException: Null value metadata         at org.jboss.kernel.plugins.config.Configurator.getPropertySetterJoinPoi nt(Configurator.java:487)         at org.jboss.kernel.plugins.config.Configurator.getPropertySetterJoinPoi nt(Configurator.java:434)         at org.jboss.kernel.plugins.config.Configurator.getPropertySetterJoinPoi nts(Configurator.java:398)         at org.jboss.kernel.plugins.config.AbstractKernelConfigurator.getPropert ySetterJoinPoints(AbstractKernelConfigurator.java:112)         at org.jboss.kernel.plugins.dependency.KernelControllerContextActions$Co nfigureAction.installAction(KernelControllerContextActions.java:313)         at org.jboss.kernel.plugins.dependency.KernelControllerContextActions$Ke rnelControllerContextAction.install(KernelControllerContextActions.java:147)         at org.jboss.dependency.plugins.AbstractControllerContextActions.install (AbstractControllerContextActions.java:51)         at org.jboss.dependency.plugins.AbstractControllerContext.install(Abstra ctControllerContext.java:226)         at org.jboss.dependency.plugins.AbstractController.install(AbstractContr oller.java:593)         at org.jboss.dependency.plugins.AbstractController.incrementState(Abstra ctController.java:346)         at org.jboss.dependency.plugins.AbstractController.resolveContexts(Abstr actController.java:438)         at org.jboss.dependency.plugins.AbstractController.resolveContexts(Abstr actController.java:379)         at org.jboss.dependency.plugins.AbstractController.install(AbstractContr oller.java:225)         at org.jboss.dependency.plugins.AbstractController.install(AbstractContr oller.java:151)         at org.jboss.kernel.plugins.deployment.AbstractKernelDeployer.deployBean (AbstractKernelDeployer.java:291)         at com.bladelogic.app.service.bootstrap.ServiceBeanXMLDeployer.deployBea n(ServiceBeanXMLDeployer.java:38)         at org.jboss.kernel.plugins.deployment.AbstractKernelDeployer.deployBean s(AbstractKernelDeployer.java:261)         at org.jboss.kernel.plugins.deployment.AbstractKernelDeployer.deploy(Abs tractKernelDeployer.java:117)         at org.jboss.kernel.plugins.deployment.xml.BeanXMLDeployer.deploy(BeanXM LDeployer.java:91)         at com.bladelogic.app.service.bootstrap.ServiceBootstrap.deploy(ServiceB ootstrap.java:240)         at com.bladelogic.app.service.bootstrap.ServiceBootstrap.deployService(S erviceBootstrap.java:187)         at com.bladelogic.app.service.bootstrap.ServiceBootstrap.bootstrap(Servi ceBootstrap.java:141)         at org.jboss.kernel.plugins.bootstrap.AbstractBootstrap.run(AbstractBoot strap.java:91)         at com.bladelogic.app.service.bootstrap.ServiceBootstrap.startup(Service Bootstrap.java:66)         at com.bladelogic.mfw.fw.BlManager.startWithType(BlManager.java:576)         at com.bladelogic.mfw.fw.BlManager.startWithUtilType(BlManager.java:686)         at com.bladelogic.content.ContentMain.main(ContentMain.java:64) [20 Sep 2011 16:23:09,989] [main] [INFO] [::] [] Starting Task Scheduling Servic e... [20 Sep 2011 16:23:09,989] [main] [INFO] [::] [] Task Scheduling Service started . [20 Sep 2011 16:23:10,004] [main] [INFO] [::] [] Registering remote services... com.bladelogic.app.service.bootstrap.DeploymentException: com.bladelogic.app.ser vice.bootstrap.DeploymentException: Failed to deploy services: bladelogic.servic e.AppServerService bladelogic.service.AsDataSourceService bladelogic.service.AuthenticationSrpService bladelogic.service.CleanupService bladelogic.service.DatabaseService bladelogic.service.EventService bladelogic.service.FileManagerService bladelogic.service.NotificationService bladelogic.service.ObjectDeleterService bladelogic.service.RBACRoleService bladelogic.service.RBACService bladelogic.service.RBACUserService

                                • 13. Re: blcontent error

                                  Will try the command you posted to see if it's better.

                                  • 14. blcontent error

                                    Are you running this ON the appserver? Can you disable iptables, and try again?

                                    1 2 3 Previous Next