Errata are the security items that you need to patch.
What errors are you getting? Do you have a valid rhn account and is that configured in the patch catalog object?
Yes, we have valid rhn account and configured in patch catalog.
It shows updated matadata for Errata, downloaded few rpms but it fails in end with following error:
"Run at Sep 2, 2011 2:02:07 PM",Error,"Sep 2, 2011 6:23:44 PM","Error occured while yummifying repositories, Error: Cannot install/update createrepo-0.4.6-1 and python-urlgrabber-2.9.6-1.2. Please ensure that either lower versions are installed or remove higher versions if they exist. Error code: 3, Error: warning: /data/PatchStore/catalog_2001404/createrepo-0.4.6-1.el4.rf.noarch.rpm: Header V3 DSA signature: NOKEY, key ID 6b8d79e6
package python-urlgrabber-3.1.0-2 (which is newer than python-urlgrabber-2.9.6-1.2.el4.rf) is already installed
after this it shows new patches added, updated etc.
The errors you are getting are not related to the patch type - Errata or update level.
A Patch catalog job runs createrepo ( a linux tool to get repositories in a format understood by yum), before running it if it finds that there is no createrepo on the system ( the linux system specified as destination repo directory), the patch catalog tries to install createrepo-0.4.6-1, and its dependencies.
In your case, it looks like that the dependency python-urlgrabber is installed at a higher version.
To resolve this you have two choices :-
1. Remove this higher version of python-urlgrabber - I will not do this as this package might be in use for some other things on the system.
2. Install createrepo manually on the system , a version that is compatible with the already installed dependencies.
I will recommend this.
Hope this helps.
Thanks Bill and Rohit.
are you using one of the pre-created catalogs that is created as part of 'blcontent' ?