9 Replies Latest reply on Jun 20, 2011 3:37 PM by sandman1 NameToUpdate

    upgrade to 8.1 on windows 2003

      Hi I recently upgraded to 8.1 SP1 from 8.0 on w2k3 and i cannot start the app server service. The file server is on the same box and is licensed. In the logs it complains that it cannot find the bladelogic.keystore file in the deployments subfolders which is accurate, that file is not there. My question is why and how can I generate it. Under deployements folder i have _spawner, _launcher, _postmig and _template... no _default folder. not sure if that is related. when i log in as blasadmin it shows me that it is using _template at the prompt. any thoughts?

      thanks

        • 1. Re: upgrade to 8.1 on windows 2003
          Bill Robinson

          Is there a deployment_upgrade.log in ‘br’ ?  are there errors in that file?

          • 2. upgrade to 8.1 on windows 2003

            yes here is the log there are some errors in it regarding the keystore:

            [17 Jun 2011 09:44:54,709] [main] [INFO] [::] [] Starting Model Graph Service...

            [17 Jun 2011 09:44:56,505] [main] [INFO] [::] [] Model Graph Service started.

            [17 Jun 2011 09:44:56,505] [main] [INFO] [::] [] Registering remote services...

            [17 Jun 2011 09:44:56,505] [main] [INFO] [::] [] Remote services registered.

            [17 Jun 2011 09:44:56,505] [main] [INFO] [::] [] Performing post-deployment operations...

            [17 Jun 2011 09:44:56,505] [main] [INFO] [::] [] Post-deployment operations completed.

            [17 Jun 2011 09:44:56,505] [main] [INFO] [::] [] Performing post-startup deployment operations...

            [17 Jun 2011 09:44:56,505] [main] [INFO] [::] [] Post-startup deployment operations complete.

            [17 Jun 2011 09:44:56,521] [main] [INFO] [::] [] Updating _launcher deployment

            [17 Jun 2011 09:44:56,537] [main] [INFO] [::] [] set AppServerLauncher KeyStorePassword to ALNXLTUPZUWLMKUOXQKZUVOZKNXQEQVLKXPOEKOKNEEKLVTQPXNNLOAQPMKMVUQN (was ALNXLTUPZUWLMKUOXQKZUVOZKNXQEQVLKXPOEKOKNEEKLVTQPXNNLOAQPMKMVUQN in new installation)

            [17 Jun 2011 09:44:56,709] [main] [INFO] [::] [] Updating _template deployment

            [17 Jun 2011 09:44:56,724] [main] [INFO] [::] [] set Database ConnectionString to  (was not previously set in new installation)

            [17 Jun 2011 09:44:56,724] [main] [INFO] [::] [] set Database DriverClass to  (was not previously set in new installation)

            [17 Jun 2011 09:44:56,802] [main] [INFO] [::] [] set Database Password to  (was not previously set in new installation)

            [17 Jun 2011 09:44:56,818] [main] [INFO] [::] [] set Database UserId to  (was not previously set in new installation)

            [17 Jun 2011 09:44:57,052] [main] [INFO] [::] [] set Database Password to  (was MUZUWUPAKZOEWELPUKNUMAZZOOZOBBMZXWXUABMZUUVQONMQOAQWNNVPOZTBAETB in new installation)

            [17 Jun 2011 09:44:57,240] [main] [INFO] [::] [] set AppServer CertPasswd to ALNXLTUPZUWLMKUOXQKZUVOZKNXQEQVLKXPOEKOKNEEKLVTQPXNNLOAQPMKMVUQN (was ALNXLTUPZUWLMKUOXQKZUVOZKNXQEQVLKXPOEKOKNEEKLVTQPXNNLOAQPMKMVUQN in new installation)

            [17 Jun 2011 09:44:57,334] [main] [INFO] [::] [] set AppServer MaxWorkItemThreads to 50 (was 5 in new installation)

            [17 Jun 2011 09:44:57,584] [main] [INFO] [::] [] Deployment upgrades completed successfully.

            [17 Jun 2011 09:44:57,584] [Thread-0] [INFO] [::] [] Undeploying

            [17 Jun 2011 09:44:57,584] [Thread-0] [INFO] [::] [] Stopping Model Graph Service...

            [17 Jun 2011 09:44:57,584] [Thread-0] [INFO] [::] [] Model Graph Service stopped.

            [17 Jun 2011 10:01:26,240] [main] [INFO] [::] [] Starting Model Graph Service...

            [17 Jun 2011 10:01:28,068] [main] [INFO] [::] [] Model Graph Service started.

            [17 Jun 2011 10:01:28,068] [main] [INFO] [::] [] Registering remote services...

            [17 Jun 2011 10:01:28,068] [main] [INFO] [::] [] Remote services registered.

            [17 Jun 2011 10:01:28,068] [main] [INFO] [::] [] Performing post-deployment operations...

            [17 Jun 2011 10:01:28,068] [main] [INFO] [::] [] Post-deployment operations completed.

            [17 Jun 2011 10:01:28,068] [main] [INFO] [::] [] Performing post-startup deployment operations...

            [17 Jun 2011 10:01:28,068] [main] [INFO] [::] [] Post-startup deployment operations complete.

            [17 Jun 2011 10:01:28,084] [main] [INFO] [::] [] Updating _launcher deployment

            [17 Jun 2011 10:01:28,115] [main] [INFO] [::] [] set AppServerLauncher KeyStorePassword to QEZOUBENBNZTEMVZPVLAOKPAUMOBTZPNWPANOOALKMKTAQEVEPPWEBBUTKPXMNQA (was ALNXLTUPZUWLMKUOXQKZUVOZKNXQEQVLKXPOEKOKNEEKLVTQPXNNLOAQPMKMVUQN in new installation)

            [17 Jun 2011 10:01:28,115] [main] [INFO] [::] [] bladelogic.keystore doesn't exist for deployment _launcher. Skipping...

            [17 Jun 2011 10:01:28,115] [main] [INFO] [::] [] Updated bladelogic.keystore for deployment _launcher

            [17 Jun 2011 10:01:28,115] [main] [INFO] [::] [] Copying AppServerLauncher-users.conf from C:\Program Files\BMC Software\BladeLogic\8.1\NSH\br\deployments\_old\_launcher to C:\Program Files\BMC Software\BladeLogic\8.1\NSH\br\deployments\_launcher

            [17 Jun 2011 10:01:28,115] [main] [INFO] [::] [] Updated AppServerLauncher-users.conf for deployment _launcher

            [17 Jun 2011 10:01:28,287] [main] [INFO] [::] [] Updating _template deployment

            [17 Jun 2011 10:01:28,287] [main] [INFO] [::] [] set Database ConnectionString to  (was not previously set in new installation)

            [17 Jun 2011 10:01:28,287] [main] [INFO] [::] [] set Database DriverClass to  (was not previously set in new installation)

            [17 Jun 2011 10:01:28,380] [main] [INFO] [::] [] set Database Password to BWMAAOPOKWKEKEZLXQVUAWVBOPKNTAVETNUXPXQWOZLLXAMAQEQEZBWVKPXNZMXN (was not previously set in new installation)

            [17 Jun 2011 10:01:28,380] [main] [INFO] [::] [] set Database UserId to  (was not previously set in new installation)

            [17 Jun 2011 10:01:28,615] [main] [INFO] [::] [] set Database Password to BWMAAOPOKWKEKEZLXQVUAWVBOPKNTAVETNUXPXQWOZLLXAMAQEQEZBWVKPXNZMXN (was BUNLWLZOEWNTNAQTANMOTLBWUOPAZZOKWZXLWEQKXVEBXWMZEKQMMZWXOXPAVXPA in new installation)

            [17 Jun 2011 10:01:28,802] [main] [INFO] [::] [] set AppServer CertPasswd to UBEQZTZXLPUMQUQPOWNAZKBETOBXMZXTMTZZBMQUWTNTLOXMZTBBUNXOAOEPLEEE (was ALNXLTUPZUWLMKUOXQKZUVOZKNXQEQVLKXPOEKOKNEEKLVTQPXNNLOAQPMKMVUQN in new installation)

            [17 Jun 2011 10:01:28,818] [main] [INFO] [::] [] Unable to find old value for Module: AppServer Option: ComponentHeaderCacheMaxSize

            [17 Jun 2011 10:01:28,818] [main] [INFO] [::] [] Unable to find old value for Module: AppServer Option: DaalPluginImportWaitTimeout

            [17 Jun 2011 10:01:28,896] [main] [INFO] [::] [] set AppServer MaxWorkItemThreads to 50 (was 5 in new installation)

            [17 Jun 2011 10:01:29,052] [main] [INFO] [::] [] Unable to find old value for Module: RBAC Option: mntWindowUpdateInterval

            [17 Jun 2011 10:01:29,052] [main] [INFO] [::] [] bladelogic.keystore doesn't exist for deployment _template. Skipping...

            [17 Jun 2011 10:01:29,052] [main] [INFO] [::] [] Updated bladelogic.keystore for deployment _template

            [17 Jun 2011 10:01:29,146] [main] [INFO] [::] [] Deployment upgrades completed successfully.

            [17 Jun 2011 10:01:29,146] [Thread-0] [INFO] [::] [] Undeploying

            [17 Jun 2011 10:01:29,146] [Thread-0] [INFO] [::] [] Stopping Model Graph Service...

            [17 Jun 2011 10:01:29,146] [Thread-0] [INFO] [::] [] Model Graph Service stopped.

            • 3. Re: upgrade to 8.1 on windows 2003
              Gerardo Bartoccini

              The upgrade process may have created some additional deployments.

              All of them need to have a file bladelogic.keystore under their root dir.

              E.g:

               

              bash-3.00# find . -name bladelogic.keystore -exec cksum {} \;

              2393277609      2027    ./br/deployments/_template/bladelogic.keystore

              2393277609      2027    ./br/deployments/_launcher/bladelogic.keystore

              2393277609      2027    ./br/deployments/default/bladelogic.keystore

              2393277609      2027    ./br/deployments/_old/_template/bladelogic.keystore

              2393277609      2027    ./br/deployments/_old/_launcher/bladelogic.keystore

              2393277609      2027    ./br/deployments/_old/default/bladelogic.keystore

              2393277609      2027    ./br/deployments/_spawner/bladelogic.keystore

              • 4. upgrade to 8.1 on windows 2003

                that's right that is the issue, there is no bladelogic.keystore in any of them...

                • 5. upgrade to 8.1 on windows 2003
                  Gerardo Bartoccini

                  If you had at least one, you could sync them by copying files over (provided that cert password is the same: see "Synchronizing Application Server keystore files" or something like this in the Admin Guide).

                   

                  It's quite weird you don't have any of them, but just in case I believe you can create one by using blmkcert. See documentation for this.

                  • 6. upgrade to 8.1 on windows 2003
                    Bill Robinson

                    You need to do the following:

                    1 - run: br/java/bin/keytool -genkey -alias blade -keyalg RSA -keysize 1024 -dname CN=<appserver> -keypass <passwd> -storepass <password> -keystore br/deployments/_template/bladelogic.keystore -validity 1000

                    to generate a new keystore

                    2 Stop the application server(s)

                    3 Move any directories from _old (NOT _template or _launcher) to the normal deployments directory overwriting any directory that was there. (but leave _old)

                    4 copy the _template/bladelogic.keystore (this should be the new one) to the other deployment dirs in deployments

                    5 use blasadmin and update the keystore passwd to what you just used for all the instances and _launcher

                    6. Re-run the Deployment Migrator, checking for failures in the br/deployments_upgrade.log

                    • 7. upgrade to 8.1 on windows 2003

                      gbartoccini: i ran the blmkcert command and it was successful. i then copied it over from the _template directory to the others. when i tried starting the appserver it now complains that the keystore has been tampered with or that the password is incorrect. i did double check the password so it's not that. well im going to uninstall and reinstall and see what happens.

                      • 8. Re: upgrade to 8.1 on windows 2003
                        Bill Robinson

                        You need to set the passwd to what you used in blmkcert in blasadmin.  and you need to follow the steps I posted to re-migrate the configs.

                        • 9. upgrade to 8.1 on windows 2003

                          Thanks for the input Bill. I reinstalled and now it works. not sure what happened the first time but I didn't get a chance to test your suggestion.