6 Replies Latest reply on Aug 14, 2011 2:52 PM by Barry McQuillan

    Simulate fails for BLPackage when trying to create directory in /

      Hi all,

       

      I'll be raising an issue for this as well, but I was wondering if anyone else has experienced this issue.

      Appserv 7.6.0.274

      Target Agent 235, 285 and 293 on both OS's

       

      I created a BLPackage that had one step, add dir /export/home.

      I created a solaris and a linux version of it.

      They all fail at the simulate phase with the same error message.

      05/11/11 09:12:19.371 INFO     bldeploy - Starting dryRun

      05/11/11 09:12:19.371 DEBUG   bldeploy - [0][] Dryrun id = 0

      05/11/11 09:12:19.371 DEBUG   bldeploy - [1][/a] Dryrun id = 1

      05/11/11 09:12:19.372 DEBUG   bldeploy - [1][/a] unixFileCreatePerms: /a

      05/11/11 09:12:19.372 DEBUG   bldeploy - [1][/a] Found directory: /a

      05/11/11 09:12:19.372 ERROR   bldeploy - [1][/a] PreCondition: Not authorized to create file /a: No such file or directory.

      05/11/11 09:12:19.372 ERROR   bldeploy - [1][/a] PreCondition "UnixFileCreatePerms" failed - Name = "/a"

      05/11/11 09:12:19.372 ERROR   bldeploy - Dryrun failed

      05/11/11 09:12:19.372 INFO     bldeploy - Unknown return code type for directory delete settings

      05/11/11 09:12:19.372 WARN     bldeploy - Deploy failed. Cleaning up staging area.

       

      The strange thing is that it works for any other directory except /.

      And if I disable simulate the package works perfectly.

       

      Any ideas?

       

      Cheers

       

      Barry