1 Reply Latest reply on Nov 10, 2011 12:55 PM by Narindra Jeethan

    prevent BL from reformatting xml config file

      Hi,

       

      I am new to BladeLogic and still learning the terms for BL. Forgive me if I don't explain the issue clearly or use the wrong term.

       

      I am using BladeLogic to install a MSI and update the config file, which is in XML format, for the MSI. The properties are setting correctly. However the format of the config file is getting mess-up. If I use BL to call a powershell script to set the properties, the format is correct.

       

      The config file has "
" which is reformatting the file.

       

      expected result

       

      <formatters>

            <add template="Timestamp: {timestamp}&#xD;&#xA;Message: {message}&#xD;&#xA;Category: {category}" type="Microsoft.Practices.EnterpriseLibrary.Logging.Formatters.TextFormatter, Microsoft.Practices.EnterpriseLibrary.Logging, Version=4.0.0.0, Culture=neutral, PublicKeyToken=*******************" name="Text Formatter" />

          </formatters>

       

      Result if BladeLogic set the properties without using powershell.

      <formatters>

            <add template="Timestamp: {timestamp}

      Message: {message}

      Category: {category}" type="Microsoft.Practices.EnterpriseLibrary.Logging.Formatters.TextFormatter, Microsoft.Practices.EnterpriseLibrary.Logging, Version=4.0.0.0, Culture=neutral, PublicKeyToken=*******************" name="Text Formatter" />

          </formatters>

       

      Any suggestion on how I could allow BL to pass the special characters?

       

      Thanks,