5 Replies Latest reply on Jul 16, 2014 4:45 AM by Rajeev Gupta

    blcli_execute error while caching

    Girish Tapare

      Hi,

       

      I am trying to create VM through SRM request. I have installed content & configured adapter as well. While running cache it shows error in arjavaplugin.log,

       

      2011-02-25 17:34:22,593 ERROR [Thread-2] com.bmc.sp.actions.util.DataPopulationThreadRunner (DataPopulationThreadRunner.java:183) - Cache failed.

      com.bmc.sp.ao.exceptions.AOException: AO Workflow execution failed.

      at com.bmc.sp.ao.BLWorkflow.executeCommand(BLWorkflow.java:88)

      at com.bmc.sp.actions.PopulateDeviceFormsAction.execute(PopulateDeviceFormsAction.java:48)

      at com.bmc.sp.actions.util.DataPopulationThreadRunner.cacheRunInSerial(DataPopulationThreadRunner.java:170)

      at com.bmc.sp.actions.util.DataPopulationThreadRunner.populateData(DataPopulationThreadRunner.java:151)

      at com.bmc.sp.actions.util.DataPopulationThreadRunner.run(DataPopulationThreadRunner.java:76)

      at java.lang.Thread.run(Unknown Source)

       

      Grid logs says,

       

      <metadata>
          <status>success</status>
        </metadata>
        <targets-output>
          <target-output>
            <metadata>
              <os-id>Windows Server 2008</os-id>
              <os-version>6.1</os-version>
              <os-arch>amd64</os-arch>
              <status>success</status>
            </metadata>
            <commands-output>
              <command-output>
                <metadata>
                  <command>blcli_execute ProvisionDevice listAllImportedDevices  </command>
                  <line-count>6</line-count>
                  <execution-milliseconds>457</execution-milliseconds>
                  <exit-code>1</exit-code>
                  <status>error</status>
                  <error>Exit code indicates error</error>
                </metadata>
                <output>
                  <line index="1">com.bladelogic.session.client.SessionLoginException: No cached Session Credential for named service profile - please login.</line>
                  <line index="2"> at com.bladelogic.cli.CliLoginOperations.getSessionCredentialFromCache(CliLoginOperations.java:192)</line>
                  <line index="3"> at com.bladelogic.cli.CliLoginOperations.obtainSessionCredential(CliLoginOperations.java:90)</line>
                  <line index="4"> at com.bladelogic.session.client.SessionLoginManager.connect(SessionLoginManager.java:160)</line>
                  <line index="5"> at com.bladelogic.session.client.SessionLoginManager.login(SessionLoginManager.java:89)</line>
                  <line index="6"> at com.bladelogic.cli.CLIMain.loginToAppServer(CLIMain.java:669)</line>
                </output>
              </command-output>
            </commands-output>
          </target-output>
        </targets-output>
      </bladelogic-response>

       

      If I try to execute above "blcli" command through nsh console it also shows same error, but I have cache credential through "blcred" command.

       

      I have tried to execute above blclci command with profile parameter eg. "blcli -v defaultProfile ProvisionDevice listAllImportedDevices"  it works & the same profile is used in BladeLogic adapter configuration.

       

      Coluld anybody help me on this.

       

      Thanks in Advance.