4 Replies Latest reply on Oct 30, 2013 10:55 AM by Murat Böyükbas

    Audit-Sync-Deploy doesnt behave as expected

    Koray Kusat

           Hi all,


      i have 2 servers which have same folders /dummy in their file systems. And they have 2 text files inside, /dummy/file1.txt and /dummy/file2.txt . When i run an audit on those folders i see they are identical. Then i changed the contents of file1.txt in server2, run an audit and saw these folders are not identical. I right clicked on the edited file1.txt in server2, choosed sync with master.It created a BLPackage and a deploy job. I run the deploy job, it finishes properly. But when i check the contents of file1.txt on server2 it's not changed. It seems the BLPackage part is problematic, the BLPackage log shows;


      Info    Jan 28, 2011 4:43:40 PM    Packaging started

      Info    Jan 28, 2011 4:43:41 PM    Done packaging

      Warning    Jan 28, 2011 4:43:40 PM    Unable to package file contents for '/dummy/file1.txt'


      But i can right click any file/folder on server1 and create a BLpackage and deploy without any problems. Did you have see any problem like that? What am i doing wrong?



        • 1. Audit-Sync-Deploy doesnt behave as expected
          Antonio Caputo

          I think this is because you didn't bring the file content in you audit job.

          To do this, check in the audit/snapshot tab of your audit job where you should see several check box.

          Look for Contents and flag it. Then rerun your test again.

          • 2. Audit-Sync-Deploy doesnt behave as expected
            Koray Kusat

            Thanks Antonio!


            you are right, the file content flag wasn't checked in the Audit options. I never thought to check it that because i thought it would set by the BLPackage (deploy file contents flag) option. But this flag is useless if you call BLPackage from Audit jobs.



            • 3. Re: Audit-Sync-Deploy doesnt behave as expected

              Hi, i hope i am at the right place here. It´s about another Audit-Sync issue.


              I want to check if all Export Files in our Environment (except Infrastructure Servers) are identical. So I have created a Audit against a Master Server with the correct exports file and run it against the target servers. I got a result and the count of servers who are not compliant. All fine.


              BUT, when I want to create an "Sync with Master" job, it doesnt. A popup opens where i can enter the name of the job, but when i finish this, no popup with the package delta options opens.


              However, when I run this audit against a Test Server Group with just a couple of Servers, the sync works as it should. Both groups (with all servers and with a couple of servers) include Servers which are not reachable (f.e. "No Authorisation to access host" issues), so this can´t be the reason.


              I have checked the Console log and found no error.


              Can you help ?

              • 4. Re: Audit-Sync-Deploy doesnt behave as expected

                By the way: this happens on 8.3.2, when your target server group has more than 50 servers included.


                We have opened a ticket on bmc on that topic.