6 Replies Latest reply on Jan 26, 2011 8:19 AM by Bill Robinson

    Handle soft link problem

    Mike Reider

      Hi all, I am running server build jobs, and most jobs work ok, but for 2 jobs I am getting this error when I run the batch job,


      Handle soft link problem : An error occurred while attempting to copy the file //blfileserv/e/bladelogic/NSH/storage/imported/1292272968787imported/1291997676882/installables/5081.1/win to //PODBLIDWEB01/temp/stage/219a62c7eb59374e85e05f017e1a5b42/23.1/win.: com.bladelogic.mfw.util.BlException: No such file or directory;Cannot access source file "//blfileserv/e/bladelogic/NSH/storage/imported/1292272968787imported/1291997676882/installables/5081.1/win"


      I checked server permissions, the file server has all my application servers listed in the exports file, also the users file has my username listed under the correct Role. The package that its trying to copy over to the target server is ok as well, not sure where this error is coming from.


      also, I checked the name of the installer, it has an ok length so I dont think the name of the installer is the issue.

        • 1. Handle soft link problem
          Mike Reider

          Seems like its failing on a particular instaler in the blpackage. One resolution is to open the blpackage, take out the installer and reimport that installer into the Depot, then add it back to the blpackage. Something gets corrupted on the file server, thats why this message comes up. I tried that and it ran fine afterward.

          • 2. Handle soft link problem
            Mike Reider

            ok we found the issue


            we have a blpackage that contains some registries, some depot files (.exe files) and depot software installers.


            when I migrated some of these depot files from Dev to Prod servers, for some reasons they are imported to depot w/o an error, but if you open each of those .exe files it shows up with "No such file or directory"


            You have to manually recreate these files in the console, going to New > File and then adding the contents, then saving the file. I dont know if this is the reason, but I have a suspicion that theres an anti-virus process thats killing these .exe files on import into Depot, but I couldnt confirm it, I havent seen any messages in teh Event viewer nor McAfee logs.


            Once these files are cleaned up and you can open them in the console itself, then if you update your blpackage to point to these new working files, the job should run ok. The Handle Soft link error usually means that an object within the blpackage does not physically exist on the fileserver, or its corrupted, the console is showing that its there, but in reality, its not on the fileserver.

            1 of 1 people found this helpful
            • 3. Handle soft link problem
              Mike Reider



              heres an example, double clicking on this sna3270.txt file brings up the depot error. The console is showing this txt file is there, but its not physically on fileserver. It needs to be recreated manually.




              2.  These 2 .exe files were not on file server but were referenced in BLpackage


              3. BLpackage referencing the 2 missing exe files. Exe files may be wiped off the fileserver due to anti-virus (unconfirmed)


              • 4. Re: Handle soft link problem
                Bill Robinson

                So do you think the issues were from a virus scanner, or is there something else?

                • 5. Re: Handle soft link problem

                  Can it be related to this issue fixed in the latest Patch?



                  When renaming a BLPackage, it is possible that the information

                  regarding the location of the package can get out of sync between the

                  BMC BladeLogic console and the File Server. This condition produces

                  an error when you re-open the BLPackage.


                  SP7 Patch 4

                  1 of 1 people found this helpful
                  • 6. Re: Handle soft link problem
                    Bill Robinson

                    It could be.