4 Replies Latest reply on Jan 11, 2011 5:43 PM by Barry McQuillan

    Solaris Patching using 10_recommended cluster not recognising LiveUpgrade patching

      Hi all,

       

      I am running through testing various configurations for patching Solaris using the Solaris Cluster option in Bladelogics 7.6.

      Patching active server, works fine (with or without zones).

      However patching using LiveUpgrade is not using LiveUpgrade at all.

      I have the following Server properties set:

      SOLARIS_ALTERNATIVE_BOOT_ENVIRONMENT = Sol10-patched1101

      SOLARIS_LIVE_UPGRADE = True

       

      lustatus shows that altboot name is correct:

      # lustatus

      Boot Environment           Is       Active Active    Can    Copy

      Name                       Complete Now    On Reboot Delete Status

      -------------------------- -------- ------ --------- ------ ----------

      first_env                  yes      yes    yes       no     -

      Sol10-patched1101          yes      no     no        yes    -

       

      When I run the Solaris_Patch_Cluster script the server has the following processes:

          root 21668 21665   1 09:39:44 pts/2       0:13 bltargetjobmanager -start -cmd "bldeploy Deploy-job-for-Solaris-10_recommended-

          root 26471 26382   1 10:04:43 ?           0:00 /sbin/sh /var/sadm/pkg/SUNWcacaort/install/i.none ENDOFCLASS

          root 27691 21676   0 10:01:33 console     0:00 bash

          root 21748     1   0   Nov 24 ?           8:18 ./snmpmagt /opt/bmc/Patrol3/Solaris210-sun4-64/lib/snmpmagt.cfg NOV

          root 26382 26379   0 10:04:43 ?           0:00 /usr/sadm/install/bin/pkginstall -O patchPkgInstall -O pkg-server-mode=timeout2

          root 26157 21690   0 10:04:38 ?           0:00 /usr/bin/ksh 2001782.1/10_Recommended/installcluster --s10cluster

      bmc_bpm 21743     1   0   Nov 24 ?         292:32 PatrolAgent -p 3191

          root 26159 26158   3 10:04:38 ?           0:02 /bin/ksh -hp /usr/lib/patch/patchadd -M /var/tmp/stage/Deploy-job-for-Solaris-1

          root 21665   560   0 09:39:44 ?           0:00 bin/rscd

          root 21690 21671   1 09:46:15 ?           0:03 /usr/bin/ksh 2001782.1/10_Recommended/installcluster --s10cluster

          root 21670     1   0 09:39:44 ?           0:01 /usr/nsh/sbin/bldeploy Deploy-job-for-Solaris-10_recommended-Patch-Cluster-2000

          root 26158 26157   1 10:04:38 ?           0:00 /usr/sbin/patchadd 123893-22

          root 26379 26159   0 10:04:43 ?           0:00 pkgadd -O patchPkgInstall -O nozones -O enable-hollow-package-support -S -n -a

          root 26244     1   1 10:04:41 ?           0:00 pkgserv -d /tmp/patchadd-580026159/123893-22.26159 -N pkgadd -P 26159

       

      I can't see any references to the LiveUpgrade environment.

      Has anyone else experienced this?

       

      Cheers

       

      Barry