12 Replies Latest reply on Jan 3, 2011 12:42 PM by Chris NameToUpdate

    Sun Fire x4170 Hangs on Gentoo32 boot

      I just got in some new hardware that I need to provision.  I've been provisioning HP 465c servers with Linux using the Gentoo32 boot file successfully.  Now, I'm running my first Sun Fire x4170 through the same boot process and am getting a hang.  (screenshot below) 


      The server boots to the PXE environment, loads the proper Gentoo boot files and then hangs as shown below.  Any ideas on where to start looking for a fix?  Any help is greatly appreciated.



        • 1. Re: Sun Fire x4170 Hangs on Gentoo32 boot
          Bill Robinson

          What version of bladelogic/provisioning files, and what version of Gentoo?

          • 2. Sun Fire x4170 Hangs on Gentoo32 boot

            The OM & PM are  The Provisioning Files are from  I'm not sure which version of Gentoo you mean, but I'm using the 32-bit boot image.  The image was generated on a RHEL 5.4 variant. 


            Here's a question from left field on this issue.  Will a server boot from a Gentoo boot image if it has NO hard drive space? 

            • 3. Re: Sun Fire x4170 Hangs on Gentoo32 boot
              Bill Robinson

              What version of Gentoo – 2008, 2009?  It might be that Gentoo does not support the hardware, or we need to pass some boot options, like disabling acpi or something.


              The Gentoo image should boot, even if there are no hard disks present.  The Gentoo image runs from memory.  It’s like a live cd or knoppix.

              1 of 1 people found this helpful
              • 4. Re: Sun Fire x4170 Hangs on Gentoo32 boot

                The Gentoo version is install-x86-minimal-2007.0-r1.iso.  (2007 32-Bit Release 1)

                • 5. Re: Sun Fire x4170 Hangs on Gentoo32 boot
                  Bill Robinson

                  Can you try a later version – I think we support 2008 or 2009 in the 7.6 prov files.  If anything try booting w/ the Gentoo image w/o any bladelogic modes to see if it’s a Gentoo issue.


                  Also, are you doing windows prov in this env?

                  1 of 1 people found this helpful
                  • 6. Re: Sun Fire x4170 Hangs on Gentoo32 boot

                    This has been very insightful.  I've begun dropping in new kernel/image files into a new boot folder I made.  (Parrallel to gentoo32)


                    I'm seeing the same error booting directly to unmodified gentoo boot files that I pull directly from the minimal ISO. 


                    When I drop in these same files from the OEL55 DVD (which boots/installs successfully), I get a normal boot.


                    I think this narrows my problem down to needing to find a compatible gentoo mimimalist file that will build from my environment and yet still allow a successful boot.  Troubleshooting this down will be sped up by first pulling the unaltered files direct from the ISO to check if they'll boot properly.  When (if) I find a set that boot properly, I'll run them through the gentoo boot image file process.  (mkgen2img.sh)


                    Let me know if I'm going down a wrong path.  I'll update this thread when I have definitave results.


                    Also, yes we build windows machines from this same environment.  Though, obviously, I've made a new datastore for the Linux install files. 

                    • 7. Re: Sun Fire x4170 Hangs on Gentoo32 boot

                      I've not found a single version of the Gentoo Minimal CD that will boot my target device when I just pull the gentoo and gentoo.igz file and try to boot direct with no BladeLogic customizations (modes?). 


                      • install-x86-minimal-2007 r1 - version I used successfully for HP servers, produces error on Sun Fire
                      • install-x86-minimal-2008.0.iso - produces the same error as 2007 (screenshot top of thread)
                      • <could not find any releases for 2009>
                      • install-x86-minimal-20101123.iso (and 20100216.iso) produce the error below.




                      Any ideas on where I go from here?  I don't think there are any Gentoo minimal images that I haven't tried. There seem to be a bunch of versions for 2010, but I tried the latest release <20101123> and the earliest I could get my hands on. <20100216>

                      • 8. Re: Sun Fire x4170 Hangs on Gentoo32 boot
                        Bill Robinson

                        What kind of SATA controller does the box use?  and does gentoo support it?


                        Googling for that error turns up a couple things to try:


                        1 - boot w/ mem-2048M

                        2 - boot w/ rootdelay=15s (or maybe more)

                        3 - find the sata driver for gentoo


                        Some other things to check/try:

                        1 - can you boot w/ the rhel/sles OS?

                        2 - do you use winpe in this env as well?  if so can you get winpe working w/ this hardware?  if so, boot winpe for the device to autoregister, and then use the 'skip linux pre-install' option during provisioning

                        3 - manually register the mac and use the 'skip linux' option

                        • 9. Re: Sun Fire x4170 Hangs on Gentoo32 boot

                          Is there a method of embedding linux drivers into the boot image similar to what is done for WinPE?  I don't see any reference to that in the standard documentation.  Is there a HOW-TO on this available somewhere?


                          I'd also like to ask for more information regarding the kernel commandline parameters.  I'm doing some testing on those myself, but running into mixed results.  Is there an example somewhere or that you could supply with the suggested alterations in place?  (checking syntax)


                          I really appreciate the help you've been giving. 


                          Message was edited by: Chris -> question clarification and additions

                          • 10. Re: Sun Fire x4170 Hangs on Gentoo32 boot

                            I have an interesting update to throw at this discussion.  As I had mentioned, I had succesfully used the gentoo-minimal-2007-r1.iso image to boot and provision HP 465c servers.


                            Instead of pulling the kernel and boot image out of the ISO and presenting those boot files to the target server via the normal PXE boot process, I presented the entire gentoo-minimal.iso to the server as a virctual CD.


                            The target server fully booted to the prompt.


                            livecd root #


                            To review: I present the entire gentoo minimal 2007 ISO as a virtual CD and the system boots as expected.  If, however, I boot it via PXE using the gentoo32 files that were generated using the mkgen2img.sh process, it errors out in the screenshot at the top of this thread.  (The same boot files that provision HP 465's successfully)


                            Why is this happening? 

                            • 11. Re: Sun Fire x4170 Hangs on Gentoo32 boot



                              I reported this same error to support earlier this week. 

                              The first problem I had was with the version of squashfs - this was resolved by downloading version 4.1 from sourceforge and compiling it myself.  After getting past that error with the script, I came across the same error you see above.  This happens for either VMs or physical (HP DL series) servers. 


                              I'm waiting on an answer from Stephan on this one .... the unmodified Gentoo files do seem to complete the boot process on my test boxes. 


                              All I wanted for Christmas was a provisioning job that completed without errors!

                              • 12. Re: Sun Fire x4170 Hangs on Gentoo32 boot



                                Notes on my successful troubleshooting path below for future referece:

                                1. Skip Linux Pre-Install worked to get me past the Gentoo bugs/problems/etc
                                  1. The key to getting Skip Linux Pre-Install to work is to start the provisioning job BEFORE you PXE boot the server. 
                                  2. The provisioning job should advance to step 13 "Making run once" and hang there for a bit.
                                  3. Boot the target device.
                                  4. The job will begin advancing again after the system boots to the proper boot files. **Note1

                                After the Skip Linux Pre-Install bit was sorted out, the rest of my problems were hardware specific.

                                  1. The x4170 we're using registers EIGHT (8) eth devices during a Linux boot.
                                    1. I found this out by entering a rescue mode (described below).  During that boot, it asked me if I wanted to configure and bring up any network devices.
                                    2. I said that I did and found there to be a total of 8 devices to attempt to configure.
                                    3. I selected each one, one at a time, taking note of the MAC address listed for each device.
                                    4. Once I found the device that listed the MAC address that was hitting my DHCP/PXE server, I took note.  (eth4 in my case)
                                  2. I entered a "rescue" mode and mapped out each of the devices and found my target NIC device was eth4.  (Update this setting in the system package.)
                                    1. To do this: I mounted the Oracle Enterprise Linux installation DVD as a virtual drive.
                                    2. Once it booted, I could select from a few different boot configurations. 
                                    3. I selected the "rescue" kernel by telling the CD to boot: "linux rescue"
                                  3. While in the rescue mode, I went ahead and destroyed any existing partition tables and MBR entries to ensure a clean install try.
                                    1. fdisk /dev/sda (type m for help, follow the prompts to delete partitions, write new table data and exit)
                                    2. MBR was a little trickier:
                                      1. dd if=/dev/zero of=/dev/hda/ bs=446 count=1
                                      2. dd if=/dev/zero of=/dev/hda/ bs=512 count=1
                                      3. The bs=446 is *supposed* to just take out the grub boot information in the mbr
                                      4. The bs=512 line will take out all MBR information, including partition tables that start after byte 446.  (I went with this option *AFTER* I had already cleared out my partition information using the fdisk commands above.)



                                In my case, I had to create a completely new system package type since I was upgrading to a new version of Linux as well as moving to new hardware.  When creating a new system package type, be sure to pull the boot files from the install media for your target Linux Version. (and create a new "OS Installer Location" inside your tftproot\X86PC\pxelinux directory)  The beauty of this is that if your target OS will boot your target device, then the Skip Linux Pre-Install method should work.