6 Replies Latest reply on Dec 22, 2010 4:32 PM by claudio NameToUpdate

    error executing nexec

      Hi all,


      trying to get a machine to be added to a domain from AO. the command is :



      /opt/bmc/ao/BladeLogic/8.0/NSH/bin/nsh -c "/opt/bmc/ao/BladeLogic/8.0/NSH/scripts/nexec targetserver netdom join  targetserver /Domain:bmctest.ch /UserD:myuserid /PasswordD:Hello$$1"

      Logon failure: unknown user name or bad password.


      I get the unknown user name or bad password. When executing the same command on the target server itself, it works. Suspect it may be with the PasswordD having non alphanumeric characters, in this case $$ .


      What is the syntax that I shoudl be using in order to pass the $$ as valid password string?





        • 1. Re: error executing nexec

          Make sure to escape any spaces of special characters in your nexec command. Treat it like you would any normal shell command. Especially the dollar signs as those would be thought of as variable declarations.

          • 2. error executing nexec

            Hi Adam,


            thanks for reply.. would you mind giving me an example based on above, please


            opt/bmc/ao/BladeLogic/8.0/NSH/bin/nsh -c  "/opt/bmc/ao/BladeLogic/8.0/NSH/scripts/nexec targetserver netdom join   targetserver /Domain:bmctest.ch /UserD:myuserid /PasswordD:Hello$$1"



            • 3. Re: error executing nexec


              will try to spin my AO and BL environment up to test it out.  (the password would look something like Hello\$\$1) But, in the interim, can you please post the snippet of the rscd.log from your target machine?

              1 of 1 people found this helpful
              • 4. error executing nexec
                Wenchi Liao

                Maybe this will work?


                /opt/bmc/ao/BladeLogic/8.0/NSH/bin/nsh -c '/opt/bmc/ao/BladeLogic/8.0/NSH/scripts/nexec targetserver netdom join   targetserver /Domain:bmctest.ch /UserD:myuserid /PasswordD:Hello$$1'


                (note the single quote).


                I'm not familiar with the netdom command, but it looks like it is geared for a windows machine in a domain. Have you tried using the automation principal to run the netdom command using a domain user? You may be able to run netdom without having to pass in a username and password.

                1 of 1 people found this helpful
                • 5. error executing nexec

                  Hi Wliao,


                  tried your single quote and no luck... still got the same result, invalid username/pwd... I'll keep on searching but you have any other ideas, please let me know..



                  • 6. error executing nexec



                    The AO guy got it working..

                    He had to execute nexec from the command line (Commandline Adapter) instead of doing it from the nsh console (BladeLogic Adapter) and it works,




                    /opt/bmc/ao/BladeLogic/8.0/NSH/bin/nsh -c "/opt/bmc/ao/BladeLogic/8.0/NSH/bin/nexec targetserver netdom join targetserver /Domain:bmctest.ch /UserD:domainuser /PasswordD:Test\$\$1"



                    thanks for your feedback and hints.