8 Replies Latest reply on Dec 16, 2010 12:59 PM by Bill Robinson

    Error installing CIS template

    Jim Campbell

      Trying to install the CIS compliance template for windows 2003 server on a test system and I got the following.  There are no errors at all in the RSCD or application server logs.  Nothing else I can find is causing any encryption or 'Connection refused' errors.

       

      LOADING cis-win03 CONTENT
      APPSERVER: BLServApp1.the-domain.com
      Is this content install in a MAS (Multi App Server) setup ? [y/n] :n
      Extended Objects will be copied to //blservapp1.the-domain.com/c/Program Files/B
      MC Software/BladeLogic/8.0/NSH/storage//extended_objects
      App Server list:
      Starting import of cis-win03...
      Setting blcli option appserver_host to BLServApp1.the-domain.com
      Setting blcli option authType to BLSSO
      Setting blcli option serviceProfileName to defaultProfile
      Parsing: arguments
      Unable to append to file content-install.log: Connection refused
      //BLServApp1/e/cis-compliance-templates-8.0.0.49/ke-8.0.0/cis-compliance-content
      : Connection refused

      Unable to append to file content-install.log: Encryption configuration error

      Unable to append to file content-install.log: Connection refused
      //BLServApp1/e/cis-compliance-templates-8.0.0.49/ke-8.0.0/cis-compliance-content
      : Connection refused
      Done: arguments

      Setting blcli option appserver_host to BLServApp1.the-domain.com
      Setting blcli option authType to BLSSO
      Setting blcli option serviceProfileName to defaultProfile
      blcli call: blcli2 -Xmx512m  -v
      Import: grammars
      Command execution failed. com.bladelogic.mfw.util.BlException: Cannot use remote
      path for file transfer. Source path is: //BLServApp1/e/cis-compliance-templates
      -8.0.0.49/ke-8.0.0/cis-compliance-content/cis-win03-grammar/complianceini.gm
      mv: Unable to access file /C/Program Files/BMC Software/BladeLogic/8.0/NSH/scrip
      ts/complianceini.gm: No such file or directory
      Command execution failed. com.bladelogic.mfw.util.BlException: Cannot use remote
      path for file transfer. Source path is: //BLServApp1/e/cis-compliance-templates
      -8.0.0.49/ke-8.0.0/cis-compliance-content/cis-win03-grammar/complianceini.gm
      ERROR: blcli2 -Xmx512m  -v defaultProfile ConfigFileGrammar createConfigFileGram
      marOnFileServer ... complianceini.gm returned error code. Result is: Command exe
      cution failed.  Cannot use remote path for file transfer. Source path is: //BLSe
      rvApp1/e/cis-compliance-templates-8.0.0.49/ke-8.0.0/cis-compliance-content/cis-w
      in03-grammar/complianceini.gm
      Error running content-loader-pdq.nsh

       

      Error running cis-win03-install.nsh

        • 1. Error installing CIS template
          Gerardo Bartoccini

          First thing, you need to run the installer on the appserver.

          Is that what you are doing? In this case, there may be permissions issues at OS level.

           

          Anyway, can you run this on nsh?

           

          agentinfo BLServApp1

           

          and

           

          agentinfo BLServApp1.the-domain.com

          • 2. Error installing CIS template
            Jim Campbell

            I was running it on the appserver.  I tried to run nsh and blcred from a command prompt on the appserver originally, but when that didn't work i was using 'nsh here' from the Blade console to the app server.

             

            I'll post the results later (no access to this system where I am now), but when I did agentinfo BLServApp1 before nothing looked untoward.  The BladelogicRSCD user was mapped to the local administrator, the agent was licensed, and I even upgraded it from 8.0sp1 to 8.0sp6 so it would match the service pack level of the app server.  I didn't think to try it with the fully qualified domain name.  Using the same nsh window in which the above failures were generated (and hence hopefully the same credentials) I was able to move files around between the file server's nsh directory and the directory in which I unzipped the compliance templates.

            • 3. Error installing CIS template

              Typically a "connection refused" message means either the agent isn't running, or the server where you're trying to access the agent can't connect over the agent port possibly because of a firewall.

              • 4. Error installing CIS template
                Paul Seager-Smith

                Are you using client side certificates? If so, check the certificate config on the client (secure file and fingerprint).

                 

                Regards,

                 

                Paul

                • 5. Error installing CIS template
                  Jim Campbell

                  I can't get back to this test server until the weekend, but I was using SRP for authentication.  I don't pretend to understand the authentication blade uses, but i was opening up an nsh window using 'nsh here' with the appserver as the target and then executing the install scripts.  I was running the client from the appserver itself (or rather from a remote desktop session to the appserver).  I also tried using blcred from this window prior to running the script as well (which I assume was superfluous).  I could move files around on the server using the same window (copy from the CIS templates directory to the nsh directory e.g.).  I would assume that this would fail if the agent wasn't running or a firewall was involved.

                  • 6. Error installing CIS template
                    Bill Robinson

                    What content are you installing - the 'contrib content' or the supported content?

                    • 7. Error installing CIS template
                      Jim Campbell

                      Didn't know the difference until now.  I was trying to install from the zip files in the documents section of the Compliance forum.  I'm assuming now this is the 'contrib content' and after searching that I should be using the "Server Automation Compliance Content for Windows" from the EPD instead.  I'll try that and see if it helps.

                      • 8. Re: Error installing CIS template
                        Bill Robinson

                        That might be part of it but you should check a couple things:

                         

                        - run the installer (contrib or epd) as root/a Local Admin from the appserver box

                        - if you have multiple appservers make sure you are mapped to root/admin on the 2nd,3rd, Nth appservers.

                        - ditto on the bdssa server if you are installing the content reports