2 Replies Latest reply on Dec 13, 2010 2:34 PM by Roger May

    MSSQL deployment error through BladeLogic

    Roger May



      I've packaged MSSQL 2008R2 within BladeLogic (8 SP5). Package comprises of the source files and directories followed by .ini file and command line instruction to install


      The package installs manually  - i.e. I can send down the files and dirs via Blade and also the silent .ini file, and on the target server run the setup.exe command line. This installs ok, but when i do exactly the same but allow blade to also issue the setup.exe command line call, it starts the installation on the target server then fails with the following error in the summary.txt file:-


      Exception summary:
      The following is an exception stack listing the exceptions in outermost to innermost order
      Inner exceptions are being indented

      Exception type: Microsoft.SqlServer.Chainer.Infrastructure.ChainerInfrastructureException
              There was an error generating the XML document.
            DisableWatson = true
              at Microsoft.SqlServer.Chainer.Infrastructure.DataStoreService.SerializeObject(String rootPath, Object objectToSerialize, Boolean saveToCache)
              at Microsoft.SqlServer.Chainer.Infrastructure.DataStoreService.SerializeObject(Object objectToSerialize)
              at Microsoft.SqlServer.Chainer.Infrastructure.InputSettingService.SaveInputSettingValueToObject(InputSettingInfo inputSettingInfo, List`1 values)
              at Microsoft.SqlServer.Chainer.Infrastructure.InputSettingService.SaveParsedArgumentsIntoInputSettingStore(InputSettingSource source, Dictionary`2 parsedArguments, Boolean chainerSetting, Boolean ignoreSettingsForNotAllowedScnearios)
              at Microsoft.SqlServer.Chainer.Infrastructure.InputSettingService.ProcessCommandLineArguments(String[] commandLineArguments, Boolean chainerSetting)
              at Microsoft.SqlServer.Configuration.BootstrapExtension.ProcessFeatureCommandLineArgumentsAction.ExecuteAction(String actionId)
              at Microsoft.SqlServer.Chainer.Infrastructure.Action.Execute(String actionId, TextWriter errorStream)
              at Microsoft.SqlServer.Setup.Chainer.Workflow.ActionInvocation.ExecuteActionHelper(TextWriter statusStream, ISequencedAction actionToRun)
          Inner exception type: System.InvalidOperationException
                      There was an error generating the XML document.
                      at System.Xml.Serialization.XmlSerializer.Serialize(XmlWriter xmlWriter, Object o, XmlSerializerNamespaces namespaces, String encodingStyle, String id)
                      at System.Xml.Serialization.XmlSerializer.Serialize(TextWriter textWriter, Object o)
                      at Microsoft.SqlServer.Chainer.Infrastructure.DataStoreService.SerializeObject(String rootPath, Object objectToSerialize, Boolean saveToCache)
              Inner exception type: System.Security.Cryptography.CryptographicException
                              The system cannot find the file specified.
                              at System.Security.Cryptography.ProtectedData.Protect(Byte[] userData, Byte[] optionalEntropy, DataProtectionScope scope)
                              at Microsoft.SqlServer.Common.SqlSecureString.WriteXml(XmlWriter writer)
                              at System.Xml.Serialization.XmlSerializationWriter.WriteSerializable(IXmlSerializable serializable, String name, String ns, Boolean isNullable, Boolean wrapped)
                              at Microsoft.Xml.Serialization.GeneratedAssembly.XmlSerializationWriterSqlEngineSetupPublic.Write6_SqlEngineSetupPublic(String n, String ns, SqlEngineSetupPublic o, Boolean isNullable, Boolean needType)
                              at Microsoft.Xml.Serialization.GeneratedAssembly.XmlSerializationWriterSqlEngineSetupPublic.Write7_SqlEngineSetupPublic(Object o)


      Anyone seen this before?

      I assume this is an environmental issue, as we have exactly the same source and code installing manually, but failing through BL

      We have tried various options in the users.local file etc, to allow mapping to admin users other than administrator





        • 1. MSSQL deployment error through BladeLogic
          Paul Seager-Smith

          Not had experience with SQL 2008, but SQL 2005 always failed due to a lack of profile when run from within Bladelogic. It actually wants a profile for the BladeLogicRSCD during the install.


          SP8 and 8.1 should fix this properly, but you can try using Automation Principals with this to help get it working. If you set the automation principal to be the local administrator, the install will work correctly as it then really uses the local admin account rather than BladelogicRSCD and elevating privileges.


          The other alternatives are kludgy and involve using tools such as psexec to run the install as the local admin. As I say, no guarantees for SQL 2008, but this does fix things for 2005, so it is worth a try.





          • 2. MSSQL deployment error through BladeLogic
            Roger May

            Hi Paul,


            Thanks for your reply. I have tried using automation principals, but still with the same result. One question though, there seems to be two ways to use automation principals - one is to map a role in RBAC to automation principals in Agent ACL, and the other is to create a server property and relate that to automation principals. Is one approach better than the other, for installing mssql ?


            If this continues not to work I guess I'll have to try psexec....